Asus Merlin on RT-AC86U - 2GHz network suddenly stops

MamaLing

Occasional Visitor
Hi Everyone!
I've recently purchased a Asus RT-AC86U router. Out of the box I installed Merlin's firmware (version 386.7_2). As I set up wireless networking, I realised a new feature (at least for me), "smart connect". I immediately turned off, because I have smart devices that can only handle 2.4 GHz connection and I didn't want to reconfigure all the devices, so I named the wifi networks as they used to be on my old router. Right now I have a 2 GHz and a 5 GHz network with corresponding names. I started noticing my smart devices aren't connected after random time intervals. Only rebooting the router helps. After reboot, everything is working as expected. My question is, how to troubleshoot this problem? I was thinking to create a separate 2.4 GHz IoT network, but apparently that feature isn't supported. In the mean time I turned "smart connect" on, however I didn't reconfigure my smart devices, hoping I could use a network with a name and password from my old router. Any help would be much appreciated!
 

Amiga

Occasional Visitor
2.4 GHz on the RT-AC86U can be hit or miss. I have one setup / location where I have the Merlin firmware reboot overnight because of an old IoT device losing connectivity after more than 24+ hours. A few recent threads on this model have mentioned reverting back to 386.5_2 to alleviate some anomalies they've found with 386.7_2.
 

OzarkEdge

Part of the Furniture
Hi Everyone!
I've recently purchased a Asus RT-AC86U router. Out of the box I installed Merlin's firmware (version 386.7_2). As I set up wireless networking, I realised a new feature (at least for me), "smart connect". I immediately turned off, because I have smart devices that can only handle 2.4 GHz connection and I didn't want to reconfigure all the devices, so I named the wifi networks as they used to be on my old router. Right now I have a 2 GHz and a 5 GHz network with corresponding names. I started noticing my smart devices aren't connected after random time intervals. Only rebooting the router helps. After reboot, everything is working as expected. My question is, how to troubleshoot this problem? I was thinking to create a separate 2.4 GHz IoT network, but apparently that feature isn't supported. In the mean time I turned "smart connect" on, however I didn't reconfigure my smart devices, hoping I could use a network with a name and password from my old router. Any help would be much appreciated!

Did you buy a new AC86U? Some early product had 2.4 radio issues.

Did you reset the firmware before you configured it?

Have you observed the 2.4 signal with a WiFi analyzer app to see that it is present and stable, not bouncing around?

Are you using a 2.4 fixed control channel (not Auto) at 20MHz bandwidth that is not competing with other WiFi of similar power on the same channel? Use a WiFi analyzer to see this.

Are you using a USB 3.0 device on the router that can create EMI with 2.4 client connections?

You should define a new 2.4 SSID and client connection to fully test that client with your new network... to clear any lingering client conditions. You can disable Smart Connect and still use same SSIDs (client band steers) or different SSIDs (user band steers/segregates) per band.

I would commission/vet new router hardware with stock ASUSWRT fw and until you actually need an Asuswrt-Merlin feature.

OE
 

Tech9

Part of the Furniture
I'm testing one new IoT device as we speak with the following fail-safe settings on the same AC86U router running Asuswrt 386_48260:

1667334280242.png


1667334318403.png


1667334403065.png


The channel - whatever works best in your Wi-Fi environment. Not necessarily 1-6-11. Do not click on Disable 11b button.
 

StrikerXXX

Occasional Visitor
I'm testing one new IoT device as we speak with the following fail-safe settings on the same AC86U router running Asuswrt 386_48260:

View attachment 45139

View attachment 45140

View attachment 45141

The channel - whatever works best in your Wi-Fi environment. Not necessarily 1-6-11. Do not click on Disable 11b button.
Could you post pictures of how you configure it at 5ghz? Comparing to the thread creator user issue, I have the same issues on 5ghz, 2.4ghz is working fine. I have an rt-ac68u v3.
 

r00t

New Around Here
Same issue, occasionally 2.4 GHz just disappears, rebooting fixes.

No meaningful information in the logs as far as I could tell.

Couldn't really find any other information but the box says it's a RT-AC86U manufactured in 2020. Merlin Firmware Version: 386.7_2, using SmartConnect (so only one SSID), MU-MIMO and IGMP Snooping enabled. Channel is auto, no USB devices, but set at USB 3.0. AiProtection and most of the other "extras" are also disabled, no add-ons installed.
 

MamaLing

Occasional Visitor
Did you buy a new AC86U? Some early product had 2.4 radio issues.

Did you reset the firmware before you configured it?

Have you observed the 2.4 signal with a WiFi analyzer app to see that it is present and stable, not bouncing around?

Are you using a 2.4 fixed control channel (not Auto) at 20MHz bandwidth that is not competing with other WiFi of similar power on the same channel? Use a WiFi analyzer to see this.

Are you using a USB 3.0 device on the router that can create EMI with 2.4 client connections?

You should define a new 2.4 SSID and client connection to fully test that client with your new network... to clear any lingering client conditions. You can disable Smart Connect and still use same SSIDs (client band steers) or different SSIDs (user band steers/segregates) per band.

I would commission/vet new router hardware with stock ASUSWRT fw and until you actually need an Asuswrt-Merlin feature.

OE
Thank you for your answer! I’m going to look into this!
 

drinkingbird

Very Senior Member
Do not click on Disable 11b button.

Is that specific to that router? I've been disabling B for over a decade and G for years now. If nothing else, to disable the ability for a modern client to connect at legacy data rates when it is nearly out of range. On my AC1900 it doesn't have that checkbox but I have it set to "N only" which is the same thing, no issues for several years.

I suppose "Auto" effectively does the same thing if it doesn't see any B or G devices, but I'd rather have it locked in.

I guess on an IOT specific router, leaving data rates as low as 1M enabled might be beneficial for outdoor lightbulbs or other stuff that is very weak signal, but I wouldn't want it on my main AP.
 

drinkingbird

Very Senior Member
Asuswrt specific. On some models/firmware you can't remove it and it creates connectivity issues.



Not the same thing. You allow N devices only to connect, but the AP is still aware of B/G network around.

Pretty sure the last time I scanned with it set this way there were no CCK rates and beacons were 6 meg which is how N only greenfield should be. I'll have to check again.
 

drinkingbird

Very Senior Member
Not a good idea. You never know if someone around is still using an old IoT device with G only support. Auto is good fail-safe setting.

I would rather my AP interpret that as noise rather than attempting to coexist and slowing down my network. By not allowing the CCK rates and keeping the beacons at 6.5M, the B and G devices (and A on the 5ghz band) won't see my SSID and won't even attempt to connect to it, and if the AP truly supports greenfield mode it will not see any A/B/G devices. Whether the Asus is doing this or not I need to recheck, but my Unifi AP definitely is and I have no issues with it running in this mode for years. If it weren't for my older TV, I'd have N disabled on 5Ghz too.

By running in this mode, auto channel selection does actually have benefits over static, at least on the Unifi AP it is very good at analyzing and picking the best channel, and the Asus seems to work fine that way too.
 

Tech9

Part of the Furniture
By running in this mode, auto channel selection does actually have benefits over static, at least on the Unifi AP it is very good at analyzing and picking the best channel, and the Asus seems to work fine that way too.

As long as your Wi-Fi environment is not a high-rise apartment building. The chase for "best" channel continues forever with no clear winners. Better lock the channel and others around on Auto will move away over time. There is no best or recommended settings.
 

drinkingbird

Very Senior Member
As long as your Wi-Fi environment is not a high-rise apartment building. The chase for "best" channel continues forever with no clear winners. Better lock the channel and others around on Auto will move away over time. There is no best or recommended settings.

I had locked channels for years but it got to the point where I was frequently having to analyze and change around as people moved in and out of the neighborhood, etc. Personally, I've found that Auto now gives a better experience especially if I have it bounce and rescan periodically. I've also noticed that many consumer routers even when set to Auto will always pick 6, or grab the same channel as you even though they're right nearby and wifi analyzer clearly shows there are other cleaner channels available. So other routers "moving away over time" has not been my experience.

I also used to be a strict 1-6-11 channel person for 2.4 but these days in even semi-dense residential areas, that just doesn't apply anymore. When you have control over the entire system and environment, it is best practice, but when it is a free for all, trying to adhere to that just gets you poor performance. There may very well be more usable bandwidth on 3 than 1 or 6, even with the dual overlap.

Maybe 801.11akldjfaklsjxcvlj will include a feature where all APs negotiate with each other and live harmoniously together.
 
Last edited:

Tech9

Part of the Furniture
and wifi analyzer clearly shows there are other cleaner channels available.

Wi-Fi analyzer app doesn't show available bandwidth per channel. It only shows how many radios are using the channel. How many are active? I'm surprised you're a network engineer and draw wrong conclusions. Last time for APs set @80MHz and now for the number of APs per channel.

that just doesn't apply anymore. When you have control over the entire system and environment

This is correct.
 

drinkingbird

Very Senior Member
Wi-Fi analyzer app doesn't show available bandwidth per channel. It only shows how many radios are using the channel. How many are active? I'm surprised you're a network engineer and draw wrong conclusions. Last time for APs set @80MHz and now for the number of APs per channel.



This is correct.

I didn't say app, you're the one drawing wrong conclusions. Want to rehash the locked channel width? You claim to work with only enterprise stuff but then seem to only know the behavior of a cheap home router. I let it go because it was a stupid argument going nowhere, but I guess you can't.

Your general attitude of superiority must be real fun for your coworkers.
 

Tech9

Part of the Furniture
Not fun at all. My IT support staff may have to find another job if they argue about something I can prove wrong in 10 seconds on the very same network they were hired to support.
 

drinkingbird

Very Senior Member
Not fun at all. My IT support staff may have to find another job if they argue about something I can prove wrong in 10 seconds on the very same network they were hired to support.

As usual with you, no point in continuing a stupid argument/size comparison/ego trip, if you want to believe your experience is consistent across every manufacturer and device and everybody but you is wrong, feel free.
 

Tech9

Part of the Furniture
if you want to believe your experience is consistent across every manufacturer

There is nothing to believe in here. Check it on your own AC1900. No, BCM4360 radio is not defective. I use major brands only. They work as it was described. All of them from $1300 AP down to $30 home router. As I said, it was surprising coming from someone who said is a network engineer. If you search Google you'll get Cisco examples of this exact scenario - 80MHz AP with 40MHz capable clients. Cisco is a small company somewhere in the US. Not sure is they follow the standards.

Here, "defective" Broadcom BCM4366E example:

1667604160145.png


1667604035966.png


2-stream N client on 5GHz with AP set on 80MHz wide channel.

Have a good weekend!
 
Last edited:

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top