What's new

Asus router not reconnecting automatically after connection outage.

  • SNBForums Code of Conduct

    SNBForums is a community for everyone, no matter what their level of experience.

    Please be tolerant and patient of others, especially newcomers. We are all here to share and learn!

    The rules are simple: Be patient, be nice, be helpful or be gone!

Vince Edwards

Occasional Visitor
For my main router I use a GT-AX11000 running Asuswrt - Merlin. Generally, everything works fine, including my 1Gb, symmetrical Fusion Fibre connection. However, within the last two months I have experienced two small-hours outages, presumably to do with ISP or network provider maintenance or faults. On both occasion, once the connection has been restored, my router failed to reconnect, presumably because it is not detecting the restored connection. To restore the connection I have had to manually perform a reboot. Obviously, this causes all sorts of problems if I am away from home, e.g. being unable to connect to my VPN server or Plex media server.

My question is this: Is there a setting in WAN settings, or elsewhere, that I should change so that the router automatically reconnects after network outages?
 
To confirm, you are not using Dual WAN are you?
What firmware is the router running?
If using Asus-Merlin firmware, are you running any add-on scripts?
If the router supports more than one WAN port (like configuring the 2.5GB port as a WAN port), which port is the WAN port?
Also check the upstream device from the router just in case the problem lies with the fiber ONT or broadband provider's gateway/router.
It might help if you post a screenshot of your router's GUI WAN page settings.

Normally the router should auto reconnect once it detects the upstream WAN connection.

PS: As a troubleshooting step, since your sig line indicates "3 iMesh nodes", does the issue persist if you do not have the "imesh nodes" connected to the main router?

If running Asus-Merlin firmware there might be a add-on script to trigger a reboot upon WAN loss. Check the scripts in the add-on subforum (or AMTM) if such a script exists.
 
To confirm, you are not using Dual WAN are you?
What firmware is the router running?
If using Asus-Merlin firmware, are you running any add-on scripts?
If the router supports more than one WAN port (like configuring the 2.5GB port as a WAN port), which port is the WAN port?
Also check the upstream device from the router just in case the problem lies with the fiber ONT or broadband provider's gateway/router.
It might help if you post a screenshot of your router's GUI WAN page settings.

Normally the router should auto reconnect once it detects the upstream WAN connection.
Sorry, I should have said. I have do have a dual WAN and am using a USB connection backup dongle with a mobile broadband SIM. Do you think this may be the problem? I have left it at the default setting.
 
Sorry, I should have said. I have do have a dual WAN and am using a USB connection backup dongle with a mobile broadband SIM. Do you think this may be the problem? I have left it at the default setting.
If you haven't done so already try trouble shooting without having Dual WAN enabled to see if the issue persists. In my personal experience Dual WAN sometimes gets flaky/wonky and doesn't always roll over to the second WAN connection or back to the main WAN connection when the main WAN comes back up.
 
If you haven't done so already try trouble shooting without having Dual WAN enabled to see if the issue persists. In my personal experience Dual WAN sometimes gets flaky/wonky and doesn't always roll over to the second WAN connection or back to the main WAN connection when the main WAN comes back up.
Thanks. I will disable dual WAN for now, to see what happens. I may have to wait a while, periodically check my TBB graph to see if there have been any outages. Meanwhile, are there optimal settings that reduce the likelihood of 'failover' not operating properly?
 
Meanwhile, are there optimal settings that reduce the likelihood of 'failover' not operating properly?
As suggested earlier, post a screen shot your router GUI WAN and Dual WAN settings. Others may be able to comment if they see something wrong with those settings.

If running Asus-Merlin firmware there is a add-on script that may be of interest if you are not already using it:
WAN Failover is designed to replace the factory ASUS WAN Failover functionality, this script will monitor the WAN Interfaces using a Target IP Address and pinging these targets to determine when a failure occurs. When a failure is detected in Failover Mode, the script will switch to the Secondary WAN interface automatically and then monitor for failback conditions. When the Primary WAN interface connection is restored based on the Target IP Address, the script will perform the failback condition and switch back to Primary WAN. When a failure is detected in Load Balancing Mode, the script will remove the down WAN interface from Load Balancing and restore it when it is active again.

Requirements:

- ASUS Merlin Firmware v386.9 or higher
- JFFS custom scripts and configs Enabled
- Dual WAN Enabled
- ASUS Factory Failover Disabled (Network Monitoring Options, Allow Failback Option under WAN > Dual WAN)
 
As suggested earlier, post a screen shot your router GUI WAN and Dual WAN settings. Others may be able to comment if they see something wrong with those settings.

If running Asus-Merlin firmware there is a add-on script that may be of interest if you are not already using it:
Thank you. I will attempt to apply that when I figure how to edit firmware script. I have never attempted that sort of thing before.

If there are no future problems I will keep dual WAN. Having said that, when in Spain for two weeks, just to be sure, I will disable it.
 
As suggested earlier, post a screen shot your router GUI WAN and Dual WAN settings. Others may be able to comment if they see something wrong with those settings.

If running Asus-Merlin firmware there is a add-on script that may be of interest if you are not already using it:
Here's my current settings for failover.
1717776472553.png
 
When I've used Dual WAN with a phone as backup, I found using only DNS to test the link state worked best for me.

Many people have had issues with Dual WAN and I can't say it's great yet it has gotten me through outages.
 
When I've used Dual WAN with a phone as backup, I found using only DNS to test the link state worked best for me.

Many people have had issues with Dual WAN and I can't say it's great yet it has gotten me through outages.
Thank you. I did wonder why we have the option for both methods. It seemed like a belt and braces approach, but I suppose it could be a case of overkill.
 

Latest threads

Support SNBForums w/ Amazon

If you'd like to support SNBForums, just use this link and buy anything on Amazon. Thanks!

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!

Staff online

Top