Asus router occasionally loses internet connectivity but ISP says everything is fine

  • SNBForums Code of Conduct

    SNBForums is a community for everyone, no matter what their level of experience.

    Please be tolerant and patient of others, especially newcomers. We are all here to share and learn!

    The rules are simple: Be patient, be nice, be helpful or be gone!


New Around Here

My ISP equipment (Fiber modem) is in bridge mode and my router works fine most of the time. However when I move things and accidentally unplug the router's power or ethernet, but plug it back in soon enough, the router loses internet no matter what I try. The ISP confirms that their equipment at my place is working fine (tech can connect to the internet remotely). The problem is in the last mile and ISP says they can't help with my router config. I have NOT done any special configuration on my router. Last time this happened, the only thing that fixed the issue was hard resetting the router. Update: this happened again today and reseting the ISP equipment (power toggle) fixed the problem. What I want is a permanent resolution or at least a clear explanation for why this happens.

More Details:

Router is Asus RT-AC86U. Connection diagram is:

RTR -- Wall socket -- ISP's equipment.

When this issue happens, I login to my router and it says connected and I can see a public IP. Sometimes it says disconnected. Both times though, the ISP confirms from their end that remoting into their equipment shows everything as working fine and internet capable. What finally fixed the issue was hard reseting my router (on another occasion when I wanted to avoid hard rseting my router, I tried power toggling their equipment and it worked.

The setup on my Asus Router:
I haven't done any complicated or custom setup - I have Just configured the 2.4G and 5G SSIDs. DHCP is auto and everything else is default. DNS is set to request from ISP.

What I have tried so far:

  • Doing a hard reset helped fix the issue.
  • I'm confident it can't be an issue with the cable or wall ethernet socket or wiring behind the wall since the tech came over and tested that last mile with his equipment and confirmed everything was fine.
  • I don't suspect the router since it is new and is on the latest firmware

My suspicion is that the router may not be sending the correct hello/request packets. Last time I was trying to set it up, I first connected my laptop directly to the wall. I connected my router after this (i.e unplugged the laptop and plugged in the router) and it worked fine. So I'm wondering if an end device such as a laptop triggers the right signals to the ISP equipment. I'm tempted to test it but also don't want to risk losing my internet again.

Other things I suspect:
  • Would moving to Merlin help? I had used Merlin in the past on a different Asus router when I had used advanced features. These days I don't bother about configs. But if Merlin is known to fix this issue, I don't mind loading it.
  • Would changing the router mode help? Maybe it ensures better compatibility with the ISP

Help me identify the issue so I can avert all the nerves and stress the next time this happens!


Asuswrt-Merlin dev
During the outage try pinging a remote IP, like If the ping is working, then your issue is probably with the DNS servers, try switching the WAN DNS from Auto to something like (Google) or (Cloudflare). I recently fixed a customer's micro-interruptions that way.

If the ping isn't working, then it's a routing issue, can be anywhere between the router and the ISP.


New Around Here
I’ll try that, thanks. If the ping works fine, are you saying to change the DNS from auto (ISP) to cloud flare/Google?

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!