1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
Dismiss Notice

Welcome To SNBForums

SNBForums is a community for anyone who wants to learn about or discuss the latest in wireless routers, network storage and the ins and outs of building and maintaining a small network.

If you'd like to post a question, simply register and have at it!

While you're at it, please check out SmallNetBuilder for product reviews and our famous Router Charts, Ranker and plenty more!

Asus RT-AC1200G+ - Media Bridge mode speed capped at 173.3 Mbps.

Discussion in 'ASUSWRT - Official' started by cobe1200, Jul 17, 2019.

  1. cobe1200

    cobe1200 New Around Here

    Joined:
    Jul 17, 2019
    Messages:
    4
    Hi! I just purchased the AC1200G+ to use as a WiFi client.

    My issue is that the web panel shows "Link rate" is capped at 173.3 Mbps which I'm disappointed with, as I can't use my internet connection at full speed. My other devices easily reach 400+ Mbps. The access point I'm connecting to is AirTies 4920.

    I tried manipulating the settings at /Advanced_Wireless_Content.asp but they don't seem to have any effect on the bridge mode. I uploaded the wireless log as an attachment.

    Firmware Version:3.0.0.4.382_51610

    Is there any way to increase the speed?
     

    Attached Files:

    Last edited: Jul 17, 2019
  2. L&LD

    L&LD Part of the Furniture

    Joined:
    Dec 9, 2013
    Messages:
    9,624
    That seems like you are connected to the 2.4GHz band.

    Try connecting to the 5GHz band instead. :)
     
  3. cobe1200

    cobe1200 New Around Here

    Joined:
    Jul 17, 2019
    Messages:
    4
    Thank you for your reply however that doesn't seem possible :(
    First, the wireless log states: 2.4 GHz radio is disabled. Second, The 5 GHZ network is under "_5ghz" suffix which can also be seen in the log.

    Looking forward to more ideas!
     
  4. L&LD

    L&LD Part of the Furniture

    Joined:
    Dec 9, 2013
    Messages:
    9,624
    Sorry, I don't download the log files. I'm just basing it on the connection rate you indicated.
     
  5. Domdus

    Domdus New Around Here

    Joined:
    Nov 23, 2018
    Messages:
    7
    Location:
    Europe
    Code:
    Chanspec: 5GHz channel 116 20MHz (0xd074)
    Looks like the channel width is limited to 20 MHz, that will be the limit of throughput. Make sure your Router (AirTies) allows a wider channel width - auto (20/40/80 MHz), or forced to be 80 MHz.
    Maybe you need to force it on the bridge as client as well (/Advanced_Wireless_Content.asp).

    In case of auto settings: If channel 116 is surrounded or overlapped by other wifi networks, it may falls back to 20 MHz because of interference. Try another more free channel range for 5 GHz then.

    BR
     
    L&LD likes this.
  6. cobe1200

    cobe1200 New Around Here

    Joined:
    Jul 17, 2019
    Messages:
    4
    There is no channel width setting on the AirTies, however it allowed me to change the channel. I set it to 108 and now the link speed is 780 Mbps which is really great!:cool:
    So weird other devices were able to negotiate better speeds on the auto setting (also there are no other networks in the 100-132 range).

    Thank you!

    PS

    That view doesn't seem to affect anything at all in bridge mode (besides the radio on/off). I also checked Merlin's source code (not sure if it's on par with asuswrt here) and it seems to ignore channel settings in this mode.
     
    Domdus likes this.
  7. cobe1200

    cobe1200 New Around Here

    Joined:
    Jul 17, 2019
    Messages:
    4
    Issues with the router continue. The device restarts every hour, at the 41st minute of an hour (9:41, 10:41, etc).
    My prime suspect is DHCP. At first I used DHCP and this was the hour lease expired. So I switched all IPs to static (my PC and Asus router) and it didn't solve the problem.

    Code:
    Jul 21 11:40:59 rc_service: psta_monitor 215:notify_rc restart_wlcmode 0
    Jul 21 11:40:59 FTP Server: daemon is stoped
    Jul 21 11:40:59 Samba Server: smb daemon is stoped
    Jul 21 11:40:59 kernel: gro disabled
    Jul 21 11:41:08 RT-AC1200G+: start httpd:80
    Jul 21 11:41:12 rc_service: psta_monitor 215:notify_rc restart_wlcmode 1
    Jul 21 11:41:12 FTP Server: daemon is stoped
    I tried stopping psta_monitor (service stop_psta_monitor) right before this happens but it didn't help.
    I noticed there's a setting to debug psta_monitor (nvram set psta_debug=1) but I've no idea where these logs are stored.

    Help appreciated :)

    PS Also if I were to replace the router, what other model should I try?

    EDIT #1

    https://serverfault.com/questions/880345/asus-ac5300-wpa2-enterprise-hourly-disconnection?rq=1

    Code:
    nvram set wl1_pmk_cache=1440
    nvram set wl1_net_reauth=86400
    Seems like this helped for now. I guess the device will loose connection every day but that's acceptable.
     
    Last edited: Jul 22, 2019