ASUS RT AC1900 Router w Netgear M1 issues

  • ATTENTION! As of November 1, 2020, you are not able to reply to threads 6 months after the thread is opened if there are more than 500 posts in the thread.
    Threads will not be locked, so posts may still be edited by their authors.
    Just start a new thread on the topic to post if you get an error message when trying to reply to a thread.

Bvoorhis

Occasional Visitor
I am running a Netgear Nighthawk M1 with a Verizon sim for data. If i connect my laptop directly to the M1 i have decent internet but can bypass the ttl to get great internet. I picked up a ASUS RT AC1900 flashed wrt update and partioned the jffs to run the internet through the router via ethernet for better speed and connection. Connecting the M1 to the AC1900 isn't occurring properly and i only get limited access. I'm sure i have a setting incorrect or something but cannot figure out what the issue is. Any direction is appreciated.
 

Bvoorhis

Occasional Visitor
I have enough access to log into the routers. At first i log into the netgear router and configure it. Then i connect the ethernet cable from the M1 to the Asus ac1900 and log into it. I configure the Asus and reboot and i can no longer access the m1 router and even using ethernet doesn't allow me to connect.
 

ColinTaylor

Part of the Furniture
How are you configuring the Asus? What changes are you making?
 

Bvoorhis

Occasional Visitor
I flashed the most recent firmware. I change the lan ip to 192.168.10.1. I change the ssh and jff settings so i can write the commands to access the ttl tables and change to 65. Essentially, i followed the Ogne Tech videos from YT.
 

ColinTaylor

Part of the Furniture
I flashed the most recent firmware. I change the lan ip to 192.168.10.1. I change the ssh and jff settings so i can write the commands to access the ttl tables and change to 65. Essentially, i followed the Ogne Tech videos from YT.
I suggest you undo all of those changes and go back to how the router was setup after you connected it to the Netgear for the first time.

Can you access the internet at this point?

Then log onto the Asus and enable the "Spoof LAN TTL" option. That does the same as that youtube video does.
 

Bvoorhis

Occasional Visitor
I suggest you undo all of those changes and go back to how the router was setup after you connected it to the Netgear for the first time.

Can you access the internet at this point?

Then log onto the Asus and enable the "Spoof LAN TTL" option. That does the same as that youtube video does.
If it's that easy I'm going to cry... tears of joy obviously. I'll try it.
 

ColinTaylor

Part of the Furniture
So, i have internet now but it's only 41ping .44Mbps down and .60 up.
What ping/speeds do you get when you plug your laptop into the M1 instead?

What IP address are you pinging?

If i connect my laptop directly to the M1 i have decent internet but can bypass the ttl to get great internet.
What does "but can bypass the ttl to get great internet" mean?
 
Last edited:

Bvoorhis

Occasional Visitor
What ping/speeds do you get when you plug your laptop into the M1 instead?
I'll usually get between 20-30Mbps at a 30-35 ping. I don't know what address it's pinging or how to check that.

Not really bypass but set the command in the ttl tables to 65 so the connecting doesn't get throttled.
 

ColinTaylor

Part of the Furniture
I'll usually get between 20-30Mbps at a 30-35 ping. I don't know what address it's pinging or how to check that.
It shows the address in the output of the ping command.

Is there any difference between enabling and disabling "Spoof LAN TTL" when connected to the Asus?

Not really bypass but set the command in the ttl tables to 65 so the connecting doesn't get throttled.
I meant what does "but can" mean? "I can", "I can't", "I want to", "I am", "How can I", etc?
 

Bvoorhis

Occasional Visitor
If I use an ethernet cable to connect my laptop directly to the Netgear M1 I get the 20-30Mbps at 35ping. I also get the same speeds and ping by connecting my laptop to my Netgear M1 wifi. The issue Im having is when I run the ethernet from the M1 into the Asus AC1900. At that point, all of my speeds drop to about a .5Mbps down regardless of weather Im running through the ethernet or connected to the wifi of the Asus. I have tried the TTL Spoof and it has the same result. I was watching a video on using Putty to change the TTL table value to 65 to assist in preventing the extreme throttling. I have changed my M1 router setup to use the IP Passthrough and disable DHCP. I spoofed TTL in the Asus router and the connection is below .5Mbps on the Asus wifi. If I connect my laptop to the Asus router with ethernet cable my ping is low 20s but the .3 up and .6dwn in just crazy low. Weather I "Extend TTL value" or "Spoof TTL value" or both, the speeds are still low.
 

Attachments

ColinTaylor

Part of the Furniture
OK thanks for the extra information.

As the router's built-in TTL options don't seem sufficient I suggest we proceed as I suggested in your previous thread:

Firstly turn off the router's TTL options to stop them interfering with what we're about to do.

Then SSH into the Asus and enter the following commands at the prompt. Do not reboot the router or apply any changes through the GUI otherwise the commands will be lost. Then test the speed of your client.
Code:
[email protected]:/# modprobe xt_HL
[email protected]:/# modprobe xt_hl
[email protected]:/# iptables -t mangle -A POSTROUTING -j TTL --ttl-set 65
If the speed is still slow just enter the last command again with a different TTL value.

P.S. The M1's pass-through mode sounds like a good thing to have enabled.
 

Bvoorhis

Occasional Visitor
OK thanks for the extra information.
As the router's built-in TTL options don't seem sufficient I suggest we proceed as I suggested in your previous thread:

Firstly turn off the router's TTL options to stop them interfering with what we're about to do.

Then SSH into the Asus and enter the following commands at the prompt. Do not reboot the router or apply any changes through the GUI otherwise the commands will be lost. Then test the speed of your client.
Code:
[email protected]:/# modprobe xt_HL
[email protected]:/# modprobe xt_hl
[email protected]:/# iptables -t mangle -A POSTROUTING -j TTL --ttl-set 65
If the speed is still slow just enter the last command again with a different TTL value.

P.S. The M1's pass-through mode sounds like a good thing to have enabled.
So do you want me to enable JFFS partitions?
 

Bvoorhis

Occasional Visitor
I apologize, Im not very good with computers so bare with me. Are you wanting me to use the Putty app to input this informtation for the JFFS or put the commands in
It doesn't matter for this test. But if you've installed Merlin's firmware the /jffs partition will already exist anyway.
I pasted your commands into the authorized keys section and the speeds increased a small amount then tried TTL=70 (28ping, .63up, .65dwn)
 

Attachments

ColinTaylor

Part of the Furniture
No, no, no.

Just use putty to log into the router and type those commands at the command prompt.
 

L&LD

Part of the Furniture

ColinTaylor

Part of the Furniture
<sigh> Try it without prompt prefix (I thought that was obvious):
Code:
modprobe xt_HL
modprobe xt_hl
iptables -t mangle -A POSTROUTING -j TTL --ttl-set 65
 

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top