Asus RT-AC3200 Smart Connect Rules Fine Tuning

  • ATTENTION! As of November 1, 2020, you are not able to reply to threads 6 months after the thread is opened if there are more than 500 posts in the thread.
    Threads will not be locked, so posts may still be edited by their authors.
    Just start a new thread on the topic to post if you get an error message when trying to reply to a thread.

dlandon

Regular Contributor
I am opening this thread to start a discussion on how Smart Connect Rues can be adjusted. I have spent some time trying different things and have come up with a good starting point for the Smart Connect Rules that work for me in my environment. These settings may not work for everyone. I have g and n devices. I do not have any AC devices. The devices range from Laptops, iPads, iPhones, and Android phones. In my experimentation, I have found that Apple devices are the most sensitive and disconnect the most. I believe that the reason some users see disconnects and others not as much is dependent on the wireless environment and interference. I have seen where the 2.4GHz channel switches to 40MHz width and back to 20MHz causing a disconnect on some Laptops.

Attached is a PDF of the AC3200 Smart Connect Rules page from my router. For those of you that can do some experimentation on your router, give my settings a try and see if it does not help with the disconnects.

I did an experiment and walked around the house with an iPad from a strong signal area to a weaker area. The iPad started out connected to the 5-2 band and when I went to a weak signal area, it changed to the 5-1 band. This is the way I would expect the iPad to act. The router and iPad will try to maintain a good connection. When I stay in one place, the iPad stayed connected to the 5-1 band.

Don't expect to walk around with a device and not disconnect at least once. The router and device will switch to the best channel available in that particular spot. If the 5-2 band is weak the device will go to the 5-1 band if it is stronger, and then to the 2.4 band if necessary.

I have no idea if my settings affect the load balancing on the channels. I don't have enough devices (or any AC devices) to test load balancing.

I think the bands are selected in the order 5GHz-2, 5GHz-1, and then 2.4GHz. The Smart Connect Rules then appear to set when the router will try to shift the device off one band and onto another. The rules consist of signal strength and speed settings.

You may want to adjust the settings called RSSI (I believe this acronym is something along the lines of Radio Signal Strength). This setting looks to be the signal strength threshold on the band that the router begins to look for another channel. Remember that the stronger signal is the less negative number as measured in dBi. i.e. -50dBi is a stronger signal than -70dBi.

EDIT: I have made some more adjustments to the settings. The attached PDF is updated to some more changes I've made. These settings allow devices to switch bands more like I would think it should operate. I don't see disconnects, but these settings may not be appropriate for all wireless environments.

Note: I'm fairly convinced that the 'Bandwidth Utilization' settings apply to Load Balancing when it is turned on. I haven't tried load balancing.

Edit: I've adjusted the RSSI on the 2.4GHz band to Less. Seems to move devices to 5GHz-2 more now.
 

Attachments

  • SmartConnectSettings.pdf
    160.3 KB · Views: 14,581
Last edited:

mutas

New Around Here
Thanks for posting your settings. What version of the firmware are you using? Your configuration screen looks different than mine (3.0.0.4.378_3883).

The PHY Rate Less/Greater fields in your pdf, for example are expressed as a single field with a Less/Greater dropdown menu. It also appears that I cannot enter negative numbers into any of the dB fields. And when hitting Apply, it sure doesn't look like the settings are accepted. That's a bummer.
 

dlandon

Regular Contributor
Firmware version

I'm on firmware version 3.0.0.4.378_4129.

Be sure Smart Connect is turned on.
 

Stephen

Occasional Visitor
I am opening this thread to start a discussion on how Smart Connect Rues can be adjusted. I have spent some time trying different things and have come up with a good starting point for the Smart Connect Rules that work for me in my environment. These settings may not work for everyone. I have g and n devices. I do not have any AC devices. The devices range from Laptops, iPads, iPhones, and Android phones. In my experimentation, I have found that Apple devices are the most sensitive and disconnect the most. I believe that the reason some users see disconnects and others not as much is dependent on the wireless environment and interference. I have seen where the 2.4GHz channel switches to 40MHz width and back to 20MHz causing a disconnect on some Laptops.

Attached is a PDF of the AC3200 Smart Connect Rules page from my router. For those of you that can do some experimentation on your router, give my settings a try and see if it does not help with the disconnects.

I did an experiment and walked around the house with an iPad from a strong signal area to a weaker area. The iPad started out connected to the 5-2 band and when I went to a weak signal area, it changed to the 5-1 band. This is the way I would expect the iPad to act. The router and iPad will try to maintain a good connection. When I stay in one place, the iPad stayed connected to the 5-1 band.

Don't expect to walk around with a device and not disconnect at least once. The router and device will switch to the best channel available in that particular spot. If the 5-2 band is weak the device will go to the 5-1 band if it is stronger, and then to the 2.4 band if necessary.

I have no idea if my settings affect the load balancing on the channels. I don't have enough devices (or any AC devices) to test load balancing.

I think the bands are selected in the order 5GHz-2, 5GHz-1, and then 2.4GHz. The Smart Connect Rules then appear to set when the router will try to shift the device off one band and onto another. The rules consist of signal strength and speed settings.

You may want to adjust the settings called RSSI (I believe this acronym is something along the lines of Radio Signal Strength). This setting looks to be the signal strength threshold on the band that the router begins to look for another channel. Remember that the stronger signal is the less negative number as measured in dBi. i.e. -50dBi is a stronger signal than -70dBi.

EDIT: I have made some more adjustments to the settings. The attached PDF is updated to some more changes I've made. These settings allow devices to switch bands more like I would think it should operate. I don't see disconnects, but these settings may not be appropriate for all wireless environments.

Note: I'm fairly convinced that the 'Bandwidth Utilization' settings apply to Load Balancing when it is turned on. I haven't tried load balancing.

Would you change the settings if you had a couple of AC devices?
 

dlandon

Regular Contributor
AC Settings

I would probably use the same settings for AC devices.

There is a setting called VHT that can be set for 'AC Only'. I believe this setting would direct only AC devices to the selected band.
 

Stephen

Occasional Visitor
Does that mean you could set up Smart Connect to switch all non AC devices between 2.4 and one of the 5 bands, while keeping the second 5 band restricted to only AC devices?
 

Stephen

Occasional Visitor
I am also curious if you have used the router without Smart Connect, and if so did you have no disconnect issues with it?
 

dlandon

Regular Contributor
Does that mean you could set up Smart Connect to switch all non AC devices between 2.4 and one of the 5 bands, while keeping the second 5 band restricted to only AC devices?

Since there is zero documentation on the Smart Connect settings, I can only guess, but that's what I would think would make sense. Direct all the AC devices to one of the 5GHz bands. That way all the same speed devices are on the same band.
 

dlandon

Regular Contributor
I am also curious if you have used the router without Smart Connect, and if so did you have no disconnect issues with it?

I've not had disconnects with Smart Connect on or off that I could not attribute to being too far out of range or weak signal as I adjusted the router antennas. I've had a few issues with iPads that switched too often that I seem to have solved with a network reset on the iPads. A little research on the Internet shows people having disconnects with iPads and iPhones.
 

Stephen

Occasional Visitor
I've seen that research too, which is a concern as my family has a couple of iPads. It seems that re-setting the wireless on the iPad's works for some but not others. Before I upgrade from my RT-N66 I'm hoping there is a fw that fixes the disconnect issues or someone figures out settings that resolve it. Hoping someone with issues tries your settings.
 

joe012594

Regular Contributor
Thought I'd chime in and give some feedback on this as I'm also curious about the Smart Connect settings and if they play any role in the wireless drops. Maybe if we could even enhance the feature based on each of our individual environments and needs. From what I've personally experienced, it looks like the answer to whether or not the drops are attributed to Smart Connect is both yes and no.

Based on my own tests of the default settings for Smart Connect, all clients start off on the 2.4GHz band when they initially connect. When the router detects that your device both has a signal level greater than -56dBm and can achieve theoretical speeds greater than 110Mbps, then it hands the device off to the first priority band, which is 5GHz-2. The 5GHz-2 band seems to indicate that clients with higher speed capabilities (433Mbps or greater) be preferred and lower speed clients (below 433Mbps) be handed off to 5GHz-1, based on the PHY rate setting of < 433Mbps. Clients incapable of both retaining theoretical speeds of 110Mbps and greater plus a signal level of -76dBm and greater will be handed off to 2.4GHz until those criteria are met and then the cycle continues.

With that being said, the 5GHz-2 band (designated for AC clients) appears to have major issues. None of my AC clients can retain a connection to it. The GUI indicates such on the main page in the clients section. They get handed off to another band, but then lose all wireless connection when doing so for about 5-10 seconds until they're finally dropped to the 5GHz-1 band with all of my other N only clients, which degrades speed performance for AC clients and causes congestion on that one single band. I did try the OP's settings provided in his attachment, but they didn't work well enough for my environment nor solve the issue of splitting up/separating N and AC clients between the 2 bands. Anyone else having issues or come up with some more stable settings?
 

shane69

New Around Here
Bounce Detect

Has anyone played around with the bounce detect settings? If we can find out what that means it might help with the time the device takes to reconnect.
Having problems only on iPhone and ipads. Sometimes the iPhone never reconnects.
 

Stephen

Occasional Visitor
Has anyone played around with the bounce detect settings? If we can find out what that means it might help with the time the device takes to reconnect.
Having problems only on iPhone and ipads. Sometimes the iPhone never reconnects.

Do you have Smart Connect turned on or off?
 

jerry6

Very Senior Member
With smart connect on is the change from one radio to the next instant , or is there a noticeable delay when it hands off to the next ?
 

dlandon

Regular Contributor
With smart connect on is the change from one radio to the next instant , or is there a noticeable delay when it hands off to the next ?

On my laptop, the switch is instantaneous. If I am streaming a video and it switches, I don't notice a delay or pause.

Our iPads are a bit different. They delay when they switch at times. From what I've read, it is the nature of the beast.
 

jerry6

Very Senior Member
On my laptop, the switch is instantaneous. If I am streaming a video and it switches, I don't notice a delay or pause.

Our iPads are a bit different. They delay when they switch at times. From what I've read, it is the nature of the beast.

Good to know , what clients you using on the laptops ?
 

RMerlin

Asuswrt-Merlin dev
On my laptop, the switch is instantaneous. If I am streaming a video and it switches, I don't notice a delay or pause.

Our iPads are a bit different. They delay when they switch at times. From what I've read, it is the nature of the beast.

What wireless interface does your laptop have?

I have a feeling that reliability with Smart Connect will depend heavily on what wireless clients you are using. I have a feeling that some will work better than others when it comes to seamless roaming (which is what Smart Connect is relying upon to work properly).
 

jerry6

Very Senior Member
Intel Centrino Advanced-N 6200 AGN.

Thanks , one day I'm going to have to try smart connect , most mine are older , 5000 series AGN , hope they are as quick switching .
 

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top