Asus RT-AC5300 lost all config - Cannot Upgrade / Downgrade firmware

MyMilou

New Around Here
Hello Community

My Asus RT-AC5300 suddenly lost all its config. Even the login and password went back to default. No one was in the configuration page or touching any buttons at the time.

I can access the webGUI and reconfigure it. However, before I do so I am trying to change the firmware from Merlin 386.7_2 to the most recent Asus firmware 300438648377.

Here is what i have tried so far
- Firmware upload via WebGui. Nothing happens.
- Rescue Mode: it fails every time at around 77%.
- Load firwware via FPTPT. Same result.
- Upload older versions of both Asus and Merlin firmware. Same results.
- Reset all settings via the WPS button, the WebGui and the reset button. The config disappears but I still can change the firmware.

What am I doing wrong?
 

Adooni

Senior Member
Did you tried CFE MiniWeb Server for firmware update? and use Firefox browser for it. Here https://oldwiki.archive.openwrt.org/doc/techref/bootloader/cfe at 1/3 page youthey show how this looks like. 1st reset NVRAM and then flash new firmware. To get to miniCFE take the same steps like for FR and set PC IP to 192.168.1.10 but when router is in Rescue Mode just use Firefox and put router IP 192.168.1.1.
 

MyMilou

New Around Here
@adoono
Did you tried CFE MiniWeb Server for firmware update? and use Firefox browser for it. Here https://oldwiki.archive.openwrt.org/doc/techref/bootloader/cfe at 1/3 page youthey show how this looks like. 1st reset NVRAM and then flash new firmware. To get to miniCFE take the same steps like for FR and set PC IP to 192.168.1.10 but when router is in Rescue Mode just use Firefox and put router IP 192.168.1.1.
Thanks for the info. Note that previously I tried something like this from the window command prompt: tftp -i 192.168.1.1 FW_RT_AC5300_300438648377.trx which did not work

Update 1
- Broadcom CFE miniWeb server connected to the router while in rescue mode using Firefox
- Selected the most recent ASUS firmware and click upload
- CFE loses connection within seconds and router power light (most left) flashes slowly
- Nothing else happens even after I left it for an hour. Still blinking light
- Turn off Router and back on, it boots as normal, but firmware is not updated

Update 2
- All firmware upgrade attempts were previously done with a downloaded files (.trx) with the router NOT connected to the internet
- Latest attempts were done with the router WAN configured and therefore internet access.
- As a result, upgrading the firmware to Latest ASUS WRT was successful
- And final upgrade to Merlin latest firmware

All is back to normal.
 
Last edited:

MyMilou

New Around Here
t
To anyone: after a week of back and forth with Asus Support, I still have no answers if I have a defective component or something else. Seems Asus Support is not equipped to diagnose issues beyond the Rescue Utility.
 
Last edited:

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top