Asus RT-AC5300 parental control problem


New Around Here
Morning all,

New here but after some advice, I have a RT-AC5300 router, I have several devices which have time restricted access (save my kids living on the net), but it seems to be playing up at the minute

Not allowing access to devices it should at times it should etc, I've tried resetting all the timings, rebooting but no joy

Latest firmware from asus installed, I've just read some thing about hardware acceleration so will try that later, also could try the Merlin firmware if anybody can confirm that works better?

Any other suggestions (apart from better parenting, staying up 24/7 watching them etc) would be very helpful

Failing that I'm willing to change to another router that does this function better, if anybody has any recommendations


As a side note, how do I install merlin (just upload the firmware?) also is there a way to return to an older firmware version that I know worked better on these controls?
Last edited:


Senior Member
if you truly need parental control you should buy Synology router
just read about it/ watch yt movies. - it allow not only to setup access 6-8pm - you can setup 2h per day doesn't mother when. I work a lot with safety requirements and what weak, bad parental control is doing in dangerous. If you limit access to internet 6-8pm your child will run/ bike what ever from location it is to just get to home exactly on time. Internet is worst than drugs (more addictive). :)

most router manufacturers including Asus do not care, do not want to invest time to make this feature good, reliable etc.

Synology router can be set as bridge (and parental control and more security is still working) if you wan to use Asus or different router too.
Last edited:

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!