ASUS RT-AC56U Firmware version 3.0.0.4.380.3264 Broken?

radeon7750

Occasional Visitor
https://www.asus.com/ro/Networking/RTAC56U/HelpDesk_Download/

ASUS RT-AC56U Firmware version 3.0.0.4.380.3264

ASUS has been dedicated to cooperate with third party developers to come up with more innovative features.
To comply with regulatory amendments, we have modified firmware verification rule to ensure better firmware quality.
This version is not compatible with all previously released ASUS firmware and uncertified third party firmware.


Security Fixed
- Fixed Samba Badlock CVE-2016-2110 (Man in the middle attacks possible with NTLMSSP)
- Fixed Samba Badlock CVE-2016-2111 (NETLOGON Spoofing Vulnerability)
- ASUS firmware did not enable Samba LDAP, and not affected by CVE-2016-2112 (LDAP client and server don't enforce integrity) issue.
- The Samba version in ASUS firmware was not affected by
CVE-2016-2118 (SAMR and LSA man in the middle attacks possible)
- The Samba version in ASUS firmware was not affected by
CVE-2015-5370 (Multiple errors in DCE-RPC code)
- Fixed command injection issue. Thanks for Chris' contribution.
- Fixed XSS issue. Thanks for Chris' contribution.


Bug Fixed
- Fixed Windows Radius server compatibility issues.
- Fixed 5G performance issue when using bandwidth monitor.
- Fixed bandwidth monitor incorrect number problem.
- Fixed setup wizard redirect issue when router automatically changed LAN IP in IP conflict case.
- Modified setup wizard process when router detected DHCP and PPPoE at the same time.
- Fixed bandwidth limiter bug when there are multiple clients in rule list.
- Fixed NTP automatically sync issue when router rebooted
- Fixed Safari slow response issue.
- Enhance AiCloud dynamic stream port mechanism (please also keep AiCloud app up to date)
- Fixed AiCloud share link related issues.

MD5:621fa29a2d4af1dbe011c7404664ce1b



After downloading this firmware I noticed that the specified MD5 value doesn't correspond with the one of the downloaded file. The MD5 value I get is : 2F22983D9D19192097E717F0A4F119D2
Can anyone else also confirm this??
 

RMerlin

Asuswrt-Merlin dev
Make sure you check the TRX file, not the zip file.
 

RMerlin

Asuswrt-Merlin dev
If you are really checksuming the trx, then I can only assume it was a bad copy/paste job, since they reuse the same changelog for multiple models.
 

radeon7750

Occasional Visitor
If you are really checksuming the trx, then I can only assume it was a bad copy/paste job, since they reuse the same changelog for multiple models.
I tried checksumming the rar and also the trx file ; none matched the value stated on the website.
After using this firmware for 2 days these are my issues:
  1. Traffic Analyzer page is broken, it can't be accessed in GUI.
  2. My 1TB WD Elements hdd never goes to sleep after installing Download master. (Curiously, it does go to sleep mode if I uninstall Download master .....)

PS: I have hard reset the router before and after the update !
I have tried resetting and even flashing again multiple times , still same issues ...
bottom line : AVOID THIS FIRMWARE !!! Seems like a beta rather than a stable release!!! Also going back is a very nasty proceedure!
 
Last edited:

radeon7750

Occasional Visitor
Here is the Asus router downgrade 380 firmware solution which worked for me :
All credit goes to KevTech (original post here )

Static IP on TCP/IPv4 of adapter.
IP 192.168.1.2
subnet 255.255.255.0
gateway 192.168.1.1

Make sure no USB devices are connected.

Push reset button until power light starts blinking.

Let router completely reboot without touching anything.

Once router is back up, turn off the power button then hold in reset while powering back on to get into recovery mode.

Launch browser to 192.168.1.1

upload firmware and wait wait wait



upload the last 376 firmware first and if that goes well then move up to 378.

http://dlcdnet.asus.com/pub/ASUS/wi...754.zip?_ga=1.233151709.2110491766.1465058653



For me it only took about 5 minutes to upload the firmware using the CFE miniweb server using Internet Explorer.

A HUGE thanks to KevTech for posting the downgrade solution !!!! (every other solution I tried eventually failed , including using firmware restoration tool, etc ...)
 

RMerlin

Asuswrt-Merlin dev

radeon7750

Occasional Visitor
I am now back on Firmware version 3.0.0.4.378.9135 and everything is back to normal again. All issues are gone.

@RMerlin I have always used asus stock firmware. If I upgraded to your latest version of custom firmware for my RT-AC56U and let's say... something didn't work ... Could I revert back to asus stock firmware in that case? If so, ... to which version could I revert to? Thanks in advance.
 

RMerlin

Asuswrt-Merlin dev
I am now back on Firmware version 3.0.0.4.378.9135 and everything is back to normal again. All issues are gone.

@RMerlin I have always used asus stock firmware. If I upgraded to your latest version of custom firmware for my RT-AC56U and let's say... something didn't work ... Could I revert back to asus stock firmware in that case? If so, ... to which version could I revert to? Thanks in advance.

You can always revert back to any version you desire when using the Firmware Recovery Tool. Webui will limit you to firmware versions newer than 380_3000.
 

danyxp

Occasional Visitor
With all 380 fw I can't get past 850-900 Mbps, and during the speed test only one core is used. With 378 or older fw it gets past 930 Mbps, both cores used. Using an 1000 Mbps pppoe connection. Not really a big problem but still...

Sent from my SM-G930F using Tapatalk
 

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top