What's new

ASUS RT-AC58U connectivity with Chromecast and Google Home

  • SNBForums Code of Conduct

    SNBForums is a community for everyone, no matter what their level of experience.

    Please be tolerant and patient of others, especially newcomers. We are all here to share and learn!

    The rules are simple: Be patient, be nice, be helpful or be gone!


New Around Here

I've been using my RT-AC58U router for a few years now, without any issue. A couple of months back I've checked for firmware updates, and updated the firmware to version Since then I've been having issue with my Chromecast and Google Home, which were working fine before the update:
- I cannot connect my Chromecast to the Wifi at all. I have reseted it, and tried to reconnect it via the Google Home app, but I'm always getting the following error: "Something went wrong. Home TV may be set up, but we could not communicate with it from your iPhone... "
- My Google home is connected to the internet, but I cannot communicate with it from my phone:
  • If I give it the command "Ok Google, play some music", everything works as expected.
  • If I open the Youtube Music app from my iPhone, and try to cast the music from there, there is an infinite spinner and the music never plays. This was working as expected before.

Some notes:
- I have both a 2.4 GHz and a 5 GHz network on the router, but I'm trying to connect the Google devices to the 2.4 one, as I believe this is the only supported one.
- I have tried to disable Set AP Isolated in both 2.4 and 5 networks, as I've read that this might help, but unfortunately there was no change.

Any help is appreciated

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!