[ASUS RT-AC58U] Sharing USB via SMB not working

HerodotusPrime

New Around Here
I've been attempting to share a series of USB drives from an ASUS RT-AC58U without success. I've followed the instructions on sharing on the manufacturer's website as well as the instructions for enabling SMB1 on Windows 10. I've tried different types of drives (flash, and spinning platter) with all the file formats I can think to try (NTFS, EXFAT, FAT32). I can see other shares on my network, including an SMB1 share from my UnRaid server, so I am pretty sure this is an issue with the router.

Symptoms:

The share I've enabled just never seems to show up on the network and I can't access it via the usual \\<networkdevice>\<sharename> command from File Explorer.

What I've done to troubleshoot:

  • I turned off authentication so I could be sure it wasn't user account issue (Still doesn't appear).

  • I fired up a Powershell terminal and ran Get-WindowsOptionalFeature -Online -Featurename "SMB1Protocol" and confirmed that SMB1 was enabled (SPOILER: it was).

  • I fired up a PuTTy session and ssh'd into the router and ran df and verified that I could see the drive mounted (/dev/sda2 1953381372 161816 1953219556 0% /tmp/mnt/Data).

  • After that I dropped by the system logs to make sure that the SMB server was running (17:11:10 Samba Server: daemon is started).

  • I ejected the drive, took it back to my Windows 10 desktop and formatted it to EXFAT, and then plugged it back into the router and restarted it. For some reason with this file format the drive won't mount so I took it back to Windows 10 and reformatted it to NTFS and plugged it back into the router (Stll no joy).

  • I tried another drive, also formatted NTFS, and it behaved in a similar fashion so I suspect there is some issue with my configuration.
Has anyone out there gotten something like this working with this brand of router?
 

L&LD

Part of the Furniture
Are you using the latest firmware version 3.0.0.4.382.52243 on it?
 

L&LD

Part of the Furniture
When is the last time you have performed a full reset to factory defaults on the router? (Including, if that option is available, checking the box to 'Initialize all settings' too)?
 

HerodotusPrime

New Around Here
I'm beginning to suspect it's a Windows 10 issue. I just fired up a Raspberry Pi and installed Samba on it and I can see the network share. I'm not sure why I can see my UnRaid share, which is also SMB1, but not this new one on Windows 10. I confirmed it was there using an Android phone and a file explorer...

I hate Windows 10.
 

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top