Release ASUS RT-AC66U-B1 Firmware version 3.0.0.4.386.46065 27JAN22

bbunge

Part of the Furniture
ASUS RT-AC66U-B1 Firmware version 3.0.0.4.386.46065
Security
- Fixed string format stacks vulnerability
- Fixed cross-site-scripting vulnerability
- Fixed informational vulnerability.
Thanks to Howard McGreehan.

-Fixed SQL injection vulnerability
-Fixed json file traversal vulnerability
-Fixed plc/port file traversal vulnerability
-Fixed stack overflow vulnerability
Thanks to HP of Cyber Kunlun Lab

-Fixed authenticated stored XSS vulnerability
Thanks to Luke Walker – SmartDCC

-Fixed LPD denial of service vulnerability
-Fixed cfgserver heap overflow vulnerability
-Fixed cfgserver denial of service vulnerability
Thanks to TianHe from BeFun Cyber Security Lab.

Added more ISP profile
Digi 1 - TM
Digi 2 - TIME
Digi 3 - Digi
Digi 4 - CTS
Digi 5 - ALLO
Digi 6 - SACOFA
Maxis - CTS
Maxis - SACOFA
Maxis - TNB/ALLO

Fixed AiMesh guest network issues.
Fixed DDNS issues where the WAN IP is IPv6
Fixed UI bugs in Administration --> feedback.
Fixed time zone error.

Please unzip the firmware file first then check the MD5 code.
MD5:33b491c21c167a8beec2f450aafe1bc2
 

Lollero

New Around Here
Updated my Asus RT-AC66U_B1 (2017) to this. It serves as normal Wireless router mode.
Last update was from years ago and I cannot remember the firmware version.

The web interface got new look and many new options compared to my old one.

Some bugs also appeared:
- Routers clock went back to factory time May 5th 2018
- NTP could not sync
- Internet shows as not connected even though it worked fine -> annoying red light on the routers front indicating a problem
- Log was filled with different time outs (sadly cleared the log and cannot remember them)

Tried different NTP servers/IP adresses, DNS and Ping -Monitoring
Tried to factory reset and hard wps-reset
Tried to return older firmwares and reset
Did not work.

Found this thread that fixed my clock and connection status:

With 3 days worth of googling, I guess the ATEMODE went to status 1 along the firmware update. (It should be set to 0?)
Managed to fix it with those two commands mentioned in the link of the post above using SSH connection with Putty. (1st command changes atemode to 0 and second command does something I do not know)
After rebooting it seems to work fine.

I am new to this, so I do not know how those commands actually works/do. But by doing those, it looks fine to me now.

LAN speed is good and wifi seems stable. Log was filled with channel swithes though, so I changed the control channels from auto to manual.
 

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top