Asus RT-AC66U_B1 flush openVPN settings?

  • ATTENTION! As of November 1, 2020, you are not able to reply to threads 6 months after the thread is opened if there are more than 500 posts in the thread.
    Threads will not be locked, so posts may still be edited by their authors.
    Just start a new thread on the topic to post if you get an error message when trying to reply to a thread.

Fin9ersMcGee

New Around Here
Hello,

Only just got into the home network/home lab/server based stuff recently.
I'm pretty clued up on tech and can navigate my way through most problems. That is until I purchased a purchased an Asus RT-AC66U_B1 as a huge upgrade to my Virgin Media "SuperHub" as port forwarding just flat out doesnt work.

Arrived yesterday and quickly got it setup. Flashed the latest AsusWRT firmware followed by MerlinWRT. Assigned static IPs to my Proxmox, freenas and Minecraft servers. All working out fine so far.

I then played around with an openVPN server running on the router.
Worked out pretty fine, my friend across town connected ok and the router showed him connected.

Fast forward to today, and I've since changed a few settings of the openVPN server but now when I export the ovpn file and open it in a text editer, the certificates do not match those o the routers webGUI....
I reset back to defaults using the "Default" button under "VPN Server", changed the settings to my liking and saved the configurations. But again, the ovpn files certificates do not match those on the routers....

I've had a quick buzz round the forums here and found there might be a bug with nvram settings not being wiped.
So I logged in via SSH and ran the various commands I found to unset openVPN settings from nvram followed by a reboot. This did nothing.
So I then tried a reset by holding the reset button for 10secs and re-input all the SSID and password infos.
Once set back up, I tried again to set up openVPN but again, the certs do not match.
Next thing I tried was a full factory reset by turning the router off and holding the WPS button as I turned it on until the reset operation was complete. This did nothing also.
Next I tried the "Format JSSF Partition on Next Boot" option and powercycled the router, again, still no dice, certificates mismatch.

I'm honestly out of ideas now and have squeezed every Google search term I can think of to find help on this issue.

Any help will be greatly appreciated.
Thanks in advanced


EDIT - One more thing i tried was copying the certs from the webGUI and pasting them into the ovpn file using a text editor (Notepad++) and saving. But that also didnt do the trick.

This worked only once, the first time i tried it..... Feeling deflated that it only worked that one time.
 
Last edited:

Fin9ersMcGee

New Around Here
Ok, slight update.

So, I did the first thing i tried again, used the "Default" button under "VPN Server" tab but this time I rebooted the router. Now it seems to connect fine, BUT this time one certificate, the server cert, still doesn't match...

Now I'm even more confused as to why this time it worked, but all the other times failed.... And why the cert mismatch, or why it works now even with the server cert mismatch....

So much more to learn, look forward to posting for more help and (blindly) magically fixing things.
The next post will more than likely involved getting SMB shares from Freenas to the VPN server.....

I'm Fin9ers, btw. Complete novice :D
 

Fin9ersMcGee

New Around Here
Terribly sorry for the continued updates.
I'm still connected ok with my android phone (via 4g) and I can browse the internet and my public IP reads as my homes. But I cant connect to my freenas boxs smb shares. //MyIPAddress/MyShareName/ doesnt work.
I connected my windows laptop to my phones 4g via wifi hotspot and tried the openVPN GUI app along with the now working ovpn file from my android device, but would fail to connect, stranger still is when i enable my vpn client (nordVPN) on my laptop, the connection works but i dont get internet nor share access.... Super confused myself i think.

On top of that, the "Export OpenVPN Configuration File" button now reads:
"Certification Authentication / Server certification / Server Key field error!
Please check the Keys and Certification contents on the Advanced Settings page."

:confused::confused::confused:
 

Similar threads

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top