ASUS RT-AC68U Dual Band Wireless AC1900 Router no wifi

belveder

New Around Here
Hi i own a ASUS RT-AC68U Dual Band Wireless AC1900 Router which has been great since I got it but the last couple days the wifi has stopped working on it.

the LAN works as good as normal but no wifi on 5g or 2.4g or even guest.

I have been running Merlin on it since I bought it. Updated yesterday to RT-AC68U_386.7_2 from RT-AC68U_386.5_2

I have double checked the wifi button on the side is on

Tried formatting but nothing helps

Any help would be greatfully appreciated please
 

Tech9

Part of the Furniture
You don't have too many options. Check the power supply, reflash the firmware, do WPS hard reset. If nothing helps, you need a new router.
 

bennor

Very Senior Member
How are you determining the WiFI isn't working? What mode is the router configured for? Wireless router mode / AiMesh Router mode (Default) mode or for some other mode?

As a troubleshooting step, have you performed a hard factory reset? Do not reload any saved configuration files after performing a hard reset. Configure the router from scratch after a hard reset.
[Wireless Router] ASUS router Hard Factory Reset - Method 1

ASUS router Hard Factory Reset - Method 1

1. Turn the router off.
2. Press and hold the "WPS" button and turn the router on.
3. Power light is on (keep holding the WPS button).
4. Release the WPS button after the power LED light starts flashing.
5. Power light stops flashing and the router will automatically reboot.

Do you have any extra scripts running? Do have a USB drive attached to the router? If you have a USB hard drive attached, unmount it and remove it, then reboot the router as a troubleshooting step. Double check the Wireless settings in the GUI. Ensure the SSID is enabled. Check the Wireless > Professional section and ensure the Enable Radio option is set to On. Disable any wireless scheduling that might be enabled.
 

belveder

New Around Here
Thanks for that, I have done all that except for buying a new one lol.

I have 3 mobile phones, one tablet and Fetch tv all connected and have lost connection.

The only message i get is "device connected but no internet connection". Devices connected via lan cable all work as normal.
 

bennor

Very Senior Member
The only message i get is "device connected but no internet connection". Devices connected via lan cable all work as normal.
Have you tried doing a hard factory reset then basic config, then flashing the stock Asus firmware to the router, then perform another hard factory reset? That may help narrow down if the issue is hardware or firmware related.

 

wouterv

Very Senior Member
"device connected but no internet connection"
That indicates WiFi is working, but the router internals block Internet access.
What was more or less said before:
  1. If there are, disconnect all USB devices.
  2. Install the latest available firmware version.
  3. Reset to factory defaults.
  4. Do not load an old configuration backup file.
  5. Manual configure the router with the bare minimum, as:
    • Router Login Name.
    • Router Login Password.
    • WAN Connection Type, and what is required to connect to the Internet.
    • Wireless SSID's and WPA Pre-Shared Key's.
    • Leave everything else default.
  6. Test the router behavior:
    1. Test with a wired connection first.
    2. Test with a wireless connection.
If the above succeed, you can manually add more settings to the router as desired.
 

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top