New Around Here
So, happy ASUS RT-AC68U owner here.
I have been using it for many years in my summer house and before that in my permanent home.
This year I went to the summer house and fired the router up, but no WIFI ever presented itself to my computer or phones.
Tried to login to the router but no answer.
It gives me no IP so tried to reset it, but there is still no IP.
There is indicator lights on the NIC so there is something that is responding (L2).

After reset the only lights that is lit is the USB2.0 LED. Nothing o the WIFI LED's or even the power LED. :-/

I also found the rescue tool from ASUS, but it dosen't find my router, as there is no IP.

Is it time to scrap it? The only solution I could think of would be if there is a tool where you could start a restore from computer through the USB-port.


Very Senior Member
Have you tried a hard factory reset? May have to try it several times.

Have you tried the the firmware restoration method to see if the unit can be discovered and firmware restored?

Its possible the unit has died, or was damaged by a power spike/lightning strike if not on a good surge protector, or the power adapter is failing. As a troubleshooting step with the router hard reset, not connected to broadband and no other devices connected to it other than one single wired (Ethernet to one of the routers LAN port) computer, manually configure the computer with an IP address in the 192.168.1.x / range and try to access the router's GUI page at
Last edited:


New Around Here
Yeah, I have tried the suggested hard reset, and to get the router into rescue mode, but the power lights newer starts flashing as suggested. I have also set the IP as you suggest and that dosen't work either.
Thanks for your efforts though. It is much appreciated! :)
The next test is then to get a spare power supply and test that.


New Around Here
OK, so I measured the output from the power adaptor, and it seems it's only giving me 6.3 V which is only 1/3 of the required voltage. I think we have found the issue!

Ronald Schwerer

Very Senior Member
I hope it is the power supply. The USB2 LED on is usually a sign that it can't boot. Often due to corrupt boot loader. But if the power is bad, I suppose that could cause this also.


Occasional Visitor
Are you saying you are not getting the IP from the modem?

If so, the modem may be trying to connect to a specific MAC address Which is not your router. So power off both the modem and router. Unplug the modem from both power and the ISP for 5-10 minutes. Then plug the modem in and power up the modem, wait for it to stablize, then power up the router, wait for it to stabilize, them attach the ISP cable and see if you get an IP from the modem.

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!