1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
Dismiss Notice

Welcome To SNBForums

SNBForums is a community for anyone who wants to learn about or discuss the latest in wireless routers, network storage and the ins and outs of building and maintaining a small network.

If you'd like to post a question, simply register and have at it!

While you're at it, please check out SmallNetBuilder for product reviews and our famous Router Charts, Ranker and plenty more!

ASUS RT-AC68U USB tethering not working with Galaxy S8

Discussion in 'ASUS AC Routers & Adapters' started by Saiber77, Nov 8, 2019.

  1. Saiber77

    Saiber77 New Around Here

    Joined:
    Nov 4, 2019
    Messages:
    2
    I can't seem to get my Galaxy S8 to tether with this, it recognizes "Android_mobile" on the network status page but just says "Cable disconnected" on the WAN status. If I toggle usb tethering on the phone it shows the network settings for a brief second "192.168.43.2" but then immediately goes back to "cable disconnected".

    I've tried with various firmwares, including stock and merlin, as well as merlin beta. DD-WRT seems to have an out of the box iPhone tethering option but requires a lot of linux commands and trial and error to get a USB modem type connection, haven't seen anything yet about "Android phone" tethering with dd-wrt.

    My friend has the same router working with a different android phone, and I can confirm that this isn't a bunk router because it behaved the same on his router when I tested it with my phone. If anyone has any ideas I'd be grateful. Thanks in advance!
     
  2. AmmiD

    AmmiD New Around Here

    Joined:
    Dec 10, 2019
    Messages:
    1
    I'm encountering the same issue as saiber77. Getting 'cable disconnected' when trying to use Samsung Note 8 with USB-C. However, if i use a Samsung Prime J-3 that uses a MicroUSB, it works fine. I was hoping by upgrading my connected phone will help boost my signal/data processing speed.
     
  3. tekknyne3

    tekknyne3 New Around Here

    Joined:
    Dec 31, 2019
    Messages:
    6
    Hey I just found this pretty recent thread and wanted to add my commentary in the hopes to get lucky with my tethering problems which sound similar -

    I have an ASUS RT-AC3200 router, newest firmware and it will not tether correctly with my Samsung Galaxy S8 or new Moto Z4 both Android 9. My old Moto Z Force Android 8 works perfect when tethering but it's battery life is pretty bad so I upgraded and still kept it around for the kids. I verified the router is setup to use "Android Phone" option for WAN, I have also tried "USB Modem" with no difference. I have tried to reboot the cell phone and router devices 100x times, enabled android developer options>usb tether as default, enabled android debug mode (just throwing slime at the wall I have no idea whats up). No matter what, the router does not negotiate a WAN IP address with the cell phone. In the router network map page, under "internet status" I can choose " WAN internet connection" and toggle that on/off and the WAN IP address is stuck at 0.0.0.0. With my working Moto Z Force, once I enabled tethering on it, the router will usually pick up an IP address right away, or if I toggle the WAN on/off, it will pick one up as well, but my Samsung S8 and Moto Z4 do nothing, there's not even an error message.

    All tethering options that I can find are the same across all cell phones, default, like DHCP client IP address starts at 192.168.43.2. Both the Samsung S8 and Moto Z4 work flawlessly tethered to a Dell E5450 laptop running Windows 10 latest.

    So I dunno what the deal is, I feel like it is something with Android 9 or some settings. My Moto Z4 has a developer option for "Use hardware accelerated tethering when available" and I toggled that a few times between reboots and it did nothing.

    It sucks because we just moved to a new house and 4G internet is our only real option, so would be nice to have everything connect up to my fancy router rather than collect dust.
     
  4. sanke1

    sanke1 Senior Member

    Joined:
    Jan 11, 2014
    Messages:
    316
    Location:
    IN
    Tethering has never worked correctly on Asus Routers historically. I have tried Rt-ac68u, Rt-ac86u, Rt-ac88u and even current Rt-ax88u. Pure cowdung experience when it comes to tethering.
     
  5. doczenith1

    doczenith1 Very Senior Member

    Joined:
    Sep 19, 2014
    Messages:
    664
    Location:
    MI
    I had success with a 68U tethered to Pixel 3a running Android 10 recently. The router was running Asuswrt-Merlin firmware version 384.13.

    Those having issues what firmware are you using?
     
  6. Rottonpeech

    Rottonpeech New Around Here

    Joined:
    Feb 19, 2020
    Messages:
    2
    I too am having this same issue with my S8Plus SMG955U. I did a bit of research and found this page about an issue with the S7 (https://www.snbforums.com/threads/s..._beta3-rt-ac3100-with-partial-solution.44599/)

    I'm not certain that it's the same issue, as my S8Plus is NOT showing anything in eth3, but I can confirm that this worked with my S10+

    I also reviewed the syslog.log and didn't see anything revealing. Is there another log I should be looking at?

    If anyone knows how to work around the S8+, please let me know.
     
  7. Rottonpeech

    Rottonpeech New Around Here

    Joined:
    Feb 19, 2020
    Messages:
    2
    Has anyone tried this with the Samsung Galexy A10e?
     
  8. tekknyne3

    tekknyne3 New Around Here

    Joined:
    Dec 31, 2019
    Messages:
    6
    My Asus AC3200 is running the latest firmware from december 2019 Version 3.0.0.4.382.51939 and my Moto Z4 that doesnt work is on Android 9. I think the verdict is still out whether or not Android 10 is going to be developed for my mid-range moto z4.

    I switched back to my Moto Z Force running Android 8 and tethering is working great. My battery life just kind of sucks
     
  9. tekknyne3

    tekknyne3 New Around Here

    Joined:
    Dec 31, 2019
    Messages:
    6
    I tried my GF's Samsung Galaxy S8 with android 9 with my Asus AC3200 and it did not work. The router would almost never detect the phone when plugged into the router via USB. Sorry I know that is not your exact scenario just my 2 cents.