1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
Dismiss Notice

Welcome To SNBForums

SNBForums is a community for anyone who wants to learn about or discuss the latest in wireless routers, network storage and the ins and outs of building and maintaining a small network.

If you'd like to post a question, simply register and have at it!

While you're at it, please check out SmallNetBuilder for product reviews and our famous Router Charts, Ranker and plenty more!

Asus RT-AC86U running merlin. Guest network setup with local DNS (PiHole)

Discussion in 'Asuswrt-Merlin' started by jbpcan, Mar 24, 2019.

  1. jbpcan

    jbpcan New Around Here

    Joined:
    Mar 24, 2019
    Messages:
    9
    Is there a way to set up the guest network to use PiHole as its DNS when it is set to block Access to Intranet?

    I tried the following:
    LAN > DHCP Server > DNS Server 1 - Set PiHole IP
    Result: Works for wireless AP and ports directly connected to Internet, but doesn't work on the Guest Wifi. I'm thinking because its set to block access to Intranet.

    LAN > DNSFilter > Enable DNS-based Filtering
    Global Filter mode - Custom 1
    Custom (user-defined) DNS 1 - Set PiHole IP
    Result: No internet access on entire network.

    WAN > Internet Connection > DNS Server1 - Set PiHole IP
    Result: Works on all AP including guest netowork. But on the pihole logs, I only see the router gateway as sending all DNS requests.

    I don't mind using the WAN option. But I wanted to be able to see the devices properly on piHole. Any way to set it up that way? I also need Guest network to block access to Intranet.
     
  2. JDB

    JDB Very Senior Member

    Joined:
    Aug 28, 2016
    Messages:
    763
    jbpcan likes this.
  3. jbpcan

    jbpcan New Around Here

    Joined:
    Mar 24, 2019
    Messages:
    9
    Set router with:
    LAN > DHCP Server > DNS Server 1 - 192.168.51.123 = Pihole IP
    WAN > Internet Connection > WAN DNS SEtting > Connect to DNS Server automatically - YES

    I set up YazFi with these options:
    wl01_ENABLED=true
    wl01_IPADDR=192.168.52.0
    wl01_DHCPSTART=2
    wl01_DHCPEND=254
    wl01_DNS1=192.168.51.123
    wl01_DNS2=192.168.52.1
    wl01_FORCEDNS=true
    wl01_REDIRECTALLTOVPN=false
    wl01_VPNCLIENTNUMBER=2
    wl01_LANACCESS=false
    wl01_CLIENTISOLATION=true

    I get an IP assigned from the 52.0 block when connecting to the guest network. However, no internet. Also the device doesn't show up in the network map list on the router.
     
  4. JDB

    JDB Very Senior Member

    Joined:
    Aug 28, 2016
    Messages:
    763
    Jack Yaz likes this.
  5. jbpcan

    jbpcan New Around Here

    Joined:
    Mar 24, 2019
    Messages:
    9
    S/He helped me on the YazFi main thread.

    Resolved issue:
    Under pihole > DNS > Interface listening behavior:
    Listen on all interfaces, permit all origins
     
    Vexira, Jack Yaz and JDB like this.
  6. JDB

    JDB Very Senior Member

    Joined:
    Aug 28, 2016
    Messages:
    763
    Nice. Glad you got it sorted.


    Sent from my iPhone using Tapatalk
     
    Jack Yaz likes this.