asus rt-ac86u wifi problems

  • ATTENTION! As of November 1, 2020, you are not able to reply to threads 6 months after the thread is opened if there are more than 500 posts in the thread.
    Threads will not be locked, so posts may still be edited by their authors.
    Just start a new thread on the topic to post if you get an error message when trying to reply to a thread.


New Around Here
hi my name is james, and im having some problems regarding wifi with ac86u router.
first of all im not tech savy with any type of networking, i am the type of person that will try to solve issues but do not know much about it.
so here the problem started, we have a virgin hub 3 which as most know is a bit shirte in the wifi department, and since lockdown my partner is working from home in an it environment so an internet connection, especially wifi is important
the hub 3 was always dropping out of wifi so called virgin and they said it was because of updating their network, now this didnt sound ok to me as it was only wifi dropouts and ethernet connected devices could still access the internet, apart from the few times there was total internet drop outs, the virgin customer service person i spoke to still insisted it was a problem out of the house, i asked how that could be when if i unscrewed the coax all my ethernet connected devices coud still access one another so an engineer came out and replaced the hub 3 and the problem was still the same
even with the router in line of sight of 8 metres 5ghz and 2.4gh would still lose signal, so got a wifi extender but still the same.
i then decided id get a mid price router and decided upon a tp link archer ax50 with a little future proofing in mind, so hub 3 in modem mode and all seemed working fine until i either downloaded or streamed a film from laptop using ums to a ps3, samsung tv or the sony bdv surround we have.
the problem being the download would fluctuate from 100mbs to 20kbps constantly every 10-15 seconds or so and any streaming from the pc would stop and start every 15 seconds for 2 or 3 seconds, so thing the router was faulty sent it back and bought an asus rt-ac86u.
now i still have a problem, downloading over wifi is not a problem and we have no drop outs at all unless its virgin related.
however i do still have an upstream problem when i stream from the laptop to any device i choose with playback stopping and starting just like with the tp link.
so i found this site and set up the router as per instruction on this site and am using merlin 386.1_2 firmware
ive tried all the settings that have been suggested on this site to no avail, but heres the strange thing, when my daughter took the laptop into her room next door
i had no problems whatsoever with the streaming issue at all but put it in the same room as router it happens again, i use a wifi analyzer to select the best channels etc but still the problem persists
all the phones we have dont have a problem
the laptop is a dell G3 with a qualcomm qca9377 network adapter which is supposed to have a theoretical transmit/receive rate of 433mbps so should be able to handle streaming 1080p videos to my tv or playstation, i never had this problem with the hub 3 and only went for a better router to extend and improve the wifi throughout the flat, so it may be the tp link wasnt faulty but i have some strange set up problem somewhere, as download is fine but upstream is not, ethernet is fine also
sorry for the long winded and possibly confusing post, and any help and suggestions would be much appreciated


Very Senior Member
How fast is your Internet connection down/up? You shouldn't be playing with custom firmware if you're not tech savvy. Install the latest official firmware for your router, reset it to default settings, do manual basic configuration in the setup wizard. Lock 2.4GHz band to 20MHz wide on channels 1-6-11 and 5GHz band to 20/40/80MHz on channel 36. Don't touch any of the advanced settings yet. If this laptop is the main suspect for your poor network performance, check what is running on it. Your daughter may have downloaded something large to her OneDrive folder and now the laptop is taking the entire upload bandwidth to sinc with the cloud. This same computer may be uploading Windows updates to Internet. See what's going on there before fiddling with the router. The same issues with three different routers means you have something wrong on your own network.


Part of the Furniture
Tech9 has some good recommendations. I would recommend updating the Qualcomm driver for your laptop. See:
Might want to go back the the Asus beta firmware for the AC86U. Besides the WIFI settings above, Use Dual Band SmartConnect, Disable Airtime Fairness and Universal Beamforming in WIFI Professional for each band. Make sure to Hard Factory Reset after switching firmware.


New Around Here
i have virgins 100mb download and 10mb upload, the virgin hub didnt have this problem it just had poor wifi on both 2.4 and 5ghz and kept dropping altogether on my partners 2 work laptops, as well as the previous old laptop and the new dellG3, all that was changed on the hub 3 was separating 2.4 and 5ghz. the tp archer ax50 also had download wifi issues as well as upload which i dont have with with the 86u.
the 86u is already on channel 1 and 20mhz on 2.4ghz and channel 36 and 20/40/80mhz on the 5ghz
as for onedrive the upload speed is limited to 125kb/s so i dont think that would hog any upstream traffic with the 10mbps upload speed and is not used much anyway.
windows peer to peer updates have always been off so windows is not uploading anything.
this problem has happened with the stock firmware with no changes made, same with latest stock firmware and no changes made, same with merlin firmware with no changes made.
then with all 3 i disabled airtime fairness, universal beamforming on both bands, separated 2.4 and 5ghz
what i cant understand is that if i put the laptop in the room next door to the router the problem is no longer there and is only with streaming to devices and it seems the closer to the router the worse it gets,
all the drivers are up to date on the whole system.
both my partners work/client laptops use a vpn to connect to her work site, could this be an issue ?


New Around Here
update, while streaming to playstation, i opened task manager on the performance tab and selected wifi, the graph send line was instead of being reasonably smooth up and down decided by the bitrate of the film being fast action with a 50mbps high and stiller motion around 40mbps it was badly spiking from 50mbps to 10kbps every second or so for a minute and then stopping for 5 seconds, so i moved the laptop a bit by bit further from the router and the problem has now gone having moved it 2.6 metres from the router, within a metre of it, its totally unusable for uploads and downloads too, i dont understand why tho so it would be nice to know such things, i suppose i could liken it to throwing a stone in a pond and the ripples travel outward in a nice uniform way but throw 5 at once and the ripples cancel each other out when they reach another ripple and cause the signal to cancel itself out, or is my analogy complete and utter crap ?


Very Senior Member
i moved the laptop a bit by bit further from the router and the problem has now gone having moved it 2.6 metres from the router, within a metre of it, its totally unusable for uploads and downloads too
Radios that are too close to transmitters can suffer from overload. The circuits saturate and distort the signal.


Occasional Visitor
Hi James, so can you confirm that other devices in your network are actually working with good wifi speed, right?

Maybe do some speedtests on some of the other devices to see if you get expected speeds and to nail the problem down to the Dell G3. From reading your posts it does not sound to be a router issue, even with different firmwares. Also with the settings recommended by the others you should be well suited. Just report back if other devices generally are okay - otherwise I probably guide you into the wrong direction.
I did some research about issues with the Dell. Let's assume the wifi is okay

Are you aware of any software called Dell "SmartByte" installed on the Laptop?

Source -> google "Beware of SmartByte":

Re: Beware of SmartByte Continued...​

And another one with this issue. My brand new Inspiron 5477 AIO was getting a paltry 12Mbps max from my Virgin Media 100, videos would constantly stop and buffer, and occasional complete dropouts were common. Oddly enough, the Ookla speedtest app was reporting download speeds of ~110Mbps (which my Android devices were also getting) but the same test on via a web browser reported about 8Mbps. Thankfully, I found these posts and uninstalled Smartbyte, this immediately sorted the problem. (....)

Hope it helps!

Similar threads

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!