What's new

Asus RT-AC87U 5ghz

  • SNBForums Code of Conduct

    SNBForums is a community for everyone, no matter what their level of experience.

    Please be tolerant and patient of others, especially newcomers. We are all here to share and learn!

    The rules are simple: Be patient, be nice, be helpful or be gone!


New Around Here
Maybe you have encountered such a problem and can help, thanks in advance for all the answers.

I stitched for the firmware from Merlin 384.13_10. There is no channel selection in the settings (for both 2.4 and 5 Ghz), just an empty drop-down menu, plus there is no menu on the left, as well as an additional menu on top. There is also no 5ghz network in sysinfo it is indicated that 5hz is generally turned off. It was stitched through Asus Firmware, followed by a complete reset of nvram. I don't think it should be.
I thought that the firmware was crooked. I tried to reflash 5 times, I tried different firmware (hugo, merlin, official). Outcome is the same

I also found "5 GHz radio is not ready" in the logs

Clearly you are doing something wrong , Merlin used to work well on that router.
However the RT-AC87U is End of Life and no longer supported.
Merlin ceased support last year.

If you have tried several firmwares you need to factory reset
Last edited:
Welcome to the forums @oleg_grushin.

After flashing the firmware you want to try, did you do a full reset to factory defaults (and possibly, in multiple, different ways)? If not, the do so now.

Have you tried doing an electrical reset by unplugging the AC power plug from the wall, and from the router, and leaving the power button in the 'on' position for a minute or two, before powering back up again?

If the above doesn't work yet, have you checked that the power adaptor is working to specs? Can you try another one to verify it is the original power supply that is at fault?

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!