1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
Dismiss Notice

Welcome To SNBForums

SNBForums is a community for anyone who wants to learn about or discuss the latest in wireless routers, network storage and the ins and outs of building and maintaining a small network.

If you'd like to post a question, simply register and have at it!

While you're at it, please check out SmallNetBuilder for product reviews and our famous Router Charts, Ranker and plenty more!

Asus RT-AC88U / Gigabit Internet Slow Speed Help

Discussion in 'ASUS AC Routers & Adapters' started by krosenberg, May 10, 2018.

  1. krosenberg

    krosenberg New Around Here

    Joined:
    May 10, 2018
    Messages:
    2
    I just got RCN 1 Gigabit internet. I have an ARRIS SB8200 cable modem. When I connect my computer directly to the modem, I am seeing the speeds I expect. About 850-900Mbps (I am using Cat5e). When I connect my computer to the AC88U, I max out at about 410-450Mbps but mostly seeing 350-400. My wireless devices seem to max out at about 500Mbps on the 5Ghz network.

    I am using the latest AI Mesh stock firmware (3.0.0.4.384_20379-gc0714df). I have an AC68U setup as an AI Mesh node.

    I turned off QoS and NAT acceleration as I read those will cause speed issues.

    What can I do to increase my speed? I know the router is the choke point right now, but I am not sure what I can change to make the speed more inline with what I should be getting.
     
  2. Please support SNBForums! Just click on this link before you buy something from Amazon and we'll get a small commission on anything you buy. Thanks!
  3. doczenith1

    doczenith1 Senior Member

    Joined:
    Sep 19, 2014
    Messages:
    371
    Location:
    MI
    Turn ON NAT acceleration! 450 Mbps is ballpark for that model without NAT acceleration. My old 3100 would do around 500 Mbps. The 88U can easily do 940 Mbps with NAT acceleration on.

    I run a pretty basic setup the following options changed from the defaults and have no issues.

    Wireless 2.4 GHz Professional
    Turbo QAM - Disable (Only helps with clients that support it and there are not very many)
    Airtime Fairness - Disable
    Multi-User MIMO - Disable
    Explicit Beamforming - Disable
    Universal Beamforming - Disable

    Wireless 5 GHz Professional
    Airtime Fairness - Disable
    Multi-User MIMO - Disable (FWIW I got better 5 GHz speeds with MU-MIMO disabled)
    Universal Beamforming - Disable

    500 Mbps on wireless is about right for 2x2 AC but it's weird that the wired speed is slower than the wireless.

    What firmware did you have before you flashed your current version? Was it possibly 380 branch? Have you performed a factory reset since flashing your current fw version?
     
  4. krosenberg

    krosenberg New Around Here

    Joined:
    May 10, 2018
    Messages:
    2
    Thank you so much! That did the trick for the LAN. Enabling NAT Acceleration worked like a charm, my speed is much closer to what I am expecting (800-900Mbps).
    I tried your settings for the 5Ghz network and the speed maxes out at similar to what I had already~500 Mbps. With the 2.4Ghz, I cap out at about 100Mbps but I messed with the settings and they are a little different than what you have listed.

    I was using Merlin firmware (382.2) before I went to the AIMesh firmware and I am almost positive I did a factory reset. If I didn't could that be causing some issues?

     
  5. doczenith1

    doczenith1 Senior Member

    Joined:
    Sep 19, 2014
    Messages:
    371
    Location:
    MI
    I know it was recommended to do a reset when going from 380 to 384. I believe it's also recommended to do a reset when switching between Asuswrt-Merlin and stock firmware. Remember to do the reset after updating the firmware and do not restore a settings file.

    It can be hit or miss on whether or not you'll see issues depending on your setup. If everything seems to be working ok then you can roll with it but if you do see any issues the first thing I would do is a reset before any other trouble shooting.
     
Please support SNBForums! Just click on this link before you buy something from Amazon and we'll get a small commission on anything you buy. Thanks!