Asus RT-AC88U : good for trash, or repairable ?

  • ATTENTION! As of November 1, 2020, you are not able to reply to threads 6 months after the thread is opened if there are more than 500 posts in the thread.
    Threads will not be locked, so posts may still be edited by their authors.
    Just start a new thread on the topic to post if you get an error message when trying to reply to a thread.

gullick

New Around Here
Hello,
I've been having issues with this router for quite some time, it isn't covered by warranty anymore, and I'm about to give up.

Symptoms:
- No ping response (except under recovery mode)
- Configuration page not accessible
- No Wireless network
- LAN switch seems to work when IP manually configured on each laptop
- When connected to serial port with FTDI cable, I get garbage characters, impossible to get anything done this way

I tried several times to erase NVRAM through WPS button, without any success. When recovery mode is activated, I can ping the router but webpage isn't accessible
I can't connect to serial port, and the only thing that seems to work when recovery mode is activated is the Firmware restoration utility from ASUS
Currently running official Firmware Version 3.0.0.4.385.20631, but also tried 3.0.0.4.386.43129, as well as latest Merlin or DD-WRT : same issues

Maybe I am missing some steps, but the last thing I tried is the following:
1. Reset to factory settings (via reset button)
2. Reset NVRAM (via WPS)
3. Activate Recovery mode (via reset button)
4. I get a ping response but no webpage access to CFE
5. I uploaded Version 3.0.0.4.385.20631 via the Firmware restoration tool, with success
6. Just to be sure, I also reset to factory settings, and erase NVRAM via WPS once again
7. Router restarts, all lights green, I can access configuration page, I just connect with default admin password, and then pouf, back to square one, lost access, lost ping response.

Any wonderful idea ? I am not really into soldering anything, if nothing can be solved only with serial port, then it's going to trash.

Thanks,
 

AndreiV

Very Senior Member
Could be duff capacitors on the board , or the power supply unit is faulty.

Try another power adaptor before throwing the router out.
 

Adooni

Senior Member
in recovery mode (when Asus Firmware restoration is working) try using Firefox log at 192.168.1.1 and see if miniCFE page will be working.
if yes reset nvram and load one more time firmware from minCFE page.

try to load 1st firmware that was created for you router and available and then clear nvram and load the latest one - all via firmware restoration.
 

Tech9

Very Senior Member
It doesn't sound like software issue to me. Unfortunately, I can't help without having the unit in front of me.
 

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top