Asus rt-ax55 wifi connection problem on laptop

Atraban

New Around Here
Hello everyone
I just bought Asus rt-ax55, And all devices get full speed when connected to wifi except my laptop, it keeps disconnecting and when it connects it only get 20mbps speed, the problem is when I disable wifi password it connects without problem and gets full speed but when I set wifi to wpa2 that problem occurs, is there anyway to resolve that?
Thank you
 

L&LD

Part of the Furniture
Welcome to the forums @Atraban.

What are your actual Wi-Fi speeds? What are your ISP-provided speeds?

What laptop do you have? What Wi-Fi card/antennae setup does it have?

Have you tried using a new SSID and password as a test? (Use a guest network to test).

Have you tried resetting the laptops network settings?

Have you rebooted the router (via the GUI) and the laptop (reboot, not shutdown)?

How far away are you from the router? What firmware is the router running? When was the last time you reset the router to factory defaults and then minimally and manually configure it without using a saved backup config file?
 

Woods1ee

New Around Here
I've got a similar issue, got a RT-AX58U as the main router, a RT-AC88U node, and trying to get a RT-AX55U node working but it keeps dropping out every 30 seconds after reboot and doesn't reconnect. Any help would make my day!
 

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top