What's new

ASUS RT-AX58 - Firmware version

  • SNBForums Code of Conduct

    SNBForums is a community for everyone, no matter what their level of experience.

    Please be tolerant and patient of others, especially newcomers. We are all here to share and learn!

    The rules are simple: Be patient, be nice, be helpful or be gone!


Regular Contributor
Yesterday my RT-AX58U router found this new firmware. It isn't posted here or on the official Asus firmware download pages.
So no changelog (yet)
Bug Fixes and Enhancements:
- Improved AiMesh backhaul stability.
- Resolved the issue with login and password changes.
- Enabled WireGuard Server clients to access the Samba server.
- Enabled the failback function when using the iOS/Android USB backup WAN.
- Improved Wireguard performance.
- Enabled DynDNS and No-IP DDNS to use IPv6.
- Improved memory utilization and fixed an occasional server error when registering DDNS with an app.
- Modified the USB application option text in dual WAN.
- Added DS-Lite Support.
- Fixed ipv6 network service filter issues
- Fixed the IPsec VPN compatibility issue with Win10.
- Fixed the reboot issue when assigning specific clients in VPN fusion.
- Fixed the time display issue for the preferred upgrade time in the Auto Firmware Upgrade function.
- Resolved the IPSec VPN and Instant Guard connection issues.
- Resolved an issue that caused hostname errors in the DDNS service.

Security updates:
- Enabled and supported ECDSA certificates for Let's Encrypt.
- Enhanced protection for credentials.
- Enhanced protection for OTA firmware updates.
- Enhanced protection against SSH brute force attacks.
- Fixed several curl vulnerabilities.
- Fixed command injection vulnerability.
- Fixed the ARP poisoning vulnerability.
- Fixed code execution in custom OVPN.
- Fixed the injection vulnerability in AiCloud.
- Fixed stack buffer overflow in lighttpd.
- Fixed CVE-2023-35720
- Fixed the code execution vulnerability in AiCloud.
- Fixed the XSS and Self-reflected HTML injection vulnerability.

the firmwares releases are getting farther apart but we sure do get a lot of changes in them.

downloading it now.
They also added freemyip.com DDNS provider but didn't mention it in the changelog.
Upgraded from Merlin 388.6_2 a few hours ago (Merlin 388.6_2 -> Asuswrt 386.45898 -> Asuswrt 388.24762) and everything works fine.
RT-AX3000 version posted as well:

This is exactly the same router running exactly the same firmware. Different marketing only.
I know, but it does have its own webpage and the file says AX3000.. :)

FWIW, I installed this on mine this morning, haven't seen any issues. (But am simple- no mesh or anything.).

I know, but it does have its own webpage and the file says AX3000.. :)

FWIW, I installed this on mine this morning, haven't seen any issues. (But am simple- no mesh or anything.).

It broke my AiMesh system reboot (booting master and nodes in sync). And if I just boot the master node, a day or later the secondary node will disconnect itself from the master node from admin web page point of view. I can still get LAN connection to Internet on secondary node, but the admin web page won't see it and declared it is disconnected.
Haven't done the full reset / restore setting trick yet.

UPDATE: after 30 minutes of manually rebooted the secondary node, now the AiMesh/System Settings/System Reboot is willing to boot BOTH my master node and secondary node. How strange...
After more than 24 hours of use, I would say the new firmware (388.24762) really has some issues, at least on web admin UI.
The AiMesh connection would disappear (Disconnected status) from the admin page from time to time, you leave it alone for a few minutes, login again, and it will come back. The connected devices on the second node cannot be seen but to gradually appear.
On the network side, it looks like working normally, both the wired and wireless network on the second node.
Tried AiMesh System Reboot, power off/on the devices physically, with no apparent improvement.
Did think about to revert the firmware to previous version, but given it doesn't have any actual networking issue, I decide to keep it for a while and see if Asus would come up with a firmware update.
p.s. Mine is a pair of RT-AX3000, with wired backhaul to run AiMesh. The web admin UI is run on a MacBook Safari browser.
anyone else have a bunch of gibberish characters when viewing the client list on the network map ?


Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!