Asus RT-AX86U 160 Mhz channel falls back on 80 Mhz

  • ATTENTION! As of November 1, 2020, you are not able to reply to threads 6 months after the thread is opened if there are more than 500 posts in the thread.
    Threads will not be locked, so posts may still be edited by their authors.
    Just start a new thread on the topic to post if you get an error message when trying to reply to a thread.

pmmusale

New Around Here
I am currently running latest version 386.1 of Merlin firmware on RT-AX86U. I have two laptops with Intel AX200 which are connected on 5 Ghz channel. Whenever I reboot my router, both of those laptops show connected to 160 Mhz channel. But after some time wifi logs show connection at 80 Mhz. At laptop side connection speed drops from 2.4gbps to 1.2gbps. This was happening on beta firmware as well but I upgraded to latest firmware few days ago and still find this as an issue. I tried to renew leases from laptops but it didn't work. I have to reboot router to again see 160 Mhz connection.

Is this a bug? Did anybody experience this and have any solution?
 

KingBravery

Senior Member
This is not a bug. This is because your place is near the weather radar. 160MHz in USA only available at channel 100-128. The weather radar also use that channel. So, if router detect usage of weather radar, it will change to non dfs channel (149-161) and that channel cant use 160MHz.
 

pmmusale

New Around Here
Thanks. I live in residential area so I thought there won't be any radar usage. How can I make sure there is radar station near me?
 

Sobster88

Occasional Visitor

If you’re within 10 miles, 160mhz will turn off fairly quickly. Within 20 it may work for a while but will probably pick up interference from time to time and turn off.

Another factor would be airplane traffic as I believe the weather radar from aircraft will kick it off as well. So if you’re near a main flight path, even if the planes are a ways above you, that will trigger 160mhz to turn off as well.
 

pmmusale

New Around Here
Thanks details. If 160 Mhz channel turned off after interference with radar, is there an option to automatically turn it on back when interference is gone?

I am able to connect using rebooting or reapplying 5 GHz wifi settings again. But that means I have to monitor when it's dropped to 80 Mhz and then go to router to go for 160 Mhz again.
 

Sobster88

Occasional Visitor

pmmusale

New Around Here
Thanks for script. I am investing in 2.5gbE switch so that should eliminate need for 160 Mhz band. If that band is getting disconnected multiple times in a day, then I would want to interfere with any active radar in my vicinity.
 

dlandiss

Very Senior Member
Thanks details. If 160 Mhz channel turned off after interference with radar, is there an option to automatically turn it on back when interference is gone?

I am able to connect using rebooting or reapplying 5 GHz wifi settings again. But that means I have to monitor when it's dropped to 80 Mhz and then go to router to go for 160 Mhz again.
Could you enlighten me what makes 160MHz channels attractive? A streaming movie takes less than 5MHz of download bandwidth, so even at 5GHz/80MHz settings you should be able to stream at least 10 movies at once.

BTW, thank you for your correct use of the GHz and MHz abbreviations -- a clarity not found often enough on these forums.
 

tallytr

Senior Member
Same thing in Vancouver Canada area. Router switches to 80MHz after a coupe days or a week max.
I have a weekly reboot scheduled...
Sure, you can always manually set 160MHz but then you are Wi-Fi 6 (AX) only....
 

kernol

Very Senior Member
Same thing in Vancouver Canada area. Router switches to 80MHz after a coupe days or a week max.
I have a weekly reboot scheduled...
Sure, you can always manually set 160MHz but then you are Wi-Fi 6 (AX) only....

Fully aware that Channels vary from region to region - but here is my setup on my RT-AX86U which is rock steady - sticks on 160MHz and happily accommodates OLD 5GHz clients including a 2013 MacBook Pro - while at the same time delivering full speed to latest Wi-Fi 6 AX devices.

2021-05-28 05_55_16-ASUS Wireless Router RT-AX86U - General.jpg


Control Channel 128 may be a problem for you in Canada - may need to try 149?

EDIT: - Useful link on Channels here ...
https://en.wikipedia.org/wiki/List_of_WLAN_channels
 
Last edited:

tallytr

Senior Member
I’ll try that, many thanks!
Anything suggesting not to use 36 (my default for years….)
 

kernol

Very Senior Member
I’ll try that, many thanks!
Anything suggesting not to use 36 (my default for years….)
Not sure - I'm in South Africa - and Channel 36 did not work too well for me at 160MHz ... I only got full stability at Channel 128 [which is clear of DFS etc here in RSA.]
According to Wikipedia link - it looks like Channel 36 will give you 160MHz ... with some potential overlap with DFS in the upper range.

Worth a try - but the other settings in the pic of my setup were required as well.
 

dev_null

Senior Member
I made a related comment in this thread: https://www.snbforums.com/goto/post?id=691183.

I am partial to the DFS channels because I'm in a low/no-radar area and no neighbors have hardware that can use UNII-2/UNII-2 Ext channels, so I get those to myself. I have encountered the channel change on one or two occassions, but I have a solution for that.

For me the solution is to be notified if radar is detected with a cronjob, which checks the log for the word radar and then emails me using the div-email script described in the vnStat-on-Merlin thread. This updated version of the cronjob then deletes the line containing the word Radar and cleans up the notifications. (Yes I could do this is script form, but concatenation is fun!)

Code:
cru a radar_detect "7 4 * * * grep Radar /opt/var/log/messages > /opt/var/log/radar.txt && sh /jffs/scripts/div-email.sh 'Radar detected - check channel' /opt/var/log/radar.txt  && rm /opt/var/log/radar.txt && sed -i '/Radar/d' /opt/var/log/messages 2>/dev/null || echo 'No radar detected'"

Note: I then need to manually restart wireless via the gui. I tried using adamm's channelhog script but found that the commands embedded in his script did not respect the channel selection in the gui, they simply restarted the 5GHz radio on whatever automatic channel had been selected. Likely working as intended but not fit for my purposes - I want it to restart on the specified DFS channel (either 100 or 104). Since it's only happened once in three months, and that was quite likely a false-positive, manually restarting from the UI is not an issue.

Note2: some devices (Roku, Amazon) don't pick up DFS channels, so you'll need to decide if the trade-off is worth it.

Note3: I'm using uiScribe so your log file location may differ.
 
Last edited:

Similar threads

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top