Solved ASUS RT-AX86U network performance issues

  • ATTENTION! As of November 1, 2020, you are not able to reply to threads 6 months after the thread is opened if there are more than 500 posts in the thread.
    Threads will not be locked, so posts may still be edited by their authors.
    Just start a new thread on the topic to post if you get an error message when trying to reply to a thread.

Sanek2k6

Occasional Visitor
Hello!

I just got the new ASUS RT-AX86U to replace my old ASUS RT-AC1900P that was having constant wifi stability issues. However as soon as I ran the first speed test, I knew something was definitely wrong.

I have a 1Gbit down/30 Mbit up connection through my ISP (Rogers) using a Technicolor CGM4140COM gateway (rev 2.2) in Bridge Mode. Speed test directly against the modem (Modem --- PC) gives ~850Mbit down/32Mbit up at the time of testing. While connected through the router (Modem --- Router --- PC), testing against the same speed test server gave 300 Mbps-400 Mbps down (no issues with upload).

Router's CPU was barely even used during this test, so it was not being overloaded by any means and all the advanced features (AI/Game/QoS, etc) were disabled by default, so those werent slowing anything down.

Went to check the router's firmware update page and the check would fail. Thinking it was something to do with their update servers, I updated it manually to the latest (3.0.0.4.384_9318-gdbf18b0), which did not seem to help anything. I then noticed that the DST settings were wrong by default for Canada and once fixed, the router was able to check the ASUS router firmware page now (probably the previous issue was due to TLS failing because of the large time drift). Fixing that seemed to improve the download speeds somewhat:
1603727844206.png


Still well shy of the 800 Mbps+ that I see when connected directly. Funny thing is that I see it get up to almost 700 Mbps when testing wirelessly from my iPad Pro, so I think its maybe something weird going on with the LAN?
  • I tested both plugging LAN into the 2.5 Gbit port on the router and setting up that port for WAN to see if there was any improvement - and there wasn't (other than IPV6 refusing to work over that port).
  • Having IPV6 enabled or disabled also didnt seem to give any performance improvement either.
  • Everything shows up as 1 Gbps for WAN/LAN ports in the Status page.
  • Performed factory reset multiple times, which did not resolve the issue.

Hoping someone has any ideas what might be going wrong here.



// Edit:

Solution: After lots of testing, looks like it might be some sort of incompatibility between this router and the Intel Ethernet chipsets. Bought a 2.5 Gbe card with a Realtek 8125 controller and seems to be good so far. So not actually a good solution and definitely questions with the Intel controllers that I've tested, but at least got things working on my end.
 
Last edited:

Sanek2k6

Occasional Visitor
Would RMA even help here? The pings seem fine and its not rebooting or anything - just the performance is not as good as it should be, which could be a firmware issue? Has anyone here tested it with a gigabit WAN?
 

stevechan

New Around Here
I had a similar issue as you are having now. My download speed was around 500 on a LAN connection. I resolved the issue by turning off QOS.
 

Nicerouter103

New Around Here
I'm capped at 300 mbps on a 1gb connection after recent firmware update. Flashed back no issue. Flashed to most recent capped at 300 mbps. All things turned off qos and so forth.
 

L&LD

Part of the Furniture
Wired or wireless?
 

L&LD

Part of the Furniture
What about testing with a laptop that is plugged in to AC power and set to performance mode?

What about testing with a new SSID?
 

Smokindog

Senior Member
If you've got two windows devices, I've had good look with Netstress to isolate testing. It may be available on other platforms but I've never looked. You can eliminate your WAN/MODEM/ISP and see if you've got issues with your router.


Just thinking out loud.
 

Nicerouter103

New Around Here
1603814402085.png


iperf from phone to wired laptop on router. Same limit when using SpeedTest.Net

Wireless log:

1603814555517.png


Phones are 802.11ax 80 mhz capable. In diagnostics on phone connected to 802.11ax

Can't flash back to do test on old firmware right now. Will later.

Previously achieved 800+ speed test on phone averaged 670-800 on phone.

300 ish looks to be cap can see speed test being throttled.

Wired clients are not effected.
 

Sanek2k6

Occasional Visitor
Running iperf3 between 2 PCs on my network over LAN/Ethernet, gave me results between 750 Mbit and 870 Mbit, which is somewhat lower than what I would expect. Running 4 clients in parallel gave me results as high as 941Mbit, which is really the realistic maximum I would expect with a gigabit connection. So again, not sure what to make of it - leaning towards exchanging it at Best Buy.

//Edit: note how much slower WAN to LAN (Ethernet) is than the WIFI:
Modem --- Router --- PC (Ethernet)
1603897643198.png


Modem -- Router -- iPhone (WIFI)
1603897669890.png


If no one else is seeing the same thing then I definitely need to replace it.
 
Last edited:

Sanek2k6

Occasional Visitor
Test direct to the modem (and it was still going up when the test was finished):
1604012230465.png


Talked with ASUS and they consulted with the engineers and decided its probably a hardware issue. They wanted me to send it back to them, but I opted to just exchange it at Best Buy here tomorrow and will see if the replacement is any better. It is so odd to see this issue - I've never seen a case where WIFI is so much faster than Ethernet.

As a side note, it was kinda nice to actually have an option to talk to someone at ASUS - maybe its me, but I seem to remember them just not having any real support at all beyond the community forums.
 

SoCalReviews

Senior Member
Good to know you were able to talk with Asus engineers. Let us know how the replacement works out.
 

Sanek2k6

Occasional Visitor
Well, swapped out the router today and the replacement seems to have the same issues. I have not updated the firmware to the latest yet, but pretty disappointed so far - so much for the hardware issue theory.

I will update the firmware and see if it gets any better, but maybe it’s some weird issue between this router and my modem?

I’ve seen other reports here about the AX routers showing much lower wired speeds than the AC ones, so I wonder if it’s some weird incompatibility issue or something.
One interesting thread is here:

Although it doesn’t really help that much :(
 

Sanek2k6

Occasional Visitor
The firmware update improved things a bit, but its still far from the expected speeds over wired.

At this point, I wanted to check a few things via SSH:

The only thing that jumped out at me as not being normal are the couple of hundred dropped RX and 13k dropped TX packets (mostly TX), as reported by the router via ifconfig for ETH7 (so I think that means transmitted to my PC?). ETH0 had 0 dropped RX and 0 dropped TX. There were no errors.

I tried turning off both modem and router for a while, then powering up the modem, then the router, then plugging in the WAN, then LAN. Also tried changing out all the cables to completely different ones and that didnt help either.

I do wonder if its some weird incompatibility with my modem, but I'm out of ideas. A test from my iPad Pro 11" 2020 gave 727 Mbps download speed over Wifi about a meter away from the router, so there is definitely something weird going on with the wired connection, but I'm not sure what else I can check.
 
Last edited:

KingBravery

Regular Contributor
Can you try just use 80Mhz instead of 160Mhz? This is just suggestion to try. I'm afraid that maybe 160Mhz give interference to unshielded (UTP) LAN cable.
 

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top