Release ASUS RT-AX88U Firmware Version 3.0.0.4.386.48631 (2022/04/25)

LimJK

Very Senior Member
Version 3.0.0.4.386.48631

2022/04/25 71.86 MBytes

ASUS RT-AX88U Firmware version 3.0.0.4.386.48631
1. Fixed OpenSSL CVE-2022-0778
2. Fixed CVE-2021-34174, CVE-2022-0778
3. Added more security measures to block malware.
4. Fixed Stored XSS vulnerability. Thanks to Milan Kyselica of IstroSec.
5. Fixed CVE-2022-23970, CVE-2022-23971, CVE-2022-23972, CVE-2022-23973, CVE-2022-25595, CVE-2022-25596, CVE-2022-25597
6. Added 3rd party DNS server list in WAN --> DNS to help users enhance the connection security.


Please unzip the firmware file first then check the MD5 code.
MD5: 532dc2f4396429ee499fdd6218975538
 
Last edited:

LimJK

Very Senior Member
I decided to hit the GUI Upgrade Firmware button :p
Successfully upgraded for my configuration :)

Edit: Running for 10 hours, still working for my configuration, all Wired and Wireless Devices connected to my AiMesh Router or AiMesh Node(s) do not have any connection issue "yet".
 
Last edited:

Fyew-jit-tiv

Regular Contributor
This firmware has stopped clients from connecting to the node via wifi. Also all clients connected to node via ethernet does not show up under Aimesh. Reverting back to previous firmware solves problem.

Running 2 x Ax88u
 

Gregory Phillips

Very Senior Member
I just flashed to it and will report back if I experience any issues with it. So far all clients reconnected successfully after the reboot.
 

Yakkosmurf

Occasional Visitor
This firmware has stopped clients from connecting to the node via wifi. Also all clients connected to node via ethernet does not show up under Aimesh. Reverting back to previous firmware solves problem.

Running 2 x Ax88u
Good to know. I have 2 AX88Us as nodes to an AX89X via wired backhaul. I guess I'll try the update and see what happens and report back tomorrow.
 

andy352

New Around Here
Running new firmware without issue on RT AX88u. New firmware on RT AX58u (node) will not work via wireless backhaul, reverted back on RT AX58u. AiMesh working with new firmware on RT AX88u and old firmware RT AX58u wireless backhaul (node).
 

Fyew-jit-tiv

Regular Contributor
Running new firmware without issue on RT AX88u. New firmware on RT AX58u (node) will not work via wireless backhaul, reverted back on RT AX58u. AiMesh working with new firmware on RT AX88u and old firmware RT AX58u wireless backhaul (node).
Im using a wired backhaul (AX88U) and wifi devices cannot connect to the node. These two problem sound related. Do you manually install the update?
 

d5aqoep

Regular Contributor
This firmware has stopped clients from connecting to the node via wifi. Also all clients connected to node via ethernet does not show up under Aimesh. Reverting back to previous firmware solves problem.

Running 2 x Ax88u

Same setup and no issue here with AiMesh



  1. Reboot your primary router.
  2. Removing the node.
  3. Let it reset itsefl and reboot
  4. Add it back again.
 

Fyew-jit-tiv

Regular Contributor
This is what happens when i disable 2.4ghz mode. GUI shows i have disabled 5ghz and the 2.4 ghz isn't visible. FTR i dont use 2.4ghz as all my wireless devices sit on the 5ghz spectrum and the router is using Ethernet backhaul mode.
 

Attachments

  • Screenshot 2022-04-26 121156.jpg
    Screenshot 2022-04-26 121156.jpg
    66.3 KB · Views: 121

d5aqoep

Regular Contributor
Been there done that, Doesn't work as advertised!
That's only for you.

Here it's working as advertised.



Why don't you do a full reset from ssh.
  1. Remove node first
  2. ssh [email protected] (Whatever is your router's IP)
  3. enter password and pass the command in that ssh session:
  4. hnd-erase nvram
  5. Turn off the router from mains and not via reboot command.
Set up the router as new. OR swap the node to main and try again.
It is also worth checking out if the LAN cable you are using to connect 2 routers isn't faulty. Some firmwares can have low fault tolerance.
 
Last edited:

Fyew-jit-tiv

Regular Contributor
That's only for you.

Here it's working as advertised.



Why don't you do a full reset from ssh.
  1. Remove node first
  2. ssh [email protected] (Whatever is your router's IP)
  3. enter password and pass the command in that ssh session:
  4. hnd-erase nvram
  5. Turn off the router from mains and not via reboot command.
Set up the router as new. OR swap the node to main and try again.
It is also worth checking out if the LAN cable you are using to connect 2 routers isn't faulty. Some firmwares can have low fault tolerance.
Done it all and still having this problem. Just because its working for you doesn't mean there isn't a firmware problem. My router settings may differ to yours which could be the source of this problem.

The problem isn't the ethernet cable because wifi devices cannot connect to the node on 5 or 2.4 so a faulty ethernet on wired backhaul wouldn't prevent a wireless connection to that node. @andy352 says he cant connect using wireless backhaul (different setups) but very similar problem. Seems to be a problem on the main router because setting the node back to previous firmware produces the same problem whilst using the main router on new firmware.
 
Last edited:

neil0311

Senior Member
Upgraded to this firmware using the auto update function. It corrupted something. When the router rebooted, it took me to the setup screen and made me go through the setup GUI before it would show me the admin console. Some settings were still as set. Others went back to default.
 

Fyew-jit-tiv

Regular Contributor
Upgraded to this firmware using the auto update function. It corrupted something. When the router rebooted, it took me to the setup screen and made me go through the setup GUI before it would show me the admin console. Some settings were still as set. Others went back to default.
Looks like Asus QC isn't as good these days. :mad:
 

dathbe

New Around Here
Am I right that this release does NOT include the Wireguard VPN option? If it does, I would consider taking the chance upgrading for the feature. Otherwise, I might wait for the cleanup release based on some of the issues people are having.
 

RMerlin

Asuswrt-Merlin dev
Am I right that this release does NOT include the Wireguard VPN option? If it does, I would consider taking the chance upgrading for the feature. Otherwise, I might wait for the cleanup release based on some of the issues people are having.
Don't expect Wireguard to appear until their next major (RC3) release, which probably means either they will bump from 386 to 388, or at least a version higher than the current RC3 version (386_57xxx).
 

dathbe

New Around Here
Don't expect Wireguard to appear until their next major (RC3) release, which probably means either they will bump from 386 to 388, or at least a version higher than the current RC3 version (386_57xxx).
That's disappointing, but thanks for the response. Is there any sense of when that might happen? (e.g., this year? next year? 2035?)
 

RMerlin

Asuswrt-Merlin dev
That's disappointing, but thanks for the response. Is there any sense of when that might happen? (e.g., this year? next year? 2035?)
They haven't announced any public timetable yet.
 

PR3MIUM

Regular Contributor
maybe we see soon another update because of the new critical CVE-2022-26674 from 04/22 ?
 

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top