What's new

ASUS RT-AX88U vs Nest Wi-Fi

Tommy Grace

Regular Contributor
Hi guys, after a bit of possible help here. I have both the RT-AX88U and a Google Nest Wi-Fi (bought this when my AiMesh stopped working due to firmware upgrades). Anyway what i am trying to understand is why they seem to manage traffic so differently. There are some very obvious differences between the 2 platforms which is fine but one issue i have seen with the ASUS is how it manages wireless traffic, especially when congested. What i am seeing happens regardless of QoS settings. Basically what happens is that when i use anything like Wi-Fi sweetspots or a Wi-Fi analyzer, or if a device on the LAN is downloading large amounts of data on the Wi-Fi, the latency on the LAN (wireless) goes right up and can even lead to packet loss. This also happens if i run a speedtest. Now some of this is to be expected i suppose but the reason i am questioning the ASUS setup is that if i do all of these same tests when on the Nest Wi-Fi, there is no impact on latency and there is no packet loss. One thing i have noticed is sometimes the speedtest may return a slightly lower speed i.e -1 Mbps but other than that everything seems fine. It is almost as if the Nest Wi-Fi software is handling and shaping the traffic better. So although raw speeds may not always be quite as high, in real world use it gives a better experience. Hope this all makes sense? I have tried all sorts of different configuration options but nothing seems to make a difference. I am currently running Merlin 3.184.18 but have also tried this on stock firmware. Interested in your thoughts.
 

L&LD

Part of the Furniture
Different hardware, different firmware, different (enabled or disabled) options from the SoC's used. Makes sense.

Could also be some slight incompatibilities between that firmware/options enabled on that SoC and the specific client devices you use.

One of these suggestions may also be able to 'solve' the issue too.


Have you tried RMerlin firmware on the RT-AX88U? The latest 384.19 Beta 1 is performing very well for many.

See my signature below for the M&M Config and the Nuclear Reset guides to follow if you want to test RMerlin firmware for yourself.

Before you do, make sure to make a backup of the config and the JFFS partition and save it along with a copy of the firmware you are using right now. So, you can easily go back to where you are now, after testing, if you decide to go back. :)
 

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top