Asus RT-AX92U 160Mhz bandwith ignored

  • ATTENTION! As of November 1, 2020, you are not able to reply to threads 6 months after the thread is opened if there are more than 500 posts in the thread.
    Threads will not be locked, so posts may still be edited by their authors.
    Just start a new thread on the topic to post if you get an error message when trying to reply to a thread.

Danixu

Occasional Visitor
Hello,

I bougth this router recently and I have noticed that doesn't enable the 160Mhz Bandwidth into the 5G-2 band. I'm able to enable it sometimes, but a few time later it's lowered to 80Mhz again.

I have tried almost everything I know:
  • reset the router
  • install different firmware versions using normal procedure and rescue mode
  • using the beta version
  • change the bandwidht from 20/40/80/160 to only 160
  • Changed to a fixed channel
  • Using WPA2 and WPA3
Nothing worked and is even ignoring some of the configurations I made, for example, now I have configured the router to 160Mhz and channel 100, and it is using a 40Mhz bandwidth at channel 132. I don't know if I am doing something wrong, it doesn't like my face... but I am starting to hate this router.

Is there any way to configure this router at 160Mhz bandwidth?, because my cards are compatible and the difference from 866Mhz to 1.7Gbps is notorious.

Best regards and thanks.
 

KingBravery

Senior Member
maybe your area got weather radar. that's why it change back to 80MHz
 

Danixu

Occasional Visitor
I see, I didn't know about that. Is possible to check it in any way?. Now after doing a lot of changes without sucess, I have changed the channel again to 116 and seems to be working at 160Mhz (Finally I have a 2.4Gbps link!). I don't want to change anything to avoid to have the same problem again, but if is related to a wheather radar then maybe will go back to the 80Mhz Bandwidth. Will be good to know before send the router back thinking that is not working properly.
 

dev_null

Senior Member
I see, I didn't know about that. Is possible to check it in any way?. Now after doing a lot of changes without sucess, I have changed the channel again to 116 and seems to be working at 160Mhz (Finally I have a 2.4Gbps link!). I don't want to change anything to avoid to have the same problem again, but if is related to a wheather radar then maybe will go back to the 80Mhz Bandwidth. Will be good to know before send the router back thinking that is not working properly.
Look in the logs to see if radar is detected. I'm using scribe but see Jun 11 07:04:18 RT-AX86U-C9C9 wlceventd: wlceventd_proc_event(632): eth7: Radar detected

Sometimes with more detail:
Code:
Apr 14 07:04:16 RT-AC66U_B1-BCBC kernel: SKIPPED false Type 7 Radar Detection. min_pw=1 pw_delta=0 pri=5545 fm_min=1030 fm_max=0 nconsecq_pulses=6. Time from last detection = 234296, = 3904min 56sec. Detected pulse index: 17

Apr 14 07:04:16 RT-AC66U_B1-BCBC kernel: Type 0 Radar Detection. Detected pulse index=17 fm_min=1030 fm_max=0 nconsecq_pulses=6. Time from last detection = 0, = 0min 0sec

Apr 14 07:04:16 RT-AC66U_B1-BCBC kernel: Type 7 Radar Detection. Detected pulse index=4 fm_min=1030 fm_max=0 nconsecq_pulses=6. Time from last detection = 0, = 0min 0sec

Apr 14 07:04:16 RT-AC66U_B1-BCBC syslog: eth2: Radar detected, rssi:0
 

Danixu

Occasional Visitor
Look in the logs to see if radar is detected. I'm using scribe but see Jun 11 07:04:18 RT-AX86U-C9C9 wlceventd: wlceventd_proc_event(632): eth7: Radar detected

Sometimes with more detail:
Code:
Apr 14 07:04:16 RT-AC66U_B1-BCBC kernel: SKIPPED false Type 7 Radar Detection. min_pw=1 pw_delta=0 pri=5545 fm_min=1030 fm_max=0 nconsecq_pulses=6. Time from last detection = 234296, = 3904min 56sec. Detected pulse index: 17

Apr 14 07:04:16 RT-AC66U_B1-BCBC kernel: Type 0 Radar Detection. Detected pulse index=17 fm_min=1030 fm_max=0 nconsecq_pulses=6. Time from last detection = 0, = 0min 0sec

Apr 14 07:04:16 RT-AC66U_B1-BCBC kernel: Type 7 Radar Detection. Detected pulse index=4 fm_min=1030 fm_max=0 nconsecq_pulses=6. Time from last detection = 0, = 0min 0sec

Apr 14 07:04:16 RT-AC66U_B1-BCBC syslog: eth2: Radar detected, rssi:0

Thanks!!, I'll take a look into it to see if that was the problem.

Thanks again to both.
 

Tech9

Very Senior Member
I don't want to change anything to avoid to have the same problem again

Now your entire 5GHz band is going down if radar is detected. You have to decide what do you want - speed or reliability.
 

Danixu

Occasional Visitor
For now there are no changes in bandwidth, but I am watching to it occasionally to see if changes. Fortunately is a tri-band router, so it also uses the another 5G band range for an 80Mhz channel and I will not notice too much if the 160Mhz band goes down. If I see that the 5G-2 is down because a Radar, I'll change it back to 80Mhz again.
 

Danixu

Occasional Visitor
Well, finally looks like the radar was here again and the bandwidth has changed to 80Mhz. I am not able to find any info about it in logs but seems to be the reason. Was fine during the night, and in the middle of the morning has changed. I bought a Wifi6 card and at least I have about 50% more of speed, so 160Mhz bandwidth is not required anymore to reach the full internet speed now.

Thanks to all.
 

dev_null

Senior Member
Well, finally looks like the radar was here again and the bandwidth has changed to 80Mhz. I am not able to find any info about it in logs but seems to be the reason. Was fine during the night, and in the middle of the morning has changed. I bought a Wifi6 card and at least I have about 50% more of speed, so 160Mhz bandwidth is not required anymore to reach the full internet speed now.

Thanks to all.
Huh, I'm surprised Official firmware logs don't reflect a reason for the change in BW. Or I suppose it could be unrelated to radar detection.

Do your logs mention "event: wl_chanspec_changed_action"? If so, what are the lines proceeding that?

(Note: to search you may need to download the log... if that can be done on Official.)

(Note 2: if you ever upgrade to Merlin, I have a script that can run periodically to email you if the channel changes. But it won't run on Official b/c scripting doesn't work - or at least work as easily.)

(Note 3: actually if you upgrade to Merlin, Adamm's Channelhog script can force 160mHz channel.)
 

Danixu

Occasional Visitor
Yep, the first I have searched if a Merlin firmware for my router, but no luck :rolleyes:

In the official and the original router version, I am only able to see messages related to 2.4Ghz channels like this:
acsd: eth5: selected channel spec: 0x100d (13)

At least the message about why has changed the channel on 5Ghz band should appear, but nothing. After upgrading to the latest version, some messages has started to appear about the channel changes in 5Ghz band, but nothing about the radar:
acsd: eth6: selected channel spec: 0xe03a (52/80)
acsd: acs_set_chspec: 0xe03a (52/80) for reason APCS_INIT
kernel: wl1: chanspec: 0xe03a (52/80)

I am not able to see anything that tell me "Hey, this was a change because a radar" or something, they are just simple and repeated along the day.

Best regards
 

leerees

Senior Member
It seems like you are unfortunately being hit by radar. However, one setting (in addition to what you've already done) that you should select is "AX only"

This will prevent AC devices joining that band and slowing it down.
 

Techtype

Occasional Visitor
It seems like you are unfortunately being hit by radar. However, one setting (in addition to what you've already done) that you should select is "AX only"

This will prevent AC devices joining that band and slowing it down.
Would you post a screenshot showing the location of that setting?
 

Danixu

Occasional Visitor
It seems like you are unfortunately being hit by radar. However, one setting (in addition to what you've already done) that you should select is "AX only"

This will prevent AC devices joining that band and slowing it down.


Yes, please, share the location of that option. I was searching for it but I have not found anything related.

Best regards.
 

ColinTaylor

Part of the Furniture
I will be amazed if he can show it with current firmware!
Are you saying that it's been removed in the current firmware?
Untitled.png
 

ColinTaylor

Part of the Furniture
I would say that your screenshot is not from RT-AX92U ...
You are correct. Sorry I thought you were talking about a change that would effect all AX models rather than just the RT-AX92U.

So you're saying that this option has been removed from the RT-AX92U firmware, or that it never had it in the first place?
 

Techtype

Occasional Visitor
You are correct. Sorry I thought you were talking about a change that would effect all AX models rather than just the RT-AX92U.

So you're saying that this option has been removed from the RT-AX92U firmware, or that it never had it in the first place?
Well, all I can say is that I've been all over the RT-AX92U options and it's never been there in my experience. But, I would love for someone to prove me wrong in the current firmware.
 

Similar threads

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top