Dismiss Notice

Welcome To SNBForums

SNBForums is a community for anyone who wants to learn about or discuss the latest in wireless routers, network storage and the ins and outs of building and maintaining a small network.

If you'd like to post a question, simply register and have at it!

While you're at it, please check out SmallNetBuilder for product reviews and our famous Router Charts, Ranker and plenty more!

Asus RT-N66U Merlin router, no GUI

Discussion in 'Asuswrt-Merlin' started by J Angel, Oct 11, 2017.

  1. J Angel

    J Angel New Around Here

    Joined:
    Oct 11, 2017
    Messages:
    2
    I am a networking novice, and I obviously messed up somewhere. My router has been working great with Merlin for about 2 years. I wanted to route my web browsing at work through my home router (for privacy reasons). I opened up SSH on the router, then I connect via PuTTy from work and rout internet traffic through my home router.
    It seems to be working great. But now when I try to connect to the GUI of the router at home at 192.168.1.1. I get "This page cannot be displayed". The router works great, I just can't get to the logon page. I can, however, SSH to it.

    I'd rather not factory reset it. I've made tweaks over the years for Plex, home security, and Parental controls.

    Any thoughts on what I may have done to mess this up? At least with SSH access I have a chance to fix it, if I know what I did wrong.

    I have done a quick search and didn't find anything...yet. I thought I'd post, then continue my searching.

    Thanks!
     
  2. jim769

    jim769 Very Senior Member

    Joined:
    Jul 18, 2013
    Messages:
    741
    Location:
    USA, Michigan
    Are you using a up to date firmware ? If not you will need to upgrade and factory reset if you want a secure network. Then you can address your question. There have been a ton of security updates and patches in two years.
     
  3. J Angel

    J Angel New Around Here

    Joined:
    Oct 11, 2017
    Messages:
    2
    I updated the firmware about six months ago. I don't know what version because I can't log in :)

    Is there anything I can do via SSH to undo whatever is preventing me from logging in via web? I know that's a vague question. Sorry. I don't know why turning on SSH would cause this problem.

    Believe me. If/when I get back in to this thing I will make a backup and update to latest firmware immediately.
     
  4. heysoundude

    heysoundude Regular Contributor

    Joined:
    Sep 20, 2016
    Messages:
    90
    have you tried to login to the GUI using https?
    https://192.168.1.1:8443 should get you to the login page. You'll likely have to ignore the cert error/warning, but that shouldn't be a problem from a machine at home.
     
  5. st3v3n

    st3v3n Occasional Visitor

    Joined:
    Feb 24, 2016
    Messages:
    17
    Location:
    Central US
    J Angel: I've been running RMerlin's FW on our Asus routers for years from the N66W and 3 others, to the RT-AC3200. With the latest Merlin release, the newer security concerns listed elsewhere left me with no choice, but to upgrade to 380.68_4, as soon as RMerlin released it; I generally wait a few days, but there are seriously evil dudes online; you may consider updating and saving more often. Asus can't keep our routers as tight as RMerlin does. His work on his fork is considered far superior to theirs,IMO and notwithstanding John's fork. The last update was the smoothest one I ever experienced and has worked extremely quickly, and I didn't lose a single setting. YMMV. I always back the FW and configs up before and after I update, just in case. Last week I powered the AC3200 down after adding a new opnvpn client config, to be sure nothing was left in memory that shouldn't be there. For the first time ever, I lost access to the router GUI; there was no reason. I still had partial connectivity but the GUI wouldn't come up. I was fairly sure that indicated the router was salvagable. I followed all of the instructions in RMerlin's FAQ to the letter, but nothing doing; the GUI didn't come up. I thought about it for a while. I kept after it and was begining to get the idea that things might be worse than they should be; it's worrisome. What finally worked for me, was to remain calm, and to take longer during each step of the cycle; with an N66, that will take longer still. I turned the power off to the router. I actually cut the power going to it. I have seperate A/C switches for each part of the system, rather than to fiddle with the router power button. Sometimes the router power button gets flakey and doesn't turn off completely, or isn't held in long or firmly enough. I held the WPS Button button in for a full minute, then still holding it in, flipped the power switch, keeping the WPS button firmly depressed. Then, I briefly pushed the router power button in until the LEDs lit up, then released the -power button only-; still holding the WPS button for for over a munute, until almost all of the LEDs began flashing rapidly, not completely in unison but enough, so I knew it was enough. I released the WPS button,then sat back, watched and waited. Another minute went by. Finally the red LED came up on the 3200 and stayed on. I waited a another minute, then tried 192.168.1.1 in the browser but the GUI wasn't budging; yet. I waited another minute, and then -whoopie- the GUI came up, with empty admin/password fields; it was back to RMerlin 'stock' so to speak. I re-entered all my ID/passwords, revising them later; you could use admin/admin if you're in a rush. Be sure your firewall is up before moving on. I was surprised after 2-3 hours of futzing around, with so many failed attempts including time spent thinking, little had changed in the innards. The wireless section was back to stock, but the saved config file took care of that in under a minute. The router was stable and then I could spend time going through it to verify that all was well again. I loaded a fresh new openvpn client config , no problems logging back into the GUI, that predated this incident. A final save and reboot; the router runs as smoothly and hopefully stays that way. This never happened to me in this manner with an Asus router. If you remembered to back up your firmware/configs, you shouldn't have much work ahead except to upgrade to RMerlin's latest build, or John's if you'd rather at your earliest opportunity, but that will take the recovery tool (back it all up first). If you didn't save, that"s is the tough part. Be as prepared as you can and expect the unexpected, it happens to everyone. Once your GUI comes back, start from scratch. If it's not recoverable, now is the time of year that seasonal router sales begin. You'll get a good deal on a newer, more powerful Asus router on Amazon/Newegg, etc. My method was different and longer than the road others have taken for the most part, but as RMerlin wrote, it's really difficult to brick an Asus router. My N66, is more sluggish than my trusty AC56R and definitely slower than the AC3200. All routers eventually begin to fail in odd ways. Perhaps your next Asus router will be what you need, not to mention will probably cost less than you can imagine. Good luck and hope this offering is of some help to you.
     
    Last edited: Oct 12, 2017
  6. Zirescu

    Zirescu Very Senior Member

    Joined:
    Jul 16, 2013
    Messages:
    668
    Location:
    Kelowna, BC
    In case you've setup the web interface to HTTPS on another port you can try running the following:
    Code:
    nvram set http_enable=0
    nvram commit
    service restart_httpd
     

Share This Page