Asus TR-AC66U B1 Merlin FW problems with Astrill VPN Applet

lynchy73

New Around Here
Hi all,

I have the Asus router as listed in the subject. I installed the latest firmware (Merlin) version 386.7_2. It seems to be working ok. I also installed the astrill vpn applet for this version of Asus Router with Merlin Firmware. I followed the steps, and it was successfully installed via SSH I believe (according to the messages in SSH during installation).

However after Astrill installation I don’t see the Astrill menu. I tried to install the Astrill applet again. It shows Astrill in the menu initially, but when you open the menu it’s blank. Reboot the rooter and Astrill disappears from the menu.

Prior to updating the firmware I was able to see the Astril application (I bought it a few years ago with Astrill installed and it used to work ok). It used to work ok but I tried it recently and although Astrill was shown as running and connected, but I was still getting blocked (China), IP was showing as my local location (hence why I tried to update the firmware, after which Astrill disappeared and I had to install the astrill applet via SSH).

Does anyone know if maybe I should be using an older version firmware or any other things I can try to get this working? Any suggestions welcome as I’m at a bit of a loss.

Thanks
 

Yota

Very Senior Member
Essentially "the Astrill Applet" is a third party addon that is hacked into the web GUI, I saw it a few years ago, I don't know if they are maintaining it now.

In any case, you need to contact the developer of the addon, Astrill VPN, for technical support, because we don't know how it works.

However, I would recommend OpenVPN, I'm sure most VPN providers have that option, and when you're having trouble configuring OpenVPN, there are plenty of professional members here to help you.
 

lynchy73

New Around Here
Astrill is a pretty big VPN provider. It’s a paid subscription, their (Astrill’s) iOS, android and windows software are working for me. I’ll ask support again regards what the issue might be when trying to run it on the router.

openvpn is 1 of the protocols that Atrill offer. Is openvpn a core part of the Merlin firmware? Is there any info regards setting up openvpn on the Merlin firmware that you could point me towards?
 

jberry

Regular Contributor
Sorry late reply, but this person shows you on youtube the problem, its because your Asus router is going through the domain and not the actual IP of the router itself:
 

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top