ASUS XT8 wifi issues with latest firmware 3.0.0.4.386_45934 (AP mode)

niti

Occasional Visitor
Hi everyone!

So I'm having wifi issues with latest XT8 firmware to which I just upgraded to 45934 from 42095 which used to work really good but then ended up having some issues with node wired backhaul.

I have 1 XT8 as main router for wifi and 1 XT8 as node.

I've followed these instructions with scenario 3 "Use AiMesh or ZenWiFi with network switch, and use the Main AiMesh router as AP mode (Bridge mode)"

So I'll describe my home network setup here:

1. Fiber 1000M/100M up coming in to Inteno XG6846 and ethernet cable to the Mikrotik RouterBOARD 3011UiAS -router

2. Ethernet cable from Mikrotik router to Zyxel GS1920-24hp managed switch

3. Ethernet cable from Switch to Main router XT8 LAN1 port (main router LED is red btw but still works fine, turns white if I insert the ethernet cable to WAN port)

4. Ethernet cable from Switch to Node XT8 WAN port

5. then other devices such as PC, PS5 and TV have ethernet cable from Switch and these are working fine with no issues (+900M/100M speeds (Mbps))

Previously the Node XT8 uplink was connected with 5GHz and now I switched to use ethernet cable and that's where the problems started. Feels like the node is acting weird even though I've done to both XT8's reset, firmware restoration and hard reset.

The reason why I had to upgrade from 42095 was that the wired connection was not working fine with the node XT8 and it was disconnecting every 10-15min. (Blue LED flashing) (even after switching to use uplink 5 GHz still had this disconnecting issue)

Now in the latest 45934 version the wifi is dropping and wifi speeds like 50-60 Mbps even though node uplink is using 5Ghz. Sometimes I get wifi +400Mbps up to +500Mbps but still quite often dropping to 50-60 mbps.
I have enabled Ethernet Backhaul Mode and disabled it couple of times and always rebooting and so on but still after a while ends up to same 50-60mbps issue.

No changes if I switch backhaul to use Ethernet. I've checked multiple times the ethernet cables and they are working fine. When I connect my laptop to the ethernet cable which XT8 node is using I get like +900Mbps/100Mbps so its working fine.

Am I doing something wrong with the setup or what? Every other device which is using wired cable is working perfect it's just wifi which is not working fine.

[Update 1]
I've removed Ethernet cable from node WAN port and at least it's been more than 1 hour and wifi is now stable. It's now using 5GHz uplink. Anybody knows why wired uplink is not stable?
[Update 2]
Sometimes wifi drops still.. for about 10-15 seconds and then its back.
 
Last edited:

RogerSC

Part of the Furniture
AP mode is working fine for me on the ZenWifi AX with RT-AX86U as "main" (wired-only) router. Two differences between topology that you and I have. My network switches are all dumb, unmanaged switches, to allow the mesh routers to control things, they like that. The other is that I'm not using wired backhaul, since wired backhaul isn't enough faster to make it worth my while. Works great with wireless backhaul here. There are probably other settings differences between us, I use "smart connect", and set channels and channel widths for 2.4GHz. and 5GHz. wireless, instead of "auto".

Also have very few IoT devices here, just the usual run of mobile devices, computers, laptops, streaming TV boxes and a Tablo DVR, VoIP phone, etc. The worst behaved device that I have is the Tablo DVR, it can be problematic at times. No smart light switches or other "smart home" IoT devices.

I'm also using 42095 at this point...when I reverted to it, did a full factory reset to default settings and reconfigured the ZenWiFi manually. Speeds are great, up to 700Mbps on wifi-6 at remote node, and up to about 500Mbps on wifi-5 on remote node. Very happy with those internet speeds. No drops or disconnects, etc.
 

niti

Occasional Visitor
AP mode is working fine for me on the ZenWifi AX with RT-AX86U as "main" (wired-only) router. Two differences between topology that you and I have. My network switches are all dumb, unmanaged switches, to allow the mesh routers to control things, they like that. The other is that I'm not using wired backhaul, since wired backhaul isn't enough faster to make it worth my while. Works great with wireless backhaul here. There are probably other settings differences between us, I use "smart connect", and set channels and channel widths for 2.4GHz. and 5GHz. wireless, instead of "auto".

Also have very few IoT devices here, just the usual run of mobile devices, computers, laptops, streaming TV boxes and a Tablo DVR, VoIP phone, etc. The worst behaved device that I have is the Tablo DVR, it can be problematic at times. No smart light switches or other "smart home" IoT devices.

I'm also using 42095 at this point...when I reverted to it, did a full factory reset to default settings and reconfigured the ZenWiFi manually. Speeds are great, up to 700Mbps on wifi-6 at remote node, and up to about 500Mbps on wifi-5 on remote node. Very happy with those internet speeds. No drops or disconnects, etc.
I did last night hard reset, firmware restoration to 42095 and again normal reset. I haven't configured the settings manually..everything is just as they are after reset. Only thing I did it use AP mode and set wireless SSD and password. I'm also using smart connect.

Now in 42095 firmware I'm not using wired connection for the node and it's been stable I think but still seems to be some kind of drops sometimes. I'm don't know why and I'm not good at reading system log but I saw that there's these lines repeating every 20-30min. Wifi speeds 200-500Mbps. Not stable speed and no idea why. Wired connections are having stable speed.

What kind of settings are you using? If I could try with your manual settings if I get everything working fine and then I'll never touch wifi settings again :D

Code:
Dec  9 15:17:41 wlceventd: wlceventd_proc_event(508): eth6: Disassoc 1A:09:B8:37:3C:CB, status: 0, reason: Disassociated because sending station is leaving (or has left) BSS (8), rssi:0
Dec  9 15:17:41 wlceventd: wlceventd_proc_event(508): eth6: Disassoc 1A:09:B8:37:3C:CB, status: 0, reason: Disassociated because sending station is leaving (or has left) BSS (8), rssi:0
Dec  9 15:17:48 cfg_server:  event: wl_chanspec_changed_action
Dec  9 15:17:48 cfg_server: current chansp(unit0) is 1001
Dec  9 15:17:48 cfg_server: current chansp(unit1) is e03a
Dec  9 15:17:48 cfg_server: current chansp(unit2) is d986
Dec  9 15:17:49 amas_adtbw: [ADTBW]Radar timeout
Dec  9 15:17:49 amas_adtbw: [ADTBW]Try to extend bw to 160
Dec  9 15:17:49 amas_adtbw: [ADTBW]ret 0
Dec  9 15:17:54 wlceventd: wlceventd_proc_event(508): eth5: Disassoc 1A:09:B8:37:3C:CB, status: 0, reason: Disassociated because sending station is leaving (or has left) BSS (8), rssi:0
Dec  9 15:17:54 wlceventd: wlceventd_proc_event(508): eth5: Disassoc 1A:09:B8:37:3C:CB, status: 0, reason: Disassociated because sending station is leaving (or has left) BSS (8), rssi:0
 
Last edited:

Smokey613

Very Senior Member
Although I did try a pair of XT8s a month ago, I am now running 2 CT8 units in a wireless backhaul configuration. I have tried the latest 3.0.0.4.386_45934 version of the CT8 firmware twice, doing full reset both times. I also run my CT8 in AP mode behind a custom Untangle firewall. The 45934 firmware causes instability with my wireless backhaul, plus the wifi devices do not seem able to maintain a consistent connection. I think these Zen mesh systems are by default meant to use the 5.2g band for the backhaul and ethernet backhaul support is still unreliable. I went back to 3.0.0.386_23003 version for the CT8 and my wifi is very stable now. I see no reason to update at this time.

Maybe the XT8 units suffer from this same issue.
 

AlexXT8

New Around Here
I had the exact same issue of random wifi drops in AP mode on the most recent firmware; I downgraded to 42095 and the issue disappeared (I don't have the same issue with the ethernet in the WAN port though).
 

RogerSC

Part of the Furniture
I did last night hard reset, firmware restoration to 42095 and again normal reset. I haven't configured the settings manually..everything is just as they are after reset. Only thing I did it use AP mode and set wireless SSD and password. I'm also using smart connect.

Now in 42095 firmware I'm not using wired connection for the node and it's been stable I think but still seems to be some kind of drops sometimes. I'm don't know why and I'm not good at reading system log but I saw that there's these lines repeating every 20-30min. Wifi speeds 200-500Mbps. Not stable speed and no idea why. Wired connections are having stable speed.

What kind of settings are you using? If I could try with your manual settings if I get everything working fine and then I'll never touch wifi settings again :D

Code:
Dec  9 15:17:41 wlceventd: wlceventd_proc_event(508): eth6: Disassoc 1A:09:B8:37:3C:CB, status: 0, reason: Disassociated because sending station is leaving (or has left) BSS (8), rssi:0
Dec  9 15:17:41 wlceventd: wlceventd_proc_event(508): eth6: Disassoc 1A:09:B8:37:3C:CB, status: 0, reason: Disassociated because sending station is leaving (or has left) BSS (8), rssi:0
Dec  9 15:17:48 cfg_server:  event: wl_chanspec_changed_action
Dec  9 15:17:48 cfg_server: current chansp(unit0) is 1001
Dec  9 15:17:48 cfg_server: current chansp(unit1) is e03a
Dec  9 15:17:48 cfg_server: current chansp(unit2) is d986
Dec  9 15:17:49 amas_adtbw: [ADTBW]Radar timeout
Dec  9 15:17:49 amas_adtbw: [ADTBW]Try to extend bw to 160
Dec  9 15:17:49 amas_adtbw: [ADTBW]ret 0
Dec  9 15:17:54 wlceventd: wlceventd_proc_event(508): eth5: Disassoc 1A:09:B8:37:3C:CB, status: 0, reason: Disassociated because sending station is leaving (or has left) BSS (8), rssi:0
Dec  9 15:17:54 wlceventd: wlceventd_proc_event(508): eth5: Disassoc 1A:09:B8:37:3C:CB, status: 0, reason: Disassociated because sending station is leaving (or has left) BSS (8), rssi:0

From your log entries, it looks to me as though you have 160MHz. channel width enabled for the 5GHz-2 radio, it is enabled by default. Disable that, and it will use 80MHz. channel width for backhaul. That alone might stabilize things for you.

As I said, even though I'm using smart connect, I do set a 2.4GHz. channel (I use channel 6 here, the other non-overlapping channels are 1 and 11), and 20MHz. channel width on 2.4GHz. On 5GHz., I use channel 44 on the 5GHz-1 radio, and channel 157 on the 5GHz-2 radio, both are 80MHz. channel width. I chose these by using the Android app "Wi-Fi Analyzer" to see which of the 2.4GHz. channels was least "busy", that's channel 6 around here. A little different for 5GHz. since that's only essentially 1 80MHz. signal width for the low and/or high part of the band, for that I try to match the same control channel as the strongest neighbor. That's to have as little overlap as possible, since these chips do best when there's no overlap (or as little as possible). Overlap looks like noise, the radios are designed to deal with multiple signals on the same frequency they're on.

I also disable "universal beamforming" in the wireless professional settings for all bands.

That's the major stuff that might get you going.
 
Last edited:

niti

Occasional Visitor
From your log entries, it looks to me as though you have 160MHz. channel width enabled for the 5GHz-2 radio, it is enabled by default. Disable that, and it will use 80MHz. channel width for backhaul. That alone might stabilize things for you.

As I said, even though I'm using smart connect, I do set a 2.4GHz. channel (I use channel 6 here, the other non-overlapping channels are 1 and 11), and 20MHz. channel width on 2.4GHz. On 5GHz., I use channel 44 on the 5GHz-1 radio, and channel 157 on the 5GHz-2 radio, both are 80MHz. channel width. I chose these by using the Android app "Wi-Fi Analyzer" to see which of the 2.4GHz. channels was least "busy", that's channel 6 around here. A little different for 5GHz. since that's only essentially 1 80MHz. signal width for the low and/or high part of the band, for that I try to match the same control channel as the strongest neighbor. That's to have as little overlap as possible, since these chips do best when there's no overlap (or as little as possible). Overlap looks like noise, the radios are designed to deal with multiple signals on the same frequency they're on.

I also disable "universal beamforming" in the wireless professional settings for all bands.

That's the major stuff that might get you going.
I did change channel for 2.4GHz to 3 and that seems to work fine and now i think its been stable. Getting on iPhone 13 mini +400Mbps and up +100Mbps. I think its okay and enough stable.

But again this setup except for channel change was how I had it initially when I got fiber. I had version 42095 and xt node with wireless backhaul and it was working fine but I thought if I give wired connection from switch to the xt8 I might get better speeds but that turned to be difficult and even in the latest firmware speeds were not higher than this but I lost stable connection in the latest firmware so thats why I restored to 42095 which I think is the most stable firmware.

I don't still get why wired connection to xt8 node is not working correctly and keeps disconnect

Thank you for your help!
 

Semihage

New Around Here
I am running into exactly the same problem as well and am in the process of reverting all my node's firmware to 42095.
Question... Do any of you use ethernet backhaul? Which port do you plug in for the main AP router and each mesh node? WAN port or the LAN port ?
 

niti

Occasional Visitor
I am running into exactly the same problem as well and am in the process of reverting all my node's firmware to 42095.
Question... Do any of you use ethernet backhaul? Which port do you plug in for the main AP router and each mesh node? WAN port or the LAN port ?
I'm using WAN port on the main router and at the moment not using ethernet backhaul on the node. But according to the FAQ link I have posted upper the main ap router should use LAN port and the node should use WAN port but this didn't result to a stable wifi for me. I also tried WAN port on the main router and node but node was disconnecting very often. If you get it working fine please let me know
 

niti

Occasional Visitor
Thought I give a quick update about my progress with wifi issues.

I turned plugged ethernet cable back to node in WAN port and at first it was disconnecting after 10-20mins and then rebooted the node and it worked again for next 20min. Then tried to enable in system settings Ethernet backhaul mode and was disconnecting again... Then I disabled Ethernet backhaul mode again and rebooted the node and now its been 2 days without disconnecting and I've been checking it every 2-3 hours that its still connected and everytime its using Ethernet. No idea what helped but its been working now fine and getting speeds +500mbps.
 

Semihage

New Around Here
yeah I actually manage to get it working by plugin everything into WAN node as well.. One dumb mistake I did was I actually put my AP router under modem's passthrough. That's a dumb thing to do since I obviously can't see my other nodes. So I disabled passthrough on my modem, and have all ethernet coming out form my AP ZENWifi router's LAN port and everything is running fine.
 

niti

Occasional Visitor
I don't still understand how just by enabling ethernet backhaul mode everything will crash and internet wireless speeds drop to 10-50mbps... am I understanding ethernet backhaul mode wrong or should it work fine if I have ethernet cable from switch to main xt8 router n ap mode to LAN1 port and ethernet cable from switch to xt8 node WAN port.

Here what I just tried.
  1. Make sure that XT8 node uplink type is Ethernet
  2. Enable Ethernet Backhaul Mode in System Settings
  3. After a while WiFi is back but speedtest 10-50mbps..
  4. Disable Ethernet Backhaul Mode
  5. Still speedtest sucks...
  6. Node XT8 not working via Ethernet
  7. Reboot Node and it started working but disconnected after 5-10min
  8. Repeat step 7 like 10 times
  9. Remove Ethernet cable from Node and reboot to get Wireless uplink
  10. Connected fine and no issues with that but I have ethernet cable just for node so I want to connect using Ethernet uplink.
  11. Again Node XT8 disconnecting when in Ethernet uplink and rebooted it many times
  12. Hard Reset Node XT8 and connect using Wireless
  13. Connect again Ethernet cable and wait if uplink changes automatically but no it's still in Wireless uplink
  14. Change Backhaul Connection Priority to "1G WAN first" and now it started disconnecting again
  15. Rebooted and connected... again disconnected after a while and then finally after 3-4 reboots its using only Ethernet and now it's been 30min and no disconnects yet
I think Ethernet Backhaul Mode is not working for me correctly or in this 42095 version.. I tried to check the wifi settings but didn't know if anything was wrong there after enabling Ethernet Backhaul Mode..

Is this happening to anybody else when enabling Ethernet backhaul mode and has wired connection?
  • Switch <-- Ethernet Cable CAT8 --> XT8 LAN1 Port Main router in AP Mode
  • Switch <-- Ethernet Cable CAT8 --> XT8 Node WAN Port

Nothing special in the System log except for this Roaming Assistant log entries in the first 3 rows. The rest I think are quite normal and mostly the logs are like that (MAC address changed in the logs before pasting here..)

Code:
Dec 16 12:27:54 roamast: [EXAP]Deauth old sta in 0 0: [MAC ADDRESS]
Dec 16 12:27:54 roamast: eth4: disconnect weak signal strength station [MAC ADDRESS]
Dec 16 12:27:54 roamast: eth4: remove client [MAC ADDRESS] from monitor list
Dec 16 12:27:57 wlceventd: wlceventd_proc_event(491): eth6: Deauth_ind [MAC ADDRESS], status: 0, reason: Deauthenticated because sending station is leaving (or has left) IBSS or ESS (3), rssi:0
Dec 16 12:28:01 wlceventd: wlceventd_proc_event(527): eth6: Auth [MAC ADDRESS], status: Successful (0), rssi:0
Dec 16 12:28:01 wlceventd: wlceventd_proc_event(556): eth6: Assoc [MAC ADDRESS], status: Successful (0), rssi:0
Dec 16 12:28:05 wlceventd: wlceventd_proc_event(491): eth6: Deauth_ind [MAC ADDRESS], status: 0, reason: Deauthenticated because sending station is leaving (or has left) IBSS or ESS (3), rssi:0
Dec 16 12:28:11 wlceventd: wlceventd_proc_event(527): eth6: Auth [MAC ADDRESS], status: Successful (0), rssi:0
Dec 16 12:28:11 wlceventd: wlceventd_proc_event(556): eth6: Assoc [MAC ADDRESS], status: Successful (0), rssi:0
Dec 16 12:28:12 wlceventd: wlceventd_proc_event(508): eth6: Disassoc [MAC ADDRESS], status: 0, reason: Disassociated because sending station is leaving (or has left) BSS (8), rssi:0
Dec 16 12:28:12 wlceventd: wlceventd_proc_event(508): eth6: Disassoc [MAC ADDRESS], status: 0, reason: Disassociated because sending station is leaving (or has left) BSS (8), rssi:0

I even called ASUS Support and told everything what I know and tested so far and the guy just said that contact the shop where you've bought them and get new XT8 devices.. Then I asked him that do you know that the latest firmware has issues and seems that only 42095 is the most stable firmware. He didn't know.. I don't blame him but working in support should be at least familiar with the issues the users encounter. Told him that go to snbforums and read from there :D

Now it seems to be working fine but still don't know why enabling Ethernet Backhaul Mode will frack up wifi totally. Maybe I should return these to the shop and wait if I get new XT8's but I'll be without wifi for a while... I still think that its just firmware issue which hasn't been corrected yet.

Again the devices with ethernet cable are working like a dream. it's only these XT8 nodes that is not working as I want them to work. I bet if I now reboot the node I will be doing upper steps again :D
 

L&LD

Part of the Furniture
The switch used in the network may be the relevant aspect here. Does it work properly without it?
 

niti

Occasional Visitor
The switch used in the network may be the relevant aspect here. Does it work properly without it?
I have mikrotik router which has ports available. I'll test this tomorrow and let you know but if I'm not mistaken I've tried this also. I used all the ports in router to test this but still same issue but I'll test again to be sure because I don't remember now. Been fighting with this quite a while...
 

L&LD

Part of the Furniture
You may need to test with an unmanaged switch instead. Or, just a very long Ethernet cable.
 

Semihage

New Around Here
My Set up is
Modem -> AP XT8 WAN Port -> LAN ports on AP XT8 -> Unmanaged switch -> WAN port on Mesh XT8.

So essentially all the internet traffic has to go through AP XT8 device. I don't have any switch between modem and AP XT8. I only use 1 LAN port on my modem and that goes straight into AP XT8.

Make sure your modem is acting as DHCP and AP XT8 isn't on some passthrough/dmz (aka.. it should get a local ip from modem.)
 

niti

Occasional Visitor
Okay so since I have Mikrotik 3011UiAS -router which had previously only one ethernet cable going to the Zyxel GS1920-24hp managed switch and from there the ethernet cables was going to XT8 main router ap LAN port and to XT8 Node WAN port.

What I did is that since my router has extra ports I removed the XT8 devices the ethernet cable from switch and inserted directly to the router (skipping switch) and checked that its still working fine and then enabled ethernet backhaul mode and now its working like a charm.

So if anybody else is using XT8 in Access Point mode in ethernet backhaul mode and has router + switch (probably the reason is that its managed switch) I suggest to try to insert the ethernet cable directly in the router LAN port <---> XT8 main node LAN port and router LAN port <---> XT node WAN port.

Thank you all for helping! I hope now my wifi issues are gone.. I'll keep monitoring and report back here.
 

Ramsete2

New Around Here
Hi, any solutions for who is using XT8 nodes is WIFI backhaul mode?
I'm still stick to 42095 firmware that is working fine, but is becoming obsolete.
I can't believe that ASUS didn't provide a fix so far...
 

RogerSC

Part of the Furniture
Have to admit that when I've tried to use ethernet backhaul with the ZenWiFi in AP mode on 42095, have had similar results. The ZenWifi slows way down, goes at least partially incommunicado, and generally isn't a useful configuration. However, the ZenWifi works so well for me using wireless backhaul that I just don't care *smile*. Haven't had time or desire to troubleshoot the ethernet backhaul problems, since when I used the ZenWiFi with ethernet backhaul in router mode, there was little additional performance. Not worth it. Having the best performance I've seen without needing ethernet backhaul is fine with me, I really like the mesh performance (without ethernet backhaul).

For the "42095 becoming obsolete" problem, that's also not a problem (for me) using the ZenWiFi in AP mode. My main (wired-only) router is fully updated, and that's what matters to me. I'd be unhappy if I had to connect the ZenWiFi on 42095 to the internet, though.
 

Smokey613

Very Senior Member
As I mentioned earlier in this thread, I think in their attempt to implement more ethernet backhaul support on the ZenWiFi systems Asus "broke" something. I too had to roll back to a prior version because the 3.0.0.4.386.45934 firmware was very unstable. Likewise, I run my CT8 units in AP mode behind a custom Untagle firewall so no security concerns from the internet anyway.
 

Similar threads

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top