ASUS ZenWiFi AX XT8 horrendously slow speeds and connectivity issues.

  • ATTENTION! As of November 1, 2020, you are not able to reply to threads 6 months after the thread is opened if there are more than 500 posts in the thread.
    Threads will not be locked, so posts may still be edited by their authors.
    Just start a new thread on the topic to post if you get an error message when trying to reply to a thread.

SlovBoy

New Around Here
Hi guys!

Less than a month ago I bought the ZenWifi 2-pack and I installed it in my 81 m2 apartment. I thought that since the apartment has a bit of an unusual structure, I would definitely need a mesh network to get better coverage and above all else - speed.

I was shocked to find out that the speeds were absolutely not stellar - I am averaging on my Mi 8 and an iPhone 12 Max Pro speeds below 400 mb/s - sometimes dipping down to 40-80.

I decided to go borrow another 2-pack - giving me a total of 4 nodes - and the end result is, dare I say, much worse than what was initially experienced.

I put my main router into AP mode before to see if there was a difference - I activated MU-MIMO, I set the channels, disabled QoS - I am still averaging less than that. And it's wholly unpredictable.

What can I do?

Just to add - my Asus Router app and the WebGUI see my ''internet speed'' as 900+ mb/s. Now what is this measuring? The speed from the cable or the wifi speed?

Any help would be greatly appreciated :(
 

RogerSC

Part of the Furniture
Haven't seen any of this. What firmware version are you on? Have you done a reset to factory defaults and re-configured from ground zero? Two XT8's are definitely enough for your apartment, 2 nodes gives me full coverage here on a longer, narrower house (about 60' x 24', two stories).

The reason that I ask about which firmware version you're on is that some are better than others *smile*. I'm on the latest that I flashed earlier today, and that's working fine for me so far. After I flashed it, though, I did a reset to defaults on both XT8's, and a power-cycle after that.

Other suggestions are to use smart connect, and pick channels for 2.4GHz and 5GHz wireless rather than auto. Also, DFS channels don't work well here, so I'm using 80MHz channel width on 5GHz radios. And disable "Universal Beamforming" in the "Professional" Wireless Settings.
 

SlovBoy

New Around Here
Thank you for your response! :)
Haven't seen any of this. What firmware version are you on? Have you done a reset to factory defaults and re-configured from ground zero? Two XT8's are definitely enough for your apartment, 2 nodes gives me full coverage here on a longer, narrower house (about 60' x 24', two stories).
I am on the newest one that released yesterday. I upgraded them - now I'm down to 2 nodes - via the Asus Router app.
What do you mean by coverage?
What's your internet speed like? I have a 1GB/s line and now - using AP mode - I consistently get from 150-450 mb/s (the latter is however very unpredictable and hard to hit sometimes).

The reason that I ask about which firmware version you're on is that some are better than others *smile*. I'm on the latest that I flashed earlier today, and that's working fine for me so far. After I flashed it, though, I did a reset to defaults on both XT8's, and a power-cycle after that.
You did it through the app? What does it do? It doesn't delete any settings right?
And a power cycle is what? Any pointers on how to do that?


Other suggestions are to use smart connect, and pick channels for 2.4GHz and 5GHz wireless rather than auto. Also, DFS channels don't work well here, so I'm using 80MHz channel width on 5GHz radios. And disable "Universal Beamforming" in the "Professional" Wireless Settings.


I tried using Smart Connect - I lost all of my SSID's and they didn't come back. Had to do a hard reset for it to work.


So I should put 80 MHZ for both 5ghz channels, correct?

One is set to 80 and the other is set to 20/40/60/80.

What does Universal Beamforming do? Will it somehow affect my 2.4 ghz connection? I still need it since I have two devices that need it.

Thank you so much and I apoloize for bombarding you with so many questions!
 

RogerSC

Part of the Furniture
The latest version of the firmware is very new, and hasn't had much time to get the sense of how stable it is. It's working fine here, but I have a vanilla network configuration here, nothing exotic. Just computers, mobile devices, VoIP phone, streaming boxes, solar panel controller, etc. Have fiber gigabit internet here, working well. Users on this forum seem to give firmware version 42095 the best reviews for those that have lots of stuff going on. that one also worked well for me.

I do the resets to factory defaults using the reset button on the bottom of each node. The point of a reset to factory defaults is that it brings your router configuration back to how it came to you from the factory. So yes, it does change settings and requires you to re-enter your detailed configuration, but the resets get your router configuration to a known state.

To do a power cycle, I turn off the remote node AC power first, then turn off the power on the router node. Wait about 30 seconds and power the remote node back up, then power up the router node immediately after that. So a "power cycle" means turning off the AC power, then turning it back on.

Using "smart connect" implies that you only have one SSID, which is something that I like. All my clients end up on 5GHz, so it isn't a problem for me...just makes things easier.

Leaving the 5GHz. channel width selection at 20/40/80MHz. doesn't matter, your router should select 80MHz. I've never seen otherwise, here. I do set the 2.4GHz. channel width to 20MHz. explicitly though, 2.4GHz. is just too busy around here.

Leave "Explicit Beamforming" enabled, just disable "Universal Beamforming" (also called Implicit Beamforming). Feel free to play with the beamforming settings to see how they work for you, but the general advice around here is to have Explicit Beamforming enabled, and Universal Beamforming disabled. I think that there can be client compatibility problems with Universal Beamforming, but feel free to play with Universal Beamforming and see what it does for you on various clients...be sure to get a sense of how that setting affects all your clients before committing to it.
 

darky2235

New Around Here
Hi guys!

Less than a month ago I bought the ZenWifi 2-pack and I installed it in my 81 m2 apartment. I thought that since the apartment has a bit of an unusual structure, I would definitely need a mesh network to get better coverage and above all else - speed.

I was shocked to find out that the speeds were absolutely not stellar - I am averaging on my Mi 8 and an iPhone 12 Max Pro speeds below 400 mb/s - sometimes dipping down to 40-80.

I decided to go borrow another 2-pack - giving me a total of 4 nodes - and the end result is, dare I say, much worse than what was initially experienced.

I put my main router into AP mode before to see if there was a difference - I activated MU-MIMO, I set the channels, disabled QoS - I am still averaging less than that. And it's wholly unpredictable.

What can I do?

Just to add - my Asus Router app and the WebGUI see my ''internet speed'' as 900+ mb/s. Now what is this measuring? The speed from the cable or the wifi speed?

Any help would be greatly appreciated :(
Hi, did you find a solution? I am having same issues, I have a 1Gb internet speed, I changed to AP mode and Im getting 50mb downloads and 1.1 uplods? This is sick
 

SlovBoy

New Around Here
Hi, did you find a solution? I am having same issues, I have a 1Gb internet speed, I changed to AP mode and Im getting 50mb downloads and 1.1 uplods? This is sick
Hi!

The new update definitely rectified certain issues.

I'm rocking solid, stable speeds on the devices where you expect them to be.

I still get the occasional connection drop in my bedroom, but it wasn't as horrible as it was before.

What about you? What are your settings?
 

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top