Release ASUS ZenWiFi XT8 Firmware version 3.0.0.4.388.21099 (2022/10/03 )

karma

Regular Contributor
Version 3.0.0.4.388.21099

2022/10/03 46.66 MBytes

ASUS ZenWiFi AX (XT8) Firmware version 3.0.0.4.388.21099
Try more on ASUSWRT 2022 with new features at https://asus.click/ASUSWRT2022
1. Supported WireGuard VPN server and client.
2. Supported VPN fusion. It can easily achieve VPN connection to network devices like Smart TV, Game consoles and without installing the VPN client software.
3. Supported new devices connection notification.
4. Supported connection diagnostic on the ASUS router app.
5. Supported Instant Guard 2.0 which helps easily invite family or friends to join the VPN connection.
6. Upgraded parental control and added reward, new scheduler for flexible setting
7. Fixed USB icon issue in port status.
8. Fixed HTTP response splitting vulnerability. Thanks to Efstratios Chatzoglou, University of the Aegean.
9. Fixed status page HTML vulnerability. Thanks to David Ward.
10. Fixed CVE-2018-1160. Thanks to Steven Sroba.
11. Fixed cfg_server security issue.

Please unzip the firmware file first then check the MD5 code.
MD5: d87704f3d53898f19961b6085c621193

 

RogerSC

Part of the Furniture
Just upgraded from 386 firmware to 388 couple of hours ago. Feel like I should do a factory reset, since these are two different "families" of firmware. However, so far nothing untoward has happened, everything is looking as I expect, good. Took a quick tour through the admin interface, looks just fine there, too.

We'll see over time.
 

Dodgydrains

Regular Contributor
Did a full factory reset before and after upgrading to 388.21099 from 386.49873, including hard factory reset on each 4 nodes (my OCD in play).

Only thing I can see is that free RAM went down a bit from 209 MB to 199 MB.

Will stay with this FW until GNUton's next release.
 

L&LD

Part of the Furniture
Note that doing a full reset before you flashed the firmware you want to use is not ordinarily needed.
 

ML007

New Around Here
Good morning,
I have a problem with my XT8 after upgrading to 3.0.0.4.386.49873 or 3.0.0.4.388.21099.
The last stable firmware for me is 3.0.0.4.386.48706.
My node loses communication with the main unit, the LED light is yellow and I loose connection or it is very unstable.
I did a hard reset but it didn't help.
The main unit is on the first floor of the house and connects to the nod on the second floor wirelessly. I did the test by putting both units side by side - same story; yellow LED light and lost connection.
What could be the reason? Which settings should be changed to restore connection stability with the latest firmware?
Regards.
 
Last edited:

karma

Regular Contributor
I just dirty upgraded this morning 3.0.0.4.386.49873 from to 3.0.0.4.388.21099
Early days, but so far so good
 

macoloco

Occasional Visitor
Just dirty upgrade my router and my node.....node all went fine, router needs to be reset (not factory reset, just power cycle) to connect 5ghz-2 wifi devices to internet

Sometimes mac filterings doesnt apply correctly

so far ....no problems with this firmware update

i just review over UI....now in status shows wan/lan ports status and usb icon too
 

Dd852

Occasional Visitor
A small annoyance: router.ASUS.com doesn’t resolve for me now. Any ideas why? I can reach with 192.168.50.1 so no big deal but a weirdness after upgrading.
 

someuser08

Occasional Visitor
No major issues so far, but it doesn't feel as stable as on 386.49873. The only quantative metric I can do is seeing TX/RX transmit rates between 2 nodes on 5-2 backhaul and they are fluctuating up and down whilst previously it was static for weeks in a rows... I will stay on this for a week and then downgrade to compare again.
 

RogerSC

Part of the Furniture
That is in the iOS or Android app.

Yes, feature 3. above is found under "Notification Settings" in the Asus Router smart phone app.
 

niti

Occasional Visitor
Upgraded using the app from 48706 and only the main node updated for some reason. Tried few times using the app to update second node but didnt work. Even rebooting and trying to reset didnt work.

I did a firmware rescue and flashed directly the latest firmware and worked.

So far seems stable and getting higher speeds. Was getting previously around +500 to 550 mbps and now getting +700mbps.

I got 1gbps fiber connection and using ethernet backhaul.
 

carchayser

New Around Here
I recently upgraded and for about a week, all my nodes were disconnecting once every day and takes a while for them to reconnect if I don't manually restart the main router.

Main reason is probably because I have 9 nodes in total of varying models and those other nodes have not yet been upgraded to the 388+ family so there may be a compatibility issue.

Downgraded to 49873 for the meantime until Asus rolls out 388 updates for the other models.

To give you guys a clearer picture, here's how my topology goes:

4 XT8s (1 main, 1 wifi backhaul, 2 ethernet backhaul)
4 XD6s (all ethernet backhaul)
1 TUF AX5400 (ethernet backhaul)
1 TUF AX3000 (ethernet backhaul)
 

Raven76

Regular Contributor
Dirty upgrade on my two installations (4 xt8s in one house and 2 xt8s in another).
No problems at all.
Never made a factory reset from the first firmware I used (42095)
 

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top