asus zenwifi xt8 + latest firmware + nest 3rd gen learning thermostat offline off and on?

  • ATTENTION! As of November 1, 2020, you are not able to reply to threads 6 months after the thread is opened if there are more than 500 posts in the thread.
    Threads will not be locked, so posts may still be edited by their authors.
    Just start a new thread on the topic to post if you get an error message when trying to reply to a thread.

markm75

New Around Here
I have this combo of hardware and it seems ever since i did a recent firmware update, that now the nest goes to offline mode randomly.
*I guess if i thought i could go back a firmware level (somehow) i'd try to go back to the last one?

Has anyone else ran into this and knows of a fix?

Thanks in advance
 

Joners

New Around Here
All the firmware's since 3.0.0.4.386.42095 seem to have issues with IoT devices and backhaul connectivity. Id recommend downgrading to 3.0.0.4.386.42095 and see how you find it.
 

markm75

New Around Here
All the firmware's since 3.0.0.4.386.42095 seem to have issues with IoT devices and backhaul connectivity. Id recommend downgrading to 3.0.0.4.386.42095 and see how you find it.
Ok thanks, Is it as simple as just specifying the replacement firmware and updating or is there more involved to go backwards?

Does it hold all the settings or do you have to start from scratch?

I see alot of entries related to the nest like:
wlceventd: wlceventd_proc_event(508): eth5: Disassoc xyz, status: 0, reason: Disassociated because sending station is leaving (or has left) BSS (8), rssi:0
 

Joners

New Around Here
Ok thanks, Is it as simple as just specifying the replacement firmware and updating or is there more involved to go backwards?

Does it hold all the settings or do you have to start from scratch?

I see alot of entries related to the nest like:
wlceventd: wlceventd_proc_event(508): eth5: Disassoc xyz, status: 0, reason: Disassociated because sending station is leaving (or has left) BSS (8), rssi:0

I had similar issues to you and downgraded and its been light night and day, the older firmware is significantly more stable. I couldnt find a documented process, so i did the following and it was all fine.

For precaution backed up my settings first but i didnt need to restore, YMMV.

Perform a manual update of each remote node, wait for it to install, reboot, and reconnect to the main router.

Once all the remote nodes had been downgraded and were online i then did a manual update on the main router.

For me everything came back up without any issues at all. If you do have issues after downgrading i would reset everything and restore from the backup.
 

markm75

New Around Here
Well i went back as far as firmware 3.0.0.4.386_41793 i also rebooted each mesh unit. No luck, the nest still goes to offline mode.

I havent tried doing a factory reset on the asus yet however.
 

markm75

New Around Here
Update, so with my xt8 asus, a few things i did..
It was suggested to revert to a firmware from feb 2021 or previous (3.0.0.4.386.42095 or before). The 2021 feb one (42095) didnt seem to make a difference so i went with 3.0.0.4.386_41793
I dont think this was the fix.
I then went into 5ghz-1 and set the control width i think from 80 to 20/40/80. I also set the channel to 40 fixed.
So far, normally i'd have many offline periods, but so far none in several hours. One of the above fixed things (so far)

EDIT: most likely it was the control width change (more universally compatible with those type of devices)
 
Last edited:

ewilson90

New Around Here
I was facing the same issue on 43181. I downgraded only to 3.0.0.4.386.43170 (one previous), and it seems to have resolved the offline issue.

Has anyone contacted Asus about this? Some of the recent firmware fixes mention fixing security issues in the release notes, so it would be nice to have those fixes without whatever is causing the Nest to frequently disconnect.
 

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top