Asus ZenWifi XT8 slower than my AC68U :(

  • ATTENTION! As of November 1, 2020, you are not able to reply to threads 6 months after the thread is opened if there are more than 500 posts in the thread.
    Threads will not be locked, so posts may still be edited by their authors.
    Just start a new thread on the topic to post if you get an error message when trying to reply to a thread.

erkdahl

New Around Here
Hello!

I just bought the Asus ZenWiFi XT8 mesh in order to upgrade from my older AC68U router.
But to my big disappointment it is so far not at all an upgrade in performance.

In my old router (AC68U) i got speeds of 50MB/s downloading files from my NAS (connected directly with 1Gbs port to router), by Wifi to my MacBook Pro (supporting Wifi5) on 5G. This was when i was 10ft line of sight from the router.
Im using pretty much out of the box settings for WiFi as far as i know.

With my new router (ZenWifi XT8) (single node only), default settings, i get only aproximatly 22-27MB/s downloading files from my NAS. (NAS still connected through direct cable), MacBook still connected on 5G wifi.
I have tried changing the channels, i have tried changing the frequency of the 5G channel, i have tried enabling the 5G.2 backhaul band and connecting straight to that, but always the speed is only 22-27MB/s downloading files.

Is this normal? Is the ZenWiFi really worse than my old AC68U? Or is it defect? Maybe there is some settings i need to do?
Should i return it as broken and get a replacement? Or should I change to another router?
I was hoping to get NAS download speeds of at least around 100MB/s (800Mbit/s)

Hope to get some helpful advice!
 

JagoUK

Regular Contributor
Do you have any other client devices?

Macbooks do have issues.

Make sure its connecting to 5ghz and not 2.4ghz. (Seperate SSIDs)

Check what channels it is using. Try 40mhz rather than 80mhz bandwidth.

Do you have VPN installed? I've heard that can interfere too.
 

erkdahl

New Around Here
Yes i have separated the SSIDs in order to make sure im on the 5Ghz and not 2.4 ghz. So im definatly connected to 5Ghz.
I have also tested downloading from the NAS by Iphone 11 and Windows 10 laptop with NC wifi card. Both report around 20-27 MB/s also...
So it seems not to be Macbook related.
I do have other clients, apple-tv, ipad, and printer. They are all idle so should not use up bandwitdh.
No VPN installed either..
Just tried setting 40 Mhz bandwidth now but same speeds at around 20MB/s now.
Also tried setting 80 Mhz bandwidth but still same speeds...
 

erkdahl

New Around Here
Well actually i now tested from FileZilla over FTP rather than using finder. There im able to get max 60MB/s (480Mbit/s). So thats better. Still a bit less than i hoped, but i`ll take it.
 

Similar threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top