Asuswrt-Merlin 376.47 Beta 1 is out

Diz

New Around Here
Hello, I'm pretty new to Merlin and I apologize if this has been answered before Merlin. Does Merlin support Time Machine for the AC-RT66U?

Edit: 15 hours of uptime and this is the most stable software I have ever installed on a router!
 
Last edited:

RMerlin

Asuswrt-Merlin dev
Hello, I'm pretty new to Merlin and I apologize if this has been answered before Merlin. Does Merlin support Time Machine for the AC-RT66U?

No, only AC56, AC68 and AC87 are supported.
 

RMerlin

Asuswrt-Merlin dev

Just Checking

Regular Contributor
Does 376.XX have Power Limiting?

RMerlin, In a previous post of a different thread made a comment something like (I am paraphrasing from memory here) "All FW revisions from 376.XX on will have the kernel which will not allow changing the country codes and will have the input power restrictions as mandated by the FCC". Was my memory correct on this?

If so, how does this effect the wireless radio signal strength compared to routers running the 374.43_2 Forked FW? I have a couple RT-AC66's and I have a RT-AC68 going to be delivered in a few days. I'm happy with the reliability and power output of the 374.43 Forked FW which I thought to run on the new AC68.

I don't use SNMP. Is there any advantage for me to install this new FW on a RT-AC68 router?

Wireless Connection Reliability for my Clients is #1 priority.
Router Uptime Reliability is #2 priority.
Network Security is #3 priority
Wireless Range on both 2.4GHz and 5GHz bands is #4 priority.
Wireless data transmission speed is #5 priority.
OpenVPN working reliably is #6 priority.
All the rest is just features to play with.
 

Chazall1

Occasional Visitor
Great beta, Beautiful job. I upgraded from .43-3 fork. Flashed over the top no reset.
Thanks!
 

RMerlin

Asuswrt-Merlin dev
RMerlin, In a previous post of a different thread made a comment something like (I am paraphrasing from memory here) "All FW revisions from 376.XX on will have the kernel which will not allow changing the country codes and will have the input power restrictions as mandated by the FCC". Was my memory correct on this?

It's not the kernel that controls power limitations, it's the main firmware code and the closed-source wireless driver. But at this point, yes, all firmware releases since the first based on the 376 base code will only allow handling the region hardcoded in your bootloader, and with a maximum output power of 100%, which will be whatever is determined by the wireless driver as the maximum allowed for your region.

If so, how does this effect the wireless radio signal strength compared to routers running the 374.43_2 Forked FW? I have a couple RT-AC66's and I have a RT-AC68 going to be delivered in a few days. I'm happy with the reliability and power output of the 374.43 Forked FW which I thought to run on the new AC68.

For the vast majority of people, this will have zero impact. Most people leave it at the default output power, and to whichever region is hardcoded in their bootloader. That means zero change in range or available channels if you didn't previously played with either settings.

I don't use SNMP. Is there any advantage for me to install this new FW on a RT-AC68 router?

As usual, all the bugfixes, both from me and from Asus (which aren't listed in my changelogs).
 

gogubeb

Occasional Visitor
Hi all,
I have problems with traffic monitor on an RT-N66U merlin firmware from ver. 374.40..43 and latest 376.44...47beta1, it doesn't show data on table on daily or monthly screen.
I erased nvram, reset to factory default and made setting from scratch.
I don't have this problem with firmware from Asus, tomato or dd-wrt.
Thanks

 
Last edited:

RMerlin

Asuswrt-Merlin dev
Hi all,
I have problems with traffic monitor on an RT-N66U merlin firmware from ver. 374.40..43 and latest 376.44...47beta1, it doesn't show data on table on daily or monthly screen.
I erased nvram, reset to factory default and made setting from scratch.
I don't have this problem with firmware from Asus, tomato or dd-wrt.
Thanks


You probably failed to properly initialize the datafiles on the Tools -> Other Settings page.
 

gogubeb

Occasional Visitor
How can i initialize datafiles?
I have set in Tools -> Other Settings page:
- Traffic history location -RAM (default);
- Starting day of monthly cycle - 1
Thank you
 
Last edited:

CorruptedMind

Occasional Visitor
Try it on the USB 2 port to see if it's more stable. If it is, see if you can replace the USB cable you are using, it might have shielding issues (some USB 3.0 drives come with pretty cheap/poorly shielded cables).

Last night I tried connecting to the USB 2.0 port, unfortunately the same problem.... :( My movie would stream fine for about 30 mins or so and then it would loose connection and disconnect completely. I'm not sure if it is the cable? It's a My Passport Ultra 2tb 3.0 and relatively pretty new. I could try getting a new cable. My printer would loose connection too though... I will have to reboot the router to get it to find the printer on the network again.

If no one else is having USB issues on the AC87R/U then should I replace it? Unless it's a firmware issue? Does anyone else stream via DLNA on this router?
 

DaveMishSr

Very Senior Member
How can i initialize datafiles?
I have set in Tools -> Other Settings page:
- Traffic history location -RAM (default);
- Starting day of monthly cycle - 1
Thank you
First thing I would do is to create the folder "xxx1" on your flash drive. Then you will use that page to set it as the location to save your history files too. Lastly and most importantly is the check "yes" next to:

Create or reset data files:
Enable if using a new location

If you use RAM as the location to save to you will lose your data on every reboot. Never save to NVRAM as that area is reserved and for a very good reason. Leave it alone. That is why you need to save your history files to a flash drive.
 

gogubeb

Occasional Visitor
First thing I would do is to create the folder "xxx1" on your flash drive. Then you will use that page to set it as the location to save your history files too. Lastly and most importantly is the check "yes" next to:

Create or reset data files:
Enable if using a new location

If you use RAM as the location to save to you will lose your data on every reboot. Never save to NVRAM as that area is reserved and for a very good reason. Leave it alone. That is why you need to save your history files to a flash drive.

Is same with custom location, i check yes to Create or reset data files, apply then reboot and wait 1 h but same result.
 

effortless

Regular Contributor
External Drive Questions

I have a hard drive plugged into my USB 3.0 port named XXXX (just an example). When I first set it up, I can see one folder named XXXX (either through FTP or Samba) as my root folder. I later create a folder within that folder called movies path is ftp://192.168.1.1/XXXX/movies/.

For some reason, ftp://192.168.1.1/XXXX/movies/ becomes ftp://192.168.1.1/XXXX(1)/movies/ at a later point and my devices can't locate my movies due to the path change. I then can see two folders in the root of the drive... one named XXXX and one named XXXX(1).

The XXXX folder appears empty and the XXXX(1) folder now has the contents under it. Why does this happen and how can I fix it.

Also, I tried to search for this, but what file format do you recommend for a shared drive like this? I've tried NTFS and HFS+ and the drive isn't as responsive as I'd like it to be when not used for a while.


Thanks for you help and I appreciate your time and effort in producing this firmware!

EDIT: Also, this repeated message has come back in my logs since flashing your firmware over the latest stock: "kernel: Dead loop on virtual device vlan2, fix it urgently!"
 
Last edited:

wsarahan

Senior Member
@Merlin how are you?

Can i update my 87u just uploading the FW or should i make a factory reset?

And another question, i`m suffering so much with the 87u and bluetooth interference here, changed channels and nothing works, my mouse, my HeadPhone is getting crazy when 2.4 is on :(. Strange is at my old 68U nothing happened, everything worked like a charm, maybe something related to the new Quantenna driver or the chip itself?

Thanks again man
 

rod

Occasional Visitor
Some issues with the beta

Hi RMerlin

I am having trouble to access with ssh, just after updating to the beta release. It says Permission denied, please try again 3 times and after that... fails. I tryed changing the port in the UI, applying changes and after that trying to log in again, but no luck

If i go to the syslog, it is empty

Also, a couple of times it unmounts the usb hard drive, and even if I issue a refresh from the UI it wont reconnect... It detects the disc, and says it is unmounted. It allows me to run the scan disk function, but will keep unmounted until I issue a restart from de UI. The disk is ext3 formatted.

All this happend to me from mi work accessing the UI remotely... and also here from my home, accessing it from the lan. I have the RT-N16

Thnx
Rod

Update: After last time, it doesn't even let me to issue a soft-reset from the UI, so I unplugged power and plugged again. After that, the syslog worked again, ssh also works, and owncloud started to sync again. I will update if it happens again.
 

Attachments

  • no-syslog.jpg
    no-syslog.jpg
    47.9 KB · Views: 422
  • terminal.jpg
    terminal.jpg
    69.5 KB · Views: 434
Last edited:

tijaune

Regular Contributor
traffic monitor per ip

I also have problem in traffic monitor UI (maybe since 376.45) and no matter reset of history files can correct it. "Global" shows the traffic graph properly but once click on one of the 3 "Per device" elements drop down box, the UI missed the devices info section entirely.

(on IE11, Chrome, Slimjet and ios Safari).
 

Attachments

  • Capture.jpg
    Capture.jpg
    49.6 KB · Views: 635
Last edited:

rod

Occasional Visitor
Can't turn off VPN server

Hello again RMerlin.

After reading your developing updates, I decided to turn of the VPN, but it wont. I restarted the device from the UI and try again, and it doesn't stop. I will (again) do a hard power off and on, and if it still don't want to come off, then I will downgrade to an stable release, and wait until a stable one comes out.

Thanks again
Rod
 

Similar threads

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top