Asuswrt-Merlin 378.53 is now available

VANT

Very Senior Member
about memory usage....

In RT-AC87U after using samba memory usage is reduced


but in RT-n66u not, It is still at a high level.
Any chance to fix this ?
 

Attachments

  • samba_endpng.png
    samba_endpng.png
    4.5 KB · Views: 1,622

RMerlin

Asuswrt-Merlin dev
I tried but it seems that there was no difference. Please note that for every test that I am doing, I am applying the changes (obviously) and rebooting the router, and while it reboots I disable the wlan0 interface in my linux notebook, so (hopefully) cleaning up some cache that may interfere.

I was reading about this explicit-exit-notify and it seems(if I understood correctly!) that this has to do with a forced signal to the server indicating that I am disconnecting (They limit the amount of simultaneous connections that a given username can do, therefore a "hanging" connection would be bad..)

I really don't know much about troubleshooting DNS connections, I try using dig for somethings but I would really like to be able to identify which DNS server I am using...

Thanks again for your help!!

The issue is definitely linked to that setting, I have three different test cases so far, all of them have that specific setting. At least one tunnel provider even pushes that setting at connection time, and I don't know if it can be overridden by the user.

The problem is, with that setting, when the tunnel goes down the openvpn binary does not executed the "down" script it's expected to, so the environment cleanup cannot be done by the openvpn executable. I can make the firmware take care of it for cases where the user is the one who turned the tunnel off, but I can't do anything about scenarios were the tunnel was terminated by the provider or by a loss of connection.

I personally think this is a bug in openvpn, as it should execute its "down" script in such cases. However whether the OpenVPN devs would agree with me is a different story...
 

RMerlin

Asuswrt-Merlin dev
about memory usage....

In RT-AC87U after using samba memory usage is reduced


but in RT-n66u not, It is still at a high level.
Any chance to fix this ?

There's nothing to fix. It's simply the router using unused memory for buffering, for performance improvement. That memory gets released as soon something else requires it. This is normal behaviour.
 

karamazov

New Around Here
Hi. I've installed this version and found a memory issue. Not sure if this happens with the official version as I just migrated from Tomato.

A couple times I've found the /usr/bin/acsd process raising its resident memory usage at a steady rate of 4K per about 10 seconds. Both times it was after the wireless scheduler period had ended (radios had been automatically disabled after scheduled time was over).

Also, I've noticed that enabling the radio (via WPS button) outside the scheduled interval and then turning it off (via WPS button again) disables the wireless scheduling feature. I think it would be more convenient not doing it, allowing for casual use of wireless outside the scheduled times.

All in all, seems like a great firmware. Thanks for the hard work RMerlin!

Edit: acsd kept using more and more memory (reaching 14780K) while wireless was scheduled as disabled. When the wireless on time was reached memory stopped increasing, so it looks like memory leaks if the scheduler is enabled, and it does in the scheduling periods when wireless is disabled.
 
Last edited:

RussellInCincinnati

Senior Member
..."2" means "never overcommit more than you have available", which would be the logical configuration to use...Setting over_commit to "1" is a bad idea - it tells the kernel to NEVER refuse any malloc() call, even if there's no longer enough memory available...
Can somewhat dimly see that programs that are always getting a successful result from calling malloc(), can be encouraged to do things that might end up causing huge amounts of thrashing/virtual memory machinations/"disk" activity. Thanks as usual for link and comments.
 

danyxp

Occasional Visitor
Thanks for your work and feedback; especially for the ad blocker. It does affect a little the performance ( 880-900 mbps ad blocker enabled, 930+ with it disabled ) but that is somehow to be expected I guess, more processing power required; it's not a big impact and it's worth it. I'll need a few more days to test the blocking functionality on multiple devices, but it's a great feature to have.
Edit: I'm using AC56U
Disabling the ad-blocker does not bring back the lost performance, not even after a reboot. I had to do a factory reset to get back to what I was used to. Not such a big issue but it is there. I doubt that this is even visible without a gigabit connection to max out the processing power.
Browsing on mobile devices is much better with the blocker enabled, not perfect but a much cleaner experience. If you end up on a click bait site no blocker will save you.
 

Konstigt

New Around Here
Hello

If using AC66U, is the Wifi driver still the same in 378.53 as it was in 376.49_5? Because I read in 378.51 Beta 1 that it was downgraded and haven't seen any update since:


378.51 Beta 1 (28-Feb-2015)

- CHANGED: Reverted RT-AC66U driver to previous version as some users
were experiencing stability issues with the 3754 version.

Asking again, is the driver the same in 378.53 as it was in, for example, 376.49_5? For RT-AC66U.

Edit: Checked GitHub and found that there isn't any update on the Wifi driver.

https://github.com/RMerl/asuswrt-merlin/tree/master/release/src-rt-6.x

wl: Reverted wireless driver to pre-3754 for RT-AC66U
 
Last edited:

clouless

Occasional Visitor
2 subnets and OpenVPN client policy routing don t work to access an other subnet
what i got here a main modem/router from Uverse with 192.168.1.254 wireless and DHCP on it is working oK for the family, it is connected to the internet port of the asus ( VPN and wireless on) subnet is 192.168.2.1 when OpenVPN client policy routing is OFF I can ping the other subnet, access the config page of the Uverse one and above all use the printers on this subnet , when OpenVPN client policy routing is ON I cannot access the subnet and cannot input any Ip of CIDR, 192.168.1.64-192.168.1.253:
How should I do It? (bug?)
 

ml70

Regular Contributor
Still running into issues with running rsync jobs, almost always at the start of the job when it starts crawling through the directory tree. While testing, there's no other resource intensive programs running like Transmission or minidlna.

Studying /proc/meminfo while the process was running, combined with the oom-killer output, found out that the real cause is kernel running out of Normal Memory, meanwhile there is plenty of free High Memory available and swap is barely used at all, or even unused.

Experimenting with /proc/sys/vm/min_free_kbytes values i came upon an old Red Hat document detailing the old linux kernel defaults where by applying the formula i came upon a minimum default figure of (only) 16KB (was using 4096 as suggested on the forums, to avoid running into memory issues with Transmission), after applying it (16KB) there's 2 very telling lines in the oom-killer output in syslog:

kernel: Normal: 0*4kB 0*8kB 0*16kB 0*32kB 0*64kB 0*128kB 0*256kB 0*512kB 0*1024kB 0*2048kB 0*4096kB = 0kB
kernel: HighMem: 767*4kB 466*8kB 321*16kB 173*32kB 108*64kB 60*128kB 22*256kB 13*512kB 6*1024kB 0*2048kB 0*4096kB = 50492kB

There is no normal memory left at all! Surely that's a good cause for oom-killer to run, even if we're nowhere near total commit limit (normal memory size is just 10% of swap). Now just...why? And why is there a concept of normal and high memory on this cpu? 128MB per bank?

That there's 1GB swap available, unused :mad: Why doesn't it even swap? My swappiness level is 99. :eek: And i've also tried 1 and 100 and many between.

Here's output of /proc/meminfo close to the time before oom-killer activated, should it give any ideas:
[email protected]:/tmp $ cat /proc/meminfo
MemTotal: 239532 kB
MemFree: 4168 kB
Buffers: 55756 kB
Cached: 107924 kB
SwapCached: 0 kB
Active: 45148 kB
Inactive: 133516 kB
HighTotal: 131072 kB
HighFree: 1648 kB
LowTotal: 108460 kB
LowFree: 2520 kB
SwapTotal: 1048568 kB
SwapFree: 1048568 kB
Dirty: 1316 kB
Writeback: 2532 kB
AnonPages: 14992 kB
Mapped: 6236 kB
Slab: 48020 kB
SReclaimable: 32568 kB
SUnreclaim: 15452 kB
PageTables: 688 kB
NFS_Unstable: 0 kB
Bounce: 0 kB
CommitLimit: 1168332 kB
Committed_AS: 80944 kB
VmallocTotal: 1015800 kB
VmallocUsed: 6916 kB
VmallocChunk: 1006968 kB
 

kvic

Part of the Furniture
"Normal" could mean the kernel space memory. "HighMem" the user space memory. Based on your finding, I'm guessing Asus' favour of linux kernel is not tuned for running resource intensive apps.

Look for ways to allocate a higher portion of RAMs to the kernel. That may require a re-compilation of the kernel or adjust some boot arguments.

Still running into issues with running rsync jobs, almost always at the start of the job when it starts crawling through the directory tree. While testing, there's no other resource intensive programs running like Transmission or minidlna.

Studying /proc/meminfo while the process was running, combined with the oom-killer output, found out that the real cause is kernel running out of Normal Memory, meanwhile there is plenty of free High Memory available and swap is barely used at all, or even unused.

Experimenting with /proc/sys/vm/min_free_kbytes values i came upon an old Red Hat document detailing the old linux kernel defaults where by applying the formula i came upon a minimum default figure of (only) 16KB (was using 4096 as suggested on the forums, to avoid running into memory issues with Transmission), after applying it (16KB) there's 2 very telling lines in the oom-killer output in syslog:



There is no normal memory left at all! Surely that's a good cause for oom-killer to run, even if we're nowhere near total commit limit (normal memory size is just 10% of swap). Now just...why? And why is there a concept of normal and high memory on this cpu? 128MB per bank?

That there's 1GB swap available, unused :mad: Why doesn't it even swap? My swappiness level is 99. :eek: And i've also tried 1 and 100 and many between.

Here's output of /proc/meminfo close to the time before oom-killer activated, should it give any ideas:
 

rtn66uftw

Senior Member
Updated my RT-N66U from 378.52_2. Everything has been great so far. Much more stable even with Transmit Power set at 68%. Thanks Merlin for the update!
 

smallone

New Around Here
After an update on my RT-AC87 from 378.52_2 to 378.53 the wifi got really flaky and pretty unusable. I did a cold boot of it to see if it helped but nothing. Eventually i had to revert back to 378.52_2

I'm using ipv6 via static 6in4, custom ddns script, one openvpn server and one openvpn client. both 5ghz wifi and 2.4.

Has anyone else encountered that problem?
 

kman

Regular Contributor
Loving the policy based routing... One question, is there any way to route transmission or any other application running on the router to be routed through policy based rules or point me in that direction with the new policy based routing in VPN...

Thanks... much appreciated!
 
Last edited:

RussellInCincinnati

Senior Member
Still running into issues with running rsync jobs...
Why is it important to run rsync jobs on a wireless router? Can understand toying with the idea, but why pursue it for more than a few minutes if problems arise? Can't you do the same thing by running an rsync-type program on any client?
 

cosmoxl

Senior Member
The issue is definitely linked to that setting, I have three different test cases so far, all of them have that specific setting. At least one tunnel provider even pushes that setting at connection time, and I don't know if it can be overridden by the user.

The problem is, with that setting, when the tunnel goes down the openvpn binary does not executed the "down" script it's expected to, so the environment cleanup cannot be done by the openvpn executable. I can make the firmware take care of it for cases where the user is the one who turned the tunnel off, but I can't do anything about scenarios were the tunnel was terminated by the provider or by a loss of connection.

I personally think this is a bug in openvpn, as it should execute its "down" script in such cases. However whether the OpenVPN devs would agree with me is a different story...

same experience for me. +1
 

Danny Sasmita Natapradja

Occasional Visitor
The DNS config is STRICT (as it was before). Now I changed to RELAXED and everything is working. Except that I have a DNS leak...

I didn't change (at least not on purpose) any information on DNS, the WAN DNS is received from my ISP, my router distribute its own IP as a DNS for the DHCP clients... pretty simple.

Does it help if I send you some info? (route, etc)

I will try changing the DNS mode and see what is the impact.

Thanks!

I also have the same problem when using DNS Setting : Strict/Exclusive but when using my Linksys E1200 with Tomato Shibby 1.28 everything works ok unfortunately E1200 is very slow running openvpn :( I hope it will be fixed soon.
 

Attachments

  • log-ac68u-dns-exclusive.txt
    5.4 KB · Views: 638
  • log-e1200-dns-exclusive.txt
    9.5 KB · Views: 641

PorscheT

Occasional Visitor
I also have the same problem when using DNS Setting : Strict/Exclusive but when using my Linksys E1200 with Tomato Shibby 1.28 everything works ok unfortunately E1200 is very slow running openvpn :( I hope it will be fixed soon.
Using PIA VPN with AC56U just fine with "Strict" setting. Always did. I also came from Shibby 1.28.
 

Similar threads

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top