Asuswrt-Merlin 385.15 - OpenVPN fails to connect (AC86U)

  • ATTENTION! As of November 1, 2020, you are not able to reply to threads 6 months after the thread is opened if there are more than 500 posts in the thread.
    Threads will not be locked, so posts may still be edited by their authors.
    Just start a new thread on the topic to post if you get an error message when trying to reply to a thread.

player2020

New Around Here
Hi there,

I currently upgraded my ASUS router from an RT-AC51U to RT-AC86U to increase my wifi coverage and for openVPN Selective routing.
On my old AC51U configuring the OpenVPN client worked perfectly. How ever after purchasing the AC86U and upgrading the firmware to 384.15 Merlin i’ve not been able to get the VPN to connect and constantly get the following error:

Error connecting - Authentication failed

Log files shows the following lines that may indicate a problem:
  1. WARNING: this configuration may cache passwords in memory -- use the auth-nocache option to prevent this.
  2. SENT CONTROL [uk1051.nordvpn.com]: 'PUSH_REQUEST' (status=1)
  3. AUTH: Received control message: AUTH_FAILED
  4. SIGTERM[soft,auth-failure] received, process exiting
I’m following the below (url) process provided by NordVPN but the menu settings on the this refer to ASUS RT-AC87U with version 380.59 so the menu settings seem to differ from 384.15 therefore I can only think there’s some simple configuration I’m not aware of?

https://nordvpn.com/tutorials/asustwrt-merlin/openvpn/

Note*
I have checked my NordVPN credentials and they are fine.

Any comments would be much appreciated.



Virgin Hub3 (Modem Mode) - RT-AC86U on 384.15 Merlin firmware
 

fourty6and2

Occasional Visitor
When I setup my rt-ac86u to connect to ProtonVPN, I was getting an authentication error as well. Not sure if Nord is similar, but there is a different set of login credentials to use when not using their native app.

worth checking anyhow.
 

player2020

New Around Here
Thanks for the reply however with Nord there is only one set of credentials i use for both the native app and and OpenVPN via the router. This is how its been working for 2 years via the old AC51U

Cheers
 

player2020

New Around Here
I've tried 4 different ones already however only using UDP, but will use Client 2 to configure TCP and see if that makes any difference.

Thanks
 

player2020

New Around Here
Just tried TCP on Client 2 and get exactly the same outcome...Error connecting - Authentication failed
 

player2020

New Around Here
Just confirm a couple of things.

This is the customised configuration I'm using:

remote-cert-tls server
remote-random
nobind
tun-mtu 1500
tun-mtu-extra 32
mssfix 1450
persist-key
persist-tun
ping-timer-rem
reneg-sec 0
#log /tmp/vpn.log

This is the DNS Servers I've entered in the WAN settings:
103.86.96.100
103.86.99.100
 

player2020

New Around Here
SUCCESS

Hi,
I finally worked out what the problem was:
I was using my password key manager app to copy and paste the username then switch screens to go back and copy and paste the password. What I did not realise is that when I copied the Nord username and left the screen, the password manager auto switched to the Asus router credentials page, when i returned to copy the password, I was copying the wrong password.
I only noticed it when i decided to view password and was going to manually enter the details.

Many thanks for all your suggestions as it actually prompted me to delve a little deeper thus resolving the issue.
 

Similar threads

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top