Beta Asuswrt-Merlin 386.1 Beta is now available

  • ATTENTION! As of November 1, 2020, you are not able to reply to threads 6 months after the thread is opened if there are more than 500 posts in the thread.
    Threads will not be locked, so posts may still be edited by their authors.
    Just start a new thread on the topic to post if you get an error message when trying to reply to a thread.
Status
Not open for further replies.

mbze430

Regular Contributor
I recently factory reset my AX88U and currently on Beta 2. After manually setting up everything up again (painfully) my router ALWAYS "crashes" if I make changes now. well I just loses internet and I have to end up rebooting it even though some of the changes made by default doesn't require a reboot.


Are there any useful logs I can send for review to see why that is? I see my saved logs with bunch of "May 5 00:05:08 crashlog:" entries.
 
Last edited:

brianward317

Occasional Visitor
Update to my last post - updated to beta2, all good! Thank you, @RMerlin !!

Configuration:
RT-AC68U, 386.1beta2, FlexQos, VPN Client with Policy Routing.
54% memory usage, 26+ clients.

View attachment 28546
I feel in the 386 version, the memory usage is a lot better. I am running and have over 50 devices connected and it's running smooth. Right around 68% memory.
2 open Skynet v7.2.3
5 open scribe v2.4.3
j1 open connmon v2.8.1
j3 open scMerlin v2.0.1 <- v2.0.0
j4 open spdMerlin v4.1.1
j6 open uiScribe v1.4.0
NextDNS CLI.
 

L&LD

Part of the Furniture
@mbze430, unless 'recently' means after flashing Beta 2, it means very little.

If your router isn't stable a full reset is needed now (as also recommended by RMerlin too for these Beta's).
 

mbze430

Regular Contributor
@L&LD recently means yesterday I factory reset my AX88U while on Beta 2

I guess the part " After manually setting up everything up again (painfully) " wasn't hinting enough that.
 

modestyB

Occasional Visitor
AX88U Beta 2, factory reset.
Says today in Systemlog: summertime is activated for this time zone......

But on admin page summertime should only trigger mar-oct.
 

L&LD

Part of the Furniture
I would suggest trying the following steps, after removing all USB and any other connected devices from it.
  • Re-download the Beta 2 firmware for your router.
  • Verify it is not corrupt with something like Hashtab.
  • Format the JFFS partition on the next boot (click the box and make sure you hit 'Apply' before rebooting the router at least twice in 10 minutes, waiting 5 minutes between boots).
  • After allowing the router to settle after the last reboot above for at least 5 minutes, Reset the firmware to factory defaults and make sure you select the 'Initialize all settings button...' before doing so.
  • When the router reboots, reflash the firmware you downloaded and verified in the first few steps above.
  • Repeat the last three steps above to make sure the router is fully reset and is using its expected defaults on the firmware you want to use.
Do not use a saved backup file. Do not plug in the USB drive used previously for amtm, the swap file, and Entware + scripts. Before plugging in this drive, be sure you format it on a PC with NTFS.

Use the amtm Step-by-Step Guide to properly format it, set a swap file, and Entware for stable script use. Please ignore the steps to install amtm of course, it is included since RMerlin firmware 384.15_0.
 
Last edited:

L&LD

Part of the Furniture
No, it just seems like it's forever compared to what we're used to with RMerlin and all the other script devs here. :)
 

Slawek P

Senior Member
You may have connected to a different server with your ISP on reboot...
question: why are you running both connmon and spdmerlin? I lean towards thinking that's unnecessary redundancy and processor/connection load
Yes had the same thoughts later - BT reassign IPv4 each time and indeed I am hitting a different one on the fourth trace route hop than before.
Good point on connmon and spdMerlin - I guess I did not trust BT originally, but perhaps it is time to just leave one...
 

Phil Outram

Regular Contributor
Not sure if this has already been mentioned or not but openvpn client traffic is now inverted (download traffic appears as upload and upload traffic appears as download). I know there has been a long standing issue where the bandwidth monitor tab had the traffic inverted in this way but the classification tab was always correct, now it is inverted as well (and so is FlexQoS). QoS still appears to function correctly for me despite this but it would be nice if anything could be done to place it under the correct area in classification tab.
 

Aerandir14

Occasional Visitor
I have an OpenVPN Server set on my AX86U and when I connect to it through the LAN on my Windows 10 desktop, it seems like the DNS requests don't get to dnsmasq.
However, when connecting to the OpenVPN server with the same configuration on my Android smartphone, from LAN, everything works fine.

I looked at the dnsmasq.log file, when trying to access google.com on my phone, a query appears.
However, when trying the same thing on my desktop, no query shows up in the dnsmasq log.
However, I get response when doing a ping to 8.8.8.8.

I have Diversion + Skynet + Unbound installed + IPv6 passthrough.

Could it have something to do with IPv6 ?
What could explain that the DNS query from my desktop doesn't show up in the dnsmasq logs?


PS: Doing some tests, I also found out that I solved the "protocol 0800 is buggy" issue by disabling IPV6 (previously configured as Passthrough) on my AX86U.
 

WillyTP

Regular Contributor
Hello once again everybody

Just to clarify: is there anyone that with Beta2 solved Let's Encrypt issue?

Personally I didn't.
Best regards
 

Deekers

New Around Here
Just dirty flashed my AC3100 from 384.19 to 386 beta 1.

GUI loaded fine, but processor usage on both cores never dropped under 65%.
Rebooted
Processor usage returned to normal. Then I noticed that zero wireless clients were showing when I clicked on "View List" under clients. None (not even the laptop I was using to configure it). All hardwired clients were showing. Also, my AIMesh stopped working.
Flashed the 2nd router (aimesh node...AC68U) to 386.1 with no issues.

Still couldn't add the AIMESH node from the first router.
Reset my AC3100 back to 384.19 without issue. All clients once again show and I could add the AIMESH node router.

Flashed 386 beta 1 back to the AC3100 again. Still won't show any wireless clients and cannot add AiMesh node.

Flashed the AC3100 back to 384.19.

Anyone else having similar issues?

Just want to confirm that Beta 2 has fixed all of the issues above for my AC3100. All wireless clients are showing correctly and AiMesh is performing perfectly.
 

csalsa

Occasional Visitor
Did you perform a Factory Device Reset/format jffs after upgrading (at least to beta 1)?
That has been solving a number of issues.
Found the problem. Guest WiFi does not route correctly through router VPN client.

I went back to the beginning to think of what testing I could do and I realised all the IOS devices were connected to the Guest WiFi network. The devices always register successfully connected to the Wireless AP on the device but cannot access the Internet or the router home page on the IP gateway address on the Guest WiFi.

I verified this by connecting IOS devices to the main WiFi and android devices to the Guest WiFi. IOS devices started working and Android devices stopped working.

Thanks for your suggestion of the factory device reset. Yes. I had done it but good reminder.
 

EricTheRed

Occasional Visitor
I noticed another problem on the AX-86U /w beta 2. Doing a router based speed test via the browser yields full internet speeds. However, doing a wired speed test on other devices yields less than half the rated upload speed. This is on a gigabit connection where the router shows over 700 Mbps upload and devices are seeing 320Mbps
 

heysoundude

Very Senior Member
Yes had the same thoughts later - BT reassign IPv4 each time and indeed I am hitting a different one on the fourth trace route hop than before.
Good point on connmon and spdMerlin - I guess I did not trust BT originally, but perhaps it is time to just leave one...
spdMerlin is all you need...free up a few processing cycles and various smidgins of memory.
 

bbunge

Part of the Furniture
About the only minor issue is that the Adaptive QOS/Bandwidth Monitor/Download Bandwidth (and possibly Upload Bandwidth) do not register properly. System Status/System/Internet Traffic does register correctly.
Yes, I have done a Hard Factory Reset coming from the alpha version.
Not a show stopper for me.
AC86U beta 2 FlexQOS Diversion
 

crkpot

Occasional Visitor
Anyone trying AdaptiveQOS on RT-AX58U with beta2? It seems to be working for me now that it's sat for a day, but when I first turned it on, speeds were all over the place. AdaptiveQOS has never worked right on this router even with stock, so it's nice to see right now.
 

octopus

Very Senior Member
I have used 386.1-Beta2 for 2 days 14 hour(s) 54 minute(s) 28 seconds on a RT-AX86U and almost everything working fine.

It's still problem with WAN "Internet Status" get offline when change any settings and hit apply on client3 and no Internet.
(Automatic start at boot time "yes")

I have client1 and 3 running. I dont think it's changed value itself but hit apply button and restart vpnclient3 is issue.
When I do same with client1 it's working and no wan get offline.
Turn "Internet connection" off and on again turn everything normalt again and GUI display right WAN-IP and DDNS.

Octopus

@RMerlin
 
Status
Not open for further replies.

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top