Release Asuswrt-Merlin 386.2 is now available

  • ATTENTION! As of November 1, 2020, you are not able to reply to threads 6 months after the thread is opened if there are more than 500 posts in the thread.
    Threads will not be locked, so posts may still be edited by their authors.
    Just start a new thread on the topic to post if you get an error message when trying to reply to a thread.
Status
Not open for further replies.

Hazel

Senior Member
Figure i save you the pain and maybe the router.
Crappy one handed quality to put it mildly but good enough for the job.

Didn't bother recording to the end as there was no point


Holy sh*t. I just read @RMerlin in another thread saying this wouldn't be possible, but apparently it is. This might be a huge issue and could cause a lot of bricked routers. People, ffs check whether you're uploading the correct firmware and Asus, please stop re-using model numbers and get your upgrade verification process back on track.

 
Last edited:

Magnus33

Regular Contributor
Holy sh*t. I just read @RMerlin in another thread saying this wouldn't be possible, but apparently it is. This might be a huge issue and could cause a lot of bricked routers. People, ffs check whether your uploading the correct firmware and Asus, please stop re-using model numbers and get your upgrade verification process back on track.
He right under normal circumstances it shouldn't be possible but clearly something different this time.
 

Hazel

Senior Member
He right under normal circumstances it shouldn't be possible but clearly something different this time.

I've made the same mistake before myself once, with a previous build, but the verification process stopped me from messing things up, but it looks like there's a bug in the verification process now. @RMerlin, can you check and if so, inform Asus?
 

stefan21

Occasional Visitor
Did a dirty upgrade on a RT-AC68U from 386_2_2 to 386_2_4. VPN (ExpressVPN) does not start automatically after reboot. Any idea where to investigate?
 

Hazel

Senior Member
Did a dirty upgrade on a RT-AC68U from 386_2_2 to 386_2_4. VPN (ExpressVPN) does not start automatically after reboot. Any idea where to investigate?
First check the setting Automatic start at boot time on the VPN Client page is set to Yes. If that's enabled, check system log for clues, why it doesnt start automatically. Check the current time and date as well.
 

Magnus33

Regular Contributor
AC86U routers I play with are all repaired and disposable units. I see the process is starting, but as far as I know the notification pops up later on.
?

I am going to guess you haven't flashed many of these because that made no sense.
It informs your right away that the upgrade was unsuccessful not part of the way through its not how things work.

Don't take my word for it though as i am sure Merlin and everyone else here can confirm that for you.

Also the only reason i didn't record it tell the end was youtube has a 200mb upload limit for non-confirmed accounts.

Or you can try yourself and keep in mind that the router shall be unrecoverable as far as we know at this point.
 

Tech9

Part of the Furniture
Or you can try yourself and keep in mind that the router shall be unrecoverable as far as we know at this point.

Okay, I trust you. That bug has to be addressed quickly. The routers I have are failed units with zero value repaired by me. I can recover wrong flash quickly with a donor flash chip, I believe. I’m running low on donors and want to test AiMesh so you temporarily saved one AC86U soul. Thank you!
 

stefan21

Occasional Visitor
First check the setting Automatic start at boot time on the VPN Client page is set to Yes. If that's enabled, check system log for clues, why it doesnt start automatically. Check the current time and date as well.
Automatic start is enabled. I'm pretty sure it's the time disparity. VPN is trying to connect instantly while the device has booted. Syncing with the time servers (0.de.pool.ntp.org and 1.de.pool.ntp.org) is taking too long or the time delay is too long. I'll try to set the connection retry attempt to infinite. Maybe it helps.
 

Hazel

Senior Member
Automatic start is enabled. I'm pretty sure it's the time disparity. VPN is trying to connect instantly while the device has booted. Syncing with the time servers (0.de.pool.ntp.org and 1.de.pool.ntp.org) is taking too long or the time delay is too long. I'll try to set the connection retry attempt to infinite. Maybe it helps.
If time hasn't been synced yet (by ntpd or chronyd), certificates aren't valid yet. Under normal circumstances time is synced 'in time'. Are your WAN DNS servers filled? If NTP takes to long to sync for whatever reason, search the forum for a script by @Jack Yaz called ntpbootwatchdog, it can save you a lot of trouble. At least, it did in my case.

Edit: here you go - https://www.snbforums.com/threads/ntp-boot-watchdog-script.71069/
 

Hazel

Senior Member
Is there a way to start the VPN by a script?

There is, but you can start it manually from the UI too. Both won't work currently, because if time isn't synced, you've got other issues and the service isn't going to be started either way, by script or manually, because the certificates aren't valid yet. Your router has a default time which it uses as 'placeholder' until it's synced with the actual time, because it has no separate power source and an internal clock to remember the current time when switched off or rebooted.

So fiddling with a script won't help you, you need to find to underlying cause. And for that we need the system logs to determine what goes wrong. Go to system log messages, disable auto refresh, copy a large piece preferably from when your router reboots until after it fails to start OpenVPN Client 1 and paste it on a website like pastebin.com or one of it's many alternatives (make sure you redact any private information beforehand) and post the link here, so we can figure out what's going wrong.

As this is a release thread, I suggest you open a separate thread, as this is not a specific issues caused by your upgrade from 386.2_2 to 386.2_4 but more an unfortunate coincident. At least, I can't think of a cause as many have already upgraded to 386.2_4 and our VPN's worked fine after upgrading, so I suspect the cause to be something else. I haven't seen other reports so far.
 

rtn66uftw

Senior Member
Did a dirty upgrade on a RT-AC68U from 386_2_2 to 386_2_4. VPN (ExpressVPN) does not start automatically after reboot. Any idea where to investigate?
I am seeing the same issue with Winscribe on AC-86U. In previous versions the VPN automatically started
 

Hazel

Senior Member
Is there a way to start the VPN by a script?
I have replied, but my reply is held back, awaiting for moderation. Please check back later and please in the meantime open a new thread for your issue, as I'm pretty certain this has nothing to do with you upgrading to 386.2_4 (more about that in the post that's currently invisible and awaiting moderation).
 

festus77

Occasional Visitor
Dirty upgrade from 386.2_2 to 386.2_4 for both router & node. No issues after 3 hours.
 

Tech9

Part of the Furniture
Or you can try yourself and keep in mind that the router shall be unrecoverable as far as we know at this point.

I pulled the trigger actually and the firmware got rejected. :rolleyes:
Did you make the video with already loaded AX86U firmware on this AC86U router? You have mentioned wrong firmware update on May 2nd and the video was made on May 3rd. How did you recover the router to correct AC86U firmware to make this video? We need correct information here. What I saw is what @Clark Griswald said above in post #691. What @RMerlin says is the only chance to bypass the verification is to attempt flash in recovery mode.
 

stefan21

Occasional Visitor
I have replied, but my reply is held back, awaiting for moderation. Please check back later and please in the meantime open a new thread for your issue, as I'm pretty certain this has nothing to do with you upgrading to 386.2_4 (more about that in the post that's currently invisible and awaiting moderation).
ntp-boot-watchdog-script

For the second sript I made an error by copy and pasting - I missed the shebang at the beginning of the init script. Of course, this cannot work. Seems to be fine now. Sorry, my fault. Thank's for staying with me. Anyway I'd suggest to think over that bug for the next release. Not everybody is capable to create scripts...

regards,
stefan
 

maxbraketorque

Very Senior Member
After updating to 386.2_4, some internet addresses are not being resolved. I'm seeing it from at least two different machines on the network, so it appears to be something related to the routers DNS configuration which I haven't changed in at least a month.
 
Status
Not open for further replies.

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top