Release Asuswrt-Merlin 386.2_6 is now available

  • ATTENTION! As of November 1, 2020, you are not able to reply to threads 6 months after the thread is opened if there are more than 500 posts in the thread.
    Threads will not be locked, so posts may still be edited by their authors.
    Just start a new thread on the topic to post if you get an error message when trying to reply to a thread.

anotherengineer

Regular Contributor
Dirty upgrade from 386.2_0 and so far so good.
 

Sonicmojo

Regular Contributor
I am currently running Merlin 384.15 (which oddly does NOT appear in the official changelogs) on my RT-AC86U - is there anything specific that I need to do before moving right up to this current build (386.2_6)?

In the past - I have been simply doing a "dirty" update (Assuming this term means "right over top" of the existing firmware) with no issues as of yet.

Appreciate any tips or warning before I set out to upgrade this router.

Cheers!

VP
 

uwish

Occasional Visitor
All good so far!
 

det721

Part of the Furniture
I am currently running Merlin 384.15 (which oddly does NOT appear in the official changelogs) on my RT-AC86U - is there anything specific that I need to do before moving right up to this current build (386.2_6)?

In the past - I have been simply doing a "dirty" update (Assuming this term means "right over top" of the existing firmware) with no issues as of yet.

Appreciate any tips or warning before I set out to upgrade this router.

Cheers!

VP

Just load the new firmware. If you start getting wierd stuff happening it's time for a complete factory reset and reconfigure manually.
 

Makaveli

Very Senior Member
Had to wait until work day was completed. Just updated and running good no issues.
 

mxoz

Occasional Visitor
Upgraded my RT-AX58U from 386.2_4 to 386.2_6. After the reboot ethernet connectivity works (TV connected), but no WIFI (no light indicators on for 2.4/5, nor my devices see usual wifi networks). Any ideas what might be wrong and how to troubleshoot/fix it?

Edit: all is fine now.. had to connect to the router via the cable and discovered that wifi radio was switched off... Still curious how did it happen.
 
Last edited:

DallasFlier

Occasional Visitor
Dirty upgrade to my AIMesh system, all 3 routers. Running fine.
 

BreakingDad

Very Senior Member
Another sneaky late night update when all are asleep except me. sshhhhh.
 

QuikSilver

Very Senior Member
20+ day uptime but dirty upgrade from 386.2_4 on both AC86u units and so far so good.
 

predatorz

Occasional Visitor
Dirty upgrade from 386.2_4 to 386.2_6 so far so good.
 

Darcy

Senior Member
Tried updating my AX86U and AC86U with no luck. I can download the files and when I hit apply nothing happens on either router. Tried 2 computers and multiple browsers with no luck Even tried updating from the ASUS router app and nothing
 

kernol

Very Senior Member

joegreat

Very Senior Member
Tried updating my AX86U and AC86U with no luck. I can download the files and when I hit apply nothing happens on either router.
Could be memory shortage: Reboot the router and try again to update the firmware.
Or use this script to flush memory and hit "upload firmware" immediately after:
Bash:
#!/bin/sh
#
echo 'Memory usage BEFORE Clear...'
free
#
# Clear Swap-File(s)
sync; swapoff -a
#
# Clear PageCache, dentries and inodes.
# Note, we are using "echo 3", but it is not recommended in production instead use "echo 1" (Clear PageCache only)
sync; echo 3 > /proc/sys/vm/drop_caches
sync; echo 1 > /proc/sys/vm/drop_caches
#
echo 'Memory usage AFTER Clear...'
free
#
exit 0
 
Last edited:

Serkan K.

Occasional Visitor
Thank you for the update. I did a dirty update of AC86U from 386.2_4 two hours ago and everything is okay.
 

liukuohao

Occasional Visitor
Hi All,

I am very new to this Auswrt-Merlin firmware,
I have a rt-ac86u router that has Merlin being flashed for me by the vendor.
He advise me to do a factory reset after doing the new update.

Question:
1)Do I need to press the reset button after doing the manual flashing the updated firmware?

2)Also what is dirty upgrade mean?

Thank you
 
D

Deleted member 76736

Guest
A "clean" install means to install/flash a new/old firmware and AFTER THIS (!) do a factoryreset an configure it manually (NO backup of settings from other firmwares).

A "dirty" upgrade means to install/flash new/old firmware WTHOUT doing a factory reset. So you run your router with old settings but an new firmware.

Dirty upgrade from 386.2_4 main and node... Everything´s ok!!!
 
Last edited by a moderator:

JohnDeere

Regular Contributor
I've seen this before on different firmware. Turn it off, turn it on again, re-apply settings, re-import your certificate. Should be fine after.
Thanks for the reply, I've tried this, but it did not solve the problem so far. However, I noticed that WiFi is no longer accessible. 2.4G band has dissapeared, and the 5G band does not connect, saying wrong password... Might these problems related to the same issue?
I think I will downgrade back to 386.2_2 then apply the 386.2_4 and see if then I can upgrade to this version without issues.
 

Unetwork

Regular Contributor
Upgrade 386.2_4 to 386.2_6 + WPS reset + complete reconfiguration = no problem, everything is very stable on my RT-AX88U !
Thanks again to @RMerlin and his developers ;)
 

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top