Asuswrt-Merlin and Nordvpn

Hoganwch

New Around Here
Trying to install the vpn UDP file in Asuswrt-Merlin ver. 386.4 for Asus RT-AC88U. (Having the same issue with RT-AC3100). When I upload the file it clears everything else. I've tried numerous combinations, but the router does NOT redirect. Using Nordvpn. Had great success with earlier versions. Nordvpn actually has a "how to" on their site which I've used several times as well. Wondering what ideas anyone has to resolve.
 

ColinTaylor

Part of the Furniture
On the VPN client page first click on Default. Wait a few seconds for everything to reset and then browse to your ovpn file, select it and click Upload. After a few seconds the new settings should appear and you can scroll down to add your username and password.
 

Hoganwch

New Around Here
Thanks for the response. You can see the result here. It doesn't redirect. I'm very familiar with this and have set up numerous routers. The file uploads and clears everything. It doesn't appears to stay resident. I populate everything and this is what I get. When I re-upload the udp file, I have to re-enter the user name and password. It appears to be an error in the file upload. I'm using a udp file from Nordvpn.
1642221507788.png


Any insight will be appreciated...
 

eibgrad

Part of the Furniture
Beware, if the .ovpn file does NOT contain the following directive ...

Code:
redirect-gateway def1

... then it will leave the "Redirect internet traffic through tunnel" setting in the GUI as No (the default), rather than "Yes (all)". Since most providers push that directive from the server to the client, it wouldn't surprise me if many (most?) don't bother to include it in the client's config file. Prior to 386.3, having "Redirect internet traffic through tunnel" set to No would still allow the client to be redirected over the VPN provided the server pushed that directive. But with the introduction of 386.3 and beyond, that's no longer the case. When "Redirect internet traffic through tunnel" is set to No, it means NO!
 

Hoganwch

New Around Here
Beware, if the .ovpn file does NOT contain the following directive ...

Code:
redirect-gateway def1

... then it will leave the "Redirect internet traffic through tunnel" setting in the GUI as No (the default), rather than "Yes (all)". Since most providers push that directive from the server to the client, it wouldn't surprise me if many (most?) don't bother to include it in the client's config file. Prior to 386.3, having "Redirect internet traffic through tunnel" set to No would still allow the client to be redirected over the VPN provided the server pushed that directive. But with the introduction of 386.3 and beyond, that's no longer the case. When "Redirect internet traffic through tunnel" is set to No, it means NO!
THAT fixed it. Thank you. I've used these instructions for 386.2 - https://support.nordvpn.com/Connectivity/Router/1047410642/AsusWRT-Merlin-setup-with-NordVPN.htm. I put the code you suggested in the Custom Configuration field. I them realized I could simply select redirect all internet traffic using the network settings, so eliminated the custom statement (for ease of use). It seems to be working fine. (I found that I could not specify the WAN DNS settings they suggest.) THANK YOU. I use this to setup multiple vpns for various language feeds.
 

Viktor Jaep

Regular Contributor
THAT fixed it. Thank you. I've used these instructions for 386.2 - https://support.nordvpn.com/Connectivity/Router/1047410642/AsusWRT-Merlin-setup-with-NordVPN.htm. I put the code you suggested in the Custom Configuration field. I them realized I could simply select redirect all internet traffic using the network settings, so eliminated the custom statement (for ease of use). It seems to be working fine. (I found that I could not specify the WAN DNS settings they suggest.) THANK YOU. I use this to setup multiple vpns for various language feeds.
Glad you got that working. If you're interested, there's actually a much better custom config available than the one that NordVPN provides... this one has definitely helped boost my speed considerably.

Code:
remote-random
resolv-retry infinite
remote-cert-tls server
ping 15
ping-restart 0
ping-timer-rem
persist-key
persist-tun
reneg-sec 0
fast-io
disable-occ
mute-replay-warnings
auth-nocache
sndbuf 524288
rcvbuf 524288
push "sndbuf 524288"
push "rcvbuf 524288"
pull-filter ignore "auth-token"
pull-filter ignore "ifconfig-ipv6"
pull-filter ignore "route-ipv6"
explicit-exit-notify 3
tun-mtu 1500
tun-mtu-extra 32
mssfix 1450
 

Viktor Jaep

Regular Contributor
What rates do you gents see with NordVPN? I only have LTE so can't test it.
I have a 1GB Xfinity Cable connection... the results I get yield a little over 200Mbps to my closest server over NordVPN.

Screenshot 2022-01-15 19.11.28.png
 

Similar threads

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top