Ausu RT-AC86U and Brother HL-2280DW Connecting Through WiFi

  • ATTENTION! As of November 1, 2020, you are not able to reply to threads 6 months after the thread is opened if there are more than 500 posts in the thread.
    Threads will not be locked, so posts may still be edited by their authors.
    Just start a new thread on the topic to post if you get an error message when trying to reply to a thread.

MacGyverSG1

New Around Here
Hi,
I'm trying to connect my Brother HL-2280DW printer to my Asus RT-AC86U router through WiFi. I have to use the printer's little LCD screen and up and down buttons to input all info. The printer finds the SSID, but then I have to enter a Network Key. I tried the WPA Pre-Shared Key, didn't work. I tried the wifi password also, no go. Does the fact that the printer's wifi is b/g matter?

BTW, I was using Asuswrt-Merlin 384.18_0 when I first tried connecting printer. I updated to 386.1_2 today. Haven't tried connecting again, yet.
 
Last edited:

eibgrad

Very Senior Member
Seems more likely your router requires WPA2 rather than WPA. And make sure the router's wireless mode isn't N Only.
 

MacGyverSG1

New Around Here
The printer was not asking for WPA or WPA2 key (just a "Network Key"). "WPA Pre-Shared Key" is in the list for "Wireless - General" section. There is no option to choose WPA or WPA2. Wireless mode is set to Auto (options are Auto - N/AC mixed - Legacy).
 

ColinTaylor

Part of the Furniture
According to this manual (page 17) it should work when you select SSID > Infrastructure > WPA/WPA2-PSK > AES > password_for_SSID.

Does your printer have the option to use AES or is it limited to TKIP?
 
Last edited:

MacGyverSG1

New Around Here
I was on brother's website looking at that same instructions that page 17 shows. I never had to choose AES or TKIP. I didn't even have to choose between ad-hoc or infrastructure either. I'll try again tomorrow. It was late Thursday night when I was trying to get it to work (and I had had a few drinks).

I was frustrated by then because I was trying to share the printer on my network. The printer is attached to a Windows 7 Pro desktop (the desktop is connected to network using WiFi) using USB. Another Windows 7 Pro desktop wired to router can see printer and print to it. A Windows 10 Pro desktop and Windows 10 Pro laptop both connected using WiFi cannot see printer over network (but can see shared folders/files). Print sharing is enabled.

I'll report back when I can retry network setup trying to select Infrastructure -> WPA/WPA2-PSK -> AES -> WPA key or WiFi password.
 

MacGyverSG1

New Around Here
Well, after rebooting all computers and router. I then tried connecting the printer again and I pressed Menu -> Network -> WLAN -> Setup Wizard. Then it wants SSID, it searches and I select correct one. Then it wants Network Key. I enter the WPA Pre-Shared Key (from Wireless - General section in router GUI, which I have done many times before) and it connected and did a successful test print. The setup wizard never asked about ad-hoc or infrastructure. Didn't ask about authentication method or encryption type either.

I was able to add the printer on my Win 10 computers and print documents. I'm not sure what fixed the problem. It may have been rebooting everything, even though I'm pretty sure I did that at least once before.

BTW, when I updated the firmware on the RT-AC86U from 384.18_0 to 386.1_2, the WiFi password changed, even though I didn't change anything. The WiFi password is now the WPA Pre-shared Key, which has been the same thing with both firmwares. Strange.

At least everything seems to be working now, so far.

Thank you everyone for the input.
 
Last edited:

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top