Authentication failure on Asus router app after firmware upgrade

  • ATTENTION! As of November 1, 2020, you are not able to reply to threads 6 months after the thread is opened if there are more than 500 posts in the thread.
    Threads will not be locked, so posts may still be edited by their authors.
    Just start a new thread on the topic to post if you get an error message when trying to reply to a thread.

Smokie

Regular Contributor
As it states in the title. I updated the firmware the other night and seemed to have some issues with the router not been live on the app.
I decided to delete it and when I reinstalled it I can no longer log in.

Opening a browser and logging in with same user name and password works perfect. Issue seems to be just with the app.

Anyone have a similar issue?
 

dctrbnsttr

Occasional Visitor
As it states in the title. I updated the firmware the other night and seemed to have some issues with the router not been live on the app.
I decided to delete it and when I reinstalled it I can no longer log in.

Opening a browser and logging in with same user name and password works perfect. Issue seems to be just with the app.

Anyone have a similar issue?
I have written about the exact same problem elsewhere in these forums. RT AC5300 router. I have sent feedback to ASUS. So far, no response.
 

OzarkEdge

Part of the Furniture
Anyone else encounter this issue? Still no word back from my feedback to Asus

Did the app enable Web access to your router and setup a DDNS client? If so, is this acceptable to you, security-wise?

OE
 

Smokie

Regular Contributor
Did the app enable Web access to your router and setup a DDNS client? If so, is this acceptable to you, security-wise?

OE

Yeah it looked like it did so I turned it off. Before the update I had tried the alexa skill, enabling this turns DDNS on but I disabled it because the skill was uselss
 

OzarkEdge

Part of the Furniture
Yeah it looked like it did so I turned it off. Before the update I had tried the alexa skill, enabling this turns DDNS on but I disabled it because the skill was uselss

Actually, I think the app enables Web access and DDNS for the app's remote access to your router. And now it is having trouble accessing your router locally after a firmware update. Think about it... do you really want Web access to your router subject to the uncertainties of router firmware and Android apps and updates?

OE
 

Smokie

Regular Contributor
No I think your wrong. Up to this update I could only access my router via the app while on my network. There is the option to enable it remotey and I tried this before.

But your right I didn't want to leave something open so I disabled it.

This issue we are reporting is possibly a big in the firmware.
 

OzarkEdge

Part of the Furniture
No I think your wrong. Up to this update I could only access my router via the app while on my network. There is the option to enable it remotey and I tried this before.

But your right I didn't want to leave something open so I disabled it.

This issue we are reporting is possibly a big in the firmware.

See your other post.

OE
 

Smokie

Regular Contributor
As far as I remember the firewall was off from when I bought this router. Don' think the app had anything to do with it. Im all confused now lol
 

OzarkEdge

Part of the Furniture
As far as I remember the firewall was off from when I bought this router. Don' think the app had anything to do with it. Im all confused now lol

The default reason to buy a router is for its firewall which is ON by default.

The app may not have touched your firewall, but it may have enabled remote access to your router, and if that is not 100% secure, then someone else could have accessed your router and perhaps turned your firewall off.

The safe thing to do would be to factory default reset your router, reconfigure it from scratch, be sure to disable the questionable features, and don't use the app... imo.

OE
 

Smokie

Regular Contributor
Cheers.. questionable features? Anything in particular? When I use the scan for security issues it states UPNP is on and recommends it off
 

OzarkEdge

Part of the Furniture
Cheers.. questionable features? Anything in particular? When I use the scan for security issues it states UPNP is on and recommends it off

Also see the last firmware release... install it and then perform a factory rest.

The security scan is a good review. Do what it says.

Some items to consider:
- wireless security, WPA2-Personal, AES
- disable WPS
- disable UPnP
- confirm Telnet is disabled
- confirm SSH is disabled
- confirm Web Access from WAN is disabled
- enable AiProtection/Network Protection and perform Router Security Assessment Scan

And, I would avoid the app.

OE
 

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top