AX86U Speetest 600 mbit CPU Limit

netolo

New Around Here
Hi guys,

Using currently 386.5 and have the longterm issue that my bandwith Tests going up arorund 600 mbit. I've read here lot threads about Speedlimits but it doesnt help me.
It's a LAN-WAN Connection with QoS and everything else turned off. The Speedlimit come from only using 1 of the 4 cores @ 100% when I do the test. Dont know why this not spread to the other CPU's.

When I do the same Test on the Router Im getting arround 1gbit and it spread propper on all 4 CPU's. Any idea on that?
There is no QOS activated.

Thank you for any help.

Edit: sorry for posting it into wrong subforum. ASUS Wireless would be the right place, cannot move it by myself ...
 
Last edited:

Tech Junky

Very Senior Member
This is conflicting to say the least. You say you're testing from the router @ 600mbps and then in the next line you say the same thing @ 1gbps.

Speed testing should NOT be done from the router but THROUGH the router. These consumer devices don't handle apps very well and will give the impression of not working.

If your devices aren't having any issues then quit looking for one somewhere else. It's much easier to do whatever you need to do online w/o worrying about a speed test if pages are working properly. If you want to test speeds I would suggest using a torrent client and downloading a large enough file that can sustain bandwidth during the download like a Linux ISO. Once the client connects to the swarm it should be a blink of the eye before it's completed... well a few seconds actually.
 

drinkingbird

Senior Member
Hi guys,

Using currently 386.5 and have the longterm issue that my bandwith Tests going up arorund 600 mbit. I've read here lot threads about Speedlimits but it doesnt help me.
It's a LAN-WAN Connection with QoS and everything else turned off. The Speedlimit come from only using 1 of the 4 cores @ 100% when I do the test. Dont know why this not spread to the other CPU's.

When I do the same Test on the Router Im getting arround 1gbit and it spread propper on all 4 CPU's. Any idea on that?
There is no QOS activated.

Thank you for any help.

Edit: sorry for posting it into wrong subforum. ASUS Wireless would be the right place, cannot move it by myself ...

So when you test from a computer, you're seeing 600M, but when you test from the router GUI, you see 1G? That's the opposite of how it usually works so that is odd. But that router should be able to pass 1G just fine. Are you sure you have NAT acceleration enabled and none of the AIProtection, QOS, parental controls, etc? Have you done a factory reset after upgrading the firmware? In one case my throughput doubled after a factory reset following a firmware upgrade (granted it was a big upgrade, from 384 to 386).

Also could be as simple as trying a different server on speedtest.net, but if you're seeing one CPU pegged at 100% that definitely points to something running on the router that is hogging resources during the test.
 

drinkingbird

Senior Member
Routing is on single core only.

When I run a speedtest on my 1900 (68U) both cores are used about the same. 350 megs has them both around 60%. A long time ago it used to only use one and I was getting limited to around 270M, but after a firmware upgrade and reset a year or so ago, it now uses both and I get much better throughput, so they did improve something at some point. I do have aiprotection and traffic monitor enabled so maybe routing is using one core and aiprotection is using the other, but the percentages are nearly identical.

I think if you're running bare bones maybe it only needs to use a single core since HW acceleration means it doesn't need much CPU, but once you start turning on features it starts to use the other core(s)?
 

Tech9

Part of the Furniture
When I run a speedtest on my 1900 (68U) both cores are used

This router uses the CPU for Wi-Fi modules as well. BCM4360 doesn’t have dedicated processing units.
 

netolo

New Around Here
Thanks for the replays. I will try a factory reset. All features of the router AI Protection, QOS, all turned off. Checked it many times :). The Only features that Im using is (but not while speedtesting) is WireGuard and ADGuard Home. Ususally the CPU is not on load 1-2 % when I don't run a speedtest.

@drinkingbird: Could not find any Settings about NAT acceleration, where can I find it? Saw it on a screenshot under LAN Settings. But ony my WebUI I miss that. (tryed also speedtest with jumbo frame off):

1653453978394.png


It will be a lot of work but if you guys think a factory reset could help I will test that. Thanks, didnt know that the routing only made by 1 Core :(. As wrote in my first mail yes on WebUI I Archive good speeds. Tryed different Server for speedtesting:

1653453175378.png
 
Last edited:

drinkingbird

Senior Member
Thanks for the replays. I will try a factory reset. All features of the router AI Protection, QOS, all turned off. Checked it many times :). The Only features that Im using is (but not while speedtesting) is WireGuard and ADGuard Home. Ususally the CPU is not on load 1-2 % when I don't run a speedtest.

@drinkingbird: Could not find any Settings about NAT acceleration, where can I find it? Saw it on a screenshot under LAN Settings. But ony my WebUI I miss that. (tryed also speedtest with jumbo frame off):

View attachment 41392

It will be a lot of work but if you guys think a factory reset could help I will test that. Thanks, didnt know that the routing only made by 1 Core :(. As wrote in my first mail yes on WebUI I Archive good speeds. Tryed different Server for speedtesting:

View attachment 41391

If you have not factory reset recently, especially if you upgraded from an older code base or have upgraded several times, then I think a factory reset is worth the effort (make sure to format JFFS too). Check your speed test after just basic setup, then add other things like wireguard etc and see if they cause the issue again. At one point I did a factory reset, and with all the exact same settings and features enabled, I went from 100% CPU and being limited to 270 megs to 60% CPU and hitting my full 350.
 

netolo

New Around Here
Thanks a lot for the info for factory reset. After factory reset I receive full speed :):

1653455161995.png


Now I will reconfigure everything... ;-), you saved my day!

Edit: After all reconfiguration, wireguard adguard etc. speed still the same. Factory Reset solved my problem. thanks!
 
Last edited:

drinkingbird

Senior Member
Then something else is using the second core, perhaps TrendMicro components.

Yeah who knows, previously speedtest would max out 1 core and the other was idle. After I upgraded firmware and did a factory reset, it now uses both cores with nearly identical percentages. Perhaps the CPU usage I'm seeing is all trend micro and traffic monitor and the routing is negligible (with HW acceleration the routing should not use much CPU). At some point they probably optimized it so those features can use both cores.
 

papypaprika

Occasional Visitor
Thanks for the replays. I will try a factory reset. All features of the router AI Protection, QOS, all turned off. Checked it many times :). The Only features that Im using is (but not while speedtesting) is WireGuard and ADGuard Home. Ususally the CPU is not on load 1-2 % when I don't run a speedtest.
It may very well be because of Wireguard:
https://www.snbforums.com/threads/session-manager-discussion-2nd-thread.75129/post-750673
https://www.snbforums.com/threads/session-manager-discussion-2nd-thread.75129/page-21#post-731542

The Wireguard Add-On now disables by default Flow Cache, which limits download speeds substantially when you are on 1+Gbps connections.

You can either re-enable manually Flow Cache or uninstall Wireguard.
 

netolo

New Around Here
It may very well be because of Wireguard:
https://www.snbforums.com/threads/session-manager-discussion-2nd-thread.75129/post-750673
https://www.snbforums.com/threads/session-manager-discussion-2nd-thread.75129/page-21#post-731542

The Wireguard Add-On now disables by default Flow Cache, which limits download speeds substantially when you are on 1+Gbps connections.

You can either re-enable manually Flow Cache or uninstall Wireguard.


The Problem came back and it was of because of the wireguard flow control. I've manually enabled it again, and Im surfing now on full speed again ;). A thousand thanks!
 

Similar threads

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top