AX88U + 386.8 IPv6 intermittent

torchddv

Regular Contributor
I have a 6in4 HE tunnelbroker for IPv6 connectivity. The tunnel endpoint update script is working properly and the tunnel is established and IPv6 local addresses are handed out on booting the router. I am then fully connected via IPv6, as evidenced by a FF add-on that displays the IP of each webpage in the address bar.

At some random point in time, but usually within 30 to 60 minutes, I lose IPv6 connectivity at my computer. Opening a command window and attempting to ping ipv6.google.com will result in 4 failures. Attempting to ping google.com will sometimes result in failures to reach google's IPv6 address and sometimes succeed in reaching their IPv4 address, so I think DNS is still working, at least part of the time. Sometimes IPv6 connectivity spontaneously restores, perhaps even several times over the course of an afternoon but eventually fails completely.

But, at the same time as pings from the computer are failing, pings from the router (using the network tools tab in the GUI) may succeed, as do tests from other computers on the local network. Eventually failures get to the point where nothing gets through. The public IPv4 address remains unchanged, and matches the tunnel endpoint address reported on the Tunnelbroker webpage.

I have tried lowering the MTU from 1480 to 1472 to 1460 as suggested in other posts. But I suspect the problem is internal rather than the tunnel itself, given simultaneous failures and successes from different machines.

I'm at a loss what to try next. Is there something in the logs I should look for that might be a clue? Or a script that can insert something into the logs to mark when a computer is no longer reachable by IPv6?

I have had two other issues, but I don't think they are related. I'll mention them here just in case though:
1. The Asus DDNS service won't connect. I think the problem is that the name was used by my previous router. I followed Asus website and called them to have the name disassociated from the previous router so I could re-use the name. Meanwhile, I came across a post by Merlin that noted the easy way was to change the name in the old router to something else, which would free up the name for use with the new. I did that and it worked for a few days then quit. I suspect Asus finally got around to doing something at their end which screwed everything up at mine.

2. The other day, when I wrote a little script to track Wan-connected events and save them to a log on an SD card in a USB adapter, the router suddenly started lagging severely. Looking at the gui interface, I noticed core4 pegged at 100%. Then it dropped to 0 and core3 jumped to 100%. Then back again, repeatedly. Core2 started getting in on the action for a bit then all 3 were running at 100%. The system log was full of errors that seemed related to writing to the SD card. I powered down the router, had a look at the card in my computer and my little log file had some strange paragraphs inserted. I rebooted the router with an actual USB stick and all has been working fine since. So I think that issue was related to either the card or the adapter.
 

torchddv

Regular Contributor
Well I thought I was on to something. I changed the TTL from the default 255 to 64 after reading a suggestion that 64 was an appropriate value.

It seemed to work for a while, and in fact, the router has been pinging via IPv6 successfully for about 12 hours now. But my computer lost IPv6 connectivity after about 10 hours. I D/C'd and reconnected the wifi at the computer, which restored connectivity without rebooting the router, at least for now.

Does that suggest any possibilities to anyone?
 

Tech9

Part of the Furniture
@Frank Monroe may have some suggestions for you. He's using IPv6 and had some issues with Asuswrt-Merlin firmware after 386.3_2 release.

 

Frank Monroe

Regular Contributor
@Frank Monroe may have some suggestions for you. He's using IPv6 and had some issues with Asuswrt-Merlin firmware after 386.3_2 release.
This does indeed sound at least similar to my problem. Just to be clear, the problem isn't just with IPv6. It's more specifically with ICMP traffic. Since IPv6 relies on ICMP for router announcements, it's a big issue for IPv6. It may also be a problem for other types of traffic. To summarize, after upgrading to Merlin 386.4_0 last January, my devices started losing IPv6 connectivity. After doing some basic troubleshooting with pings and Wireshark captures I discovered ICMP traffic was not being passed between Ethernet connected devices, including the router itself, and wireless devices. Because of this, IPv6 devices would eventually lose their IPv6 configuration as their RA's timed out. In some cases, I could disconnect a device from wifi and then reconnect and the problem would temporarily go away. But, most of the time this did not work. To fully restore network connectivity, I would have to reboot my RT-AC5300. The problem had gotten worse and worse over time to where it was happening every day to two times a day. I tested every single release since 386.4. Unfortunately, every release since 386.4 has the issue. Reverting back to 386.3_2 completely resolves the issue. I am anxiously waiting to test 388 when its available for my model.
 

Frank Monroe

Regular Contributor
Unfortunately, Asuswrt-Merlin 386.7_2 is perhaps the last compatible version for your AC5300. AC-class routers won't get 388 firmware update.
Thanks a lot for the information. I had no idea. Well, I guess I will start looking for an upgrade or just be happy with what I have.
 

Tech9

Part of the Furniture
Understood. It remains unknown if the issue is in the base or in the changes on top though.
 

torchddv

Regular Contributor
6 hours later and <drum roll please>: it didn't work. No IPv6 connectivity from either computer or Network Tools tab. I'll try dropping the MTU a couple of times and see if that has any effect in this version.

I see there is a 388.1 in beta available for this router. I could try that next.
 

torchddv

Regular Contributor
A half hour later at MTU = 1472 and the computer has already lost connectivity, although the Network Tools is still working.
 

Ripshod

Regular Contributor
You could try going even lower on the MTU. My connection is PPPoE and it's totally unstable at anything above 1452.
 

Tech9

Part of the Furniture
Firewall rules bug was discovered in 388 firmware. More about the issue here:


If you enable IPv4 inbound firewall rules your devices with IPv6 address are exposed to Internet.
 

torchddv

Regular Contributor
I tried as low as 1440. In fact, I'm trying that right now with the 388 beta -- it seems to suffer from the same issue as the earlier FW versions tried.
 

Ripshod

Regular Contributor
Yet mine is stable 6in4 via HE (tunnelbroker) on AX88U with the 388.1beta3 firmware. There must be something interfering but what is anybody's guess.

Afterthought:
Have you added /jffs/scripts/wan-event scipt?
Probably a silly question.
 

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top