AX88U Roaming Assistant not works since 386.8

Damit1

Senior Member
Hi y'all!

Since 386.8- I have no ability for a sensible Roaming inside my network.
I have 3 story house with a hybrid mesh system.

Main router is AX88U and it is wirelessly connected to another one, and that is connected through cable to AX56U.
there are 2-3 devices that drive me nuts, they will not connect to nearest AIMesh node byself, I have to force them to connect there.
I need to bind them to nearest node in order for it to work.

TBH, its not affecting my ability to use them, just upsets me that it overrides (and in ASUS app you can clearly see it overrides) the ROAM ASSISTANT RULES.
It affects only IoT devices, and Chromecast devices (so far I can tell).
Attaching some photos from the app to show my meaning and 2.4Ghz (and 5GHz to be safe) of my network.

It occurs that way only from 386.8, when WiFi drivers are upgraded. On 386.7_2 had no problem like that.
I can tell definitely that since 386.8 the network is way more stable, but that much you cannot roam any device from inside the network.
When I try to Optimize any device that not going along my Roaming assistant rules (like used to be), it just re-connect to the router without any "checking", like there is no better node to connect to nearby.

What am I missing here?
Any words of wisdom? Any good advise?
Thank you!


1664022061835.png
1664022080836.png


1664019472382.png
 

Attachments

  • Screenshot_20220924_153453.jpg
    Screenshot_20220924_153453.jpg
    45.4 KB · Views: 32
  • Screenshot_20220924_153546.jpg
    Screenshot_20220924_153546.jpg
    45.4 KB · Views: 31
Last edited:

Tech9

Part of the Furniture
This is wireless drivers related and there is nothing for RMerlin to fix. You have to wait for the next firmware upgrade and test again. If the issue is very urgent, revert to previous firmware and see if it works.
 

Damit1

Senior Member
This is wireless drivers related and there is nothing for RMerlin to fix. You have to wait for the next firmware upgrade and test again. If the issue is very urgent, revert to previous firmware and see if it works.
That is what I thought, just wanted to ease my mind about this matter.
 

joegreat

Very Senior Member
In my case roaming work like a charm between the AX88U (running 386.8 firmware) and the Access Point AC87U (running stock firmware).

As stated by @Tech9: Looks like your issue is not related to the actual firmware...
 

OzarkEdge

Part of the Furniture
Hi y'all!

Since 386.8- I have no ability for a sensible Roaming inside my network.
I have 3 story house with a hybrid mesh system.

Main router is AX88U and it is wirelessly connected to another one, and that is connected through cable to AX56U.
there are 2-3 devices that drive me nuts, they will not connect to nearest AIMesh node byself, I have to force them to connect there.
I need to bind them to nearest node in order for it to work.

TBH, its not affecting my ability to use them, just upsets me that it overrides (and in ASUS app you can clearly see it overrides) the ROAM ASSISTANT RULES.
It affects only IoT devices, and Chromecast devices (so far I can tell).
Attaching some photos from the app to show my meaning and 2.4Ghz (and 5GHz to be safe) of my network.

It occurs that way only from 386.8, when WiFi drivers are upgraded. On 386.7_2 had no problem like that.
I can tell definitely that since 386.8 the network is way more stable, but that much you cannot roam any device from inside the network.
When I try to Optimize any device that not going along my Roaming assistant rules (like used to be), it just re-connect to the router without any "checking", like there is no better node to connect to nearby.

What am I missing here?
Any words of wisdom? Any good advise?
Thank you!


View attachment 44386View attachment 44387

View attachment 44382

In my experience, using Roaming Assistant with 2.4 clients that actually roam meant more reconnects than were necessary. I disable RA and let 2.4 clients do what they do... less unnecessary reconnects for mobile clients/streaming.

And dumb stationary clients beyond the far node will reconnect to the far router whenever the WiFi is restarted, and are perfectly content to stay there, and still work because 2.4 works at distance... rebooting them reconnects them to the near node.

For me, the best approach has been to not use RA, locate nodes as far apart as possible (5.0 wireless backhaul RSSI ~-65dBm... mine is pushed to -70-dBm at 77ft) and let 2.4 clients do what they want as long as they work.

OE
 

Tech9

Part of the Furniture
The firmware is getting more complex and with custom scripts on top the results may be unpredictable. I only test clean Asuswrt-Merlin because most issues are not even closely related to RMerlin's work and often land as non-firmware related issues in release threads. If you @Damit1 have custom scripts running, my recommendation is reset to defaults and test clean. You may get surprised.
 

Damit1

Senior Member
In my case roaming work like a charm between the AX88U (running 386.8 firmware) and the Access Point AC87U (running stock firmware).

As stated by @Tech9: Looks like your issue is not related to the actual firmware...
It is related to the FW (which includes new drivers).
For now, it works, just annoying.
 

Damit1

Senior Member
The firmware is getting more complex and with custom scripts on top the results may be unpredictable. I only test clean Asuswrt-Merlin because most issues are not even closely related to RMerlin's work and often land as non-firmware related issues in release threads. If you @Damit1 have custom scripts running, my recommendation is reset to defaults and test clean. You may get surprised.
No Scripts what so ever.
Just clean ASUSWRT MERLIN
 

Damit1

Senior Member
In my experience, using Roaming Assistant with 2.4 clients that actually roam meant more reconnects than were necessary. I disable RA and let 2.4 clients do what they do... less unnecessary reconnects for mobile clients/streaming.

And dumb stationary clients beyond the far node will reconnect to the far router whenever the WiFi is restarted, and are perfectly content to stay there, and still work because 2.4 works at distance... rebooting them reconnects them to the near node.

For me, the best approach has been to not use RA, locate nodes as far apart as possible (5.0 wireless backhaul RSSI ~-65dBm... mine is pushed to -70-dBm at 77ft) and let 2.4 clients do what they want as long as they work.

OE
Well, that is incredible about how right you are.
Did a whole reboot to IoT devices (6 IoT totally were not automatically roaming) and it re-connect them to the right one.

It means the automatic process of optimization is not working, not sure whether it is wireless driver related or FW related- whether it is manual optimization process or automatic optimization process the system would do every once in a while.

NVM, it works, just manually and not automatically.
Thank you!
 

Tech9

Part of the Furniture
it works, just manually and not automatically.

Was it working on 386.7_2 firmware?

AiMesh has "Improved the AiMesh stability" in latest stock firmware too.
 
Last edited:

OzarkEdge

Part of the Furniture
Well, that is incredible about how right you are.
Did a whole reboot to IoT devices (6 IoT totally were not automatically roaming) and it re-connect them to the right one.

It means the automatic process of optimization is not working, not sure whether it is wireless driver related or FW related- whether it is manual optimization process or automatic optimization process the system would do every once in a while.

NVM, it works, just manually and not automatically.
Thank you!

A network reboot will not correct cheap IoT adapter logic (the client decides roaming)... they will cling to what they last knew until you restart them... which means they will connect to the first signal up, the router, and never look back to the closer node signal once it comes up. I ignore them while working on the network, and restart them at some later point, if I care to.

With luck, you can restart them from within their app and not have to run around pulling power plugs. You can generally tell where they are connected by their RSSI in the Wireless Log... and their idx when using guest1 WLANs... it indicates differently depending on router or node guest1 connection.

Perhaps you can bind them to a node, but I refuse to throw in the towel and stoop that low (be bothered to); not sure it would always work anyway; and don't want to troubleshoot another not-important-to-me AiMesh function.

OE
 
Last edited:

Tech9

Part of the Furniture

Damit1

Senior Member
A network reboot will not correct cheap IoT adapter logic (the client decides roaming)... they will cling to what they last knew until you restart them... which means they will connect to the first signal up, the router, and never look back to the closer node signal once it comes up. I ignore them while working on the network, and restart them at some later point, if I care to.

With luck, you can restart them from within their app and not have to run around pulling power plugs. You can generally tell where they are connected by their RSSI in the Wireless Log... and their idx when using guest1 WLANs... it indicates differently depending on router or node guest1 connection.

Perhaps you can bind them to a node, but I refuse to throw in the towel and stoop that low (be bothered to); not sure it would always work anyway; and don't one to troubleshoot another not-important-to-me AiMesh function.

OE


Actually, not sure how true it is.
Until 386.7_2 (say about 1.5y-2y) I just clicked Optimization on each client in the app and the router/nodes would optimize the connection- then it would just re-connect to nearest node.
That made sense, now I should run around the house to do so.
Hopefully next version would have better drivers/ optimization working.

Thank you for your insightful advises anyway :)
 

Damit1

Senior Member
Wait for the next firmware release or downgrade to 386.7_2 firmware.
Yup, I guess it is true.
It works now after a run-around-the-house for physical reboot.
As long as it works Im good, reverting FW here takes me way longer
 

OzarkEdge

Part of the Furniture
Actually, not sure how true it is.
Until 386.7_2 (say about 1.5y-2y) I just clicked Optimization on each client in the app and the router/nodes would optimize the connection- then it would just re-connect to nearest node.
That made sense, now I should run around the house to do so.
Hopefully next version would have better drivers/ optimization working.

Thank you for your insightful advises anyway :)

Also beware IoT firmware updates... they can be a constant source of aggravation, depending on the OEM.

OE
 

Tech9

Part of the Furniture
It works now after a run-around-the-house for physical reboot.

Until you reboot AiMesh, perhaps. Your issue may be reboot speed related. One of your routers boots up faster and devices connect there first. Another reason to use identical routers with AiMesh.
 

Damit1

Senior Member
Until you reboot AiMesh, perhaps. Your issue may be reboot speed related. One of your routers boots up faster and devices connect there first. Another reason to use identical routers with AiMesh.


2*AX88U are the issue.
same routers as AP.
I can only finger point it towards the WiFi drivers in the last release, though Merlin asked to check settings, and that is what I did. nothing else
 

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top