Best settings for my home network AX58U, AX56U and AC58U.

SirChri

New Around Here
Hi everyone!
I just made an upgrade to my home network, set up for the first time an AiMesh network using AX58U and AX56U, after that, some problems have come.
Before saying anything else, let me attach this simple schema of my home network.
home_network.png

Note: A, B, and C are apartments not rooms.
The AX56U between the AX58U and the AC56U is the "upgrade", before the upgrade there was only the AC56U as AP in the B apartment and nothing in the C apartment.
Let's say that before the upgrade everything was working fine.
I made a factory reset on AX58U and AC56U (AX56U was brand new) and I set up from 0 the whole network.
Here are some of the problems I am having after resetting the whole network:
1 - Some devices in A apartment randomly disconnect from Wi-FI
2 - Switching from A apartment to B apartment with my smartphone sometimes force me to turn off/on wifi because gives me no internet connection message (WTF, never happened before), with the full wifi signal.
3 - My smartphone automatically switches from 5Ghz to 2.4Ghz (the same SSID with Smart Connect on) from 5/6 meters away from AX56U where the 5Ghz signal is still strong.
And other minor problems but there is something wrong with the network setup. I left almost all settings to defaults.

I spent some time reading some tips and answers on these links:

I read about disabling smart connect and setting up separate SSID and others things, but there were too many messages so I decided to open my thread.
I realized that there are a lot of skilled people here so, I am looking for any advice you can give me and go for all best practices as I can like:
1 - Should I install Asuswrt-Merlin on AX58/56U ? I didn't get the advantages.
2 - There is a "Best settings" list like the one posted by L&LD in this post post-642251
3 - and so on ...

Before leaving you to my network info and actual settings, many thanks to anyone who will answer :)

Actual Bandwith 100-120MB down / 20-25MB Up
ALL routers have both 2.4 and 5 GHz wifi on, ALL with the same SSID and PW
ALL Routers run last official release of AsusWRT
1 - ISP Modem: All settings disabled, only one IP for AX58U WAN
2 - AX58U: Factory reset, Enabled: AIProtection, Adaptive QoS, Dual-band Smart Connects, 802.11ax / WiFi 6 mode, WiFi Agile Multiband. That's all
3 - AX56U: set as Aimesh Node with Ethernet Backhaul. That's all
4 - AC56U: Factory reset, set as Access Point with IP, Subnet Mask, and Default gateway. That's all
 
Last edited:

OzarkEdge

Part of the Furniture
Hi everyone!
I just made an upgrade to my home network, set up for the first time an AiMesh network using AX58U and AX56U, after that, some problems have come.
Before saying anything else, let me attach this simple schema of my home network.
View attachment 37369
Note: A, B, and C are apartments not rooms.
The AX56U between the AX58U and the AC56U is the "upgrade", before the upgrade there was only the AC56U as AP in the B apartment and nothing in the C apartment.
Let's say that before the upgrade everything was working fine.
I made a factory reset on AX58U and AC56U (AX56U was brand new) and I set up from 0 the whole network.
Here are some of the problems I am having after resetting the whole network:
1 - Some devices in A apartment randomly disconnect from Wi-FI
2 - Switching from A apartment to B apartment with my smartphone sometimes force me to turn off/on wifi because gives me no internet connection message (WTF, never happened before), with the full wifi signal.
3 - My smartphone automatically switches from 5Ghz to 2.4Ghz (the same SSID with Smart Connect on) from 5/6 meters away from AX56U where the 5Ghz signal is still strong.
And other minor problems but there is something wrong with the network setup. I left almost all settings to defaults.

I spent some time reading some tips and answers on these links:


I read about disabling smart connect and setting up separate SSID and others things, but there were too many messages so I decided to open my thread.
I realized that there are a lot of skilled people here so, I am looking for any advice you can give me and go for all best practices as I can like:
1 - Should I install Asuswrt-Merlin on AX58/56U ? I didn't get the advantages.
2 - There is a "Best settings" list like the one posted by L&LD in this post post-642251
3 - and so on ...

Before leaving you to my network info and actual settings, many thanks to anyone who will answer :)

Actual Bandwith 100-120MB down / 20-25MB Up
ALL routers have both 2.4 and 5 GHz wifi on, ALL with the same SSID and PW
ALL Routers run last official release of AsusWRT
1 - ISP Modem: All settings disabled, only one IP for AX58U WAN
2 - AX58U: Factory reset, Enabled: AIProtection, Adaptive QoS, Dual-band Smart Connects, 802.11ax / WiFi 6 mode, WiFi Agile Multiband. That's all
3 - AX56U: set as Aimesh Node with Ethernet Backhaul. That's all
4 - AC56U: Factory reset, set as Access Point with IP, Subnet Mask, and Default gateway. That's all

Some thoughts:

When commissioning a new network, I would build it up in stages... don't add more until you are happy with less.

I would stick with Asuswrt until you have a working network since Asuswrt-Merlin adds more features to consider.

I would stick with a basic configuration until you have it working; then add functions like QoS gradually.

When you flash the latest firmware, you should then reset it to its factory defaults before configuring it from scratch...

I would reset the new AX56U before adding it to the AiMesh. You do not configure the node, just reset it and then add it from the AX58U webUI... it will get a dynamic IP address from the router DHCP server. How did you assign 192.168.1.2 to the node?

I would disable Smart Connect and Roaming Assistant and use different SSIDs, ssid-24, ssid-50. Later, you can try Smart Connect with same SSIDs. Depending on your layout and how sticky your wireless clients are, you may not need RA, but can also try it later. But keeping them disable for now will reduce the number of variables in play... until you get the basics sorted out.

OE
 
Last edited:

SirChri

New Around Here
Some thoughts:

When commissioning a new network, I would build it up in stages... don't add more until you are happy with less.

I would stick with Asuswrt until you have a working network since Asuswrt-Merlin adds more features to consider.

I would stick with a basic configuration until you have it working; then add functions like QoS gradually.

When you flash the latest firmware, you should then reset it to its factory defaults before configuring it from scratch...

I would reset the new AX56U before adding it to the AiMesh. You do not configure the node, just reset it and then add it from the AX58U webUI... it will get a dynamic IP address from the router DHCP server. How did you assign 192.168.1.2 to the node?

I would disable Smart Connect and Roaming Assistant and use different SSIDs, ssid-24, ssid-50. Later, you can try Smart Connect with same SSIDs. Depending on your layout and how sticky your wireless clients are, you may not need RA, but can also try it later. But keeping them disable for now will reduce the number of variables in play... until you get the basics sorted out.

OE
Hi Ozark and thank you for the answer. Today appeared a firmware update for both AX58U and AX56U.
I will later update both of them and factory reset the AX58U, and I'll do what you suggested to me: Not enabling QoS, Disable Smart Connect, and Roaming Assistant.
After that I'll factory reset my AX56U and add it to AiMesh through AX58U WebUI, btw I didn't manually configure the AX56U, I only followed the startup wizard, later, I gave the AX56U a static IP with a rule on AX58U DHCP Server
photo_2021-11-16_09-52-01.jpg

An Aimesh Node mac doesn't appear on the drop-down list but if you manually write the node MAC, the router automatically recognizes the Node. (as you can see from the image)
 

OzarkEdge

Part of the Furniture
I didn't manually configure the AX56U, I only followed the startup wizard, later, I gave the AX56U a static IP with a rule on AX58U DHCP Server

Understood.

You can skip the configuration Wizard... don't login after you reset the new firmware... just add the node to the AiMesh remotely.

OE
 

whitestar999

Occasional Visitor
An Aimesh Node mac doesn't appear on the drop-down list but if you manually write the node MAC, the router automatically recognizes the Node. (as you can see from the image)
I hope that's not real mac of any of your device in the screenshot.
 

SirChri

New Around Here
Understood.

You can skip the configuration Wizard... don't login after you reset the new firmware... just add the node to the AiMesh remotely.

OE
After some hours struggling with settings, testing, and rebooting/resetting, (I got the importance of reboot and waiting to correctly apply some modifications) everything seems to work smoothly and SUPER fine.
I followed your suggestions, merged with those 3 post suggestions:
A fast recap of my AX58U settings:
  • No Smart Connect, QoS, Traffic Analyzer, USB Apps, AiCloud, Parental Control. Only AiProtection and Firewall ON
  • WPS OFF
  • LAN IP Pool from 15 to 254, I use a tenth of devices with static IP
  • UPnP Off
  • WAN DNS Cloudflare (The fastest IMHO)
  • 2.4 wifi
    • mode: Auto
    • 802.11ax / WiFi 6: ON
    • Channel bandwidth: 20/40 Mhz
    • Control Channel: 11
    • Preamble: short
    • Roaming Assistant and Universal Beamforming Disabled
  • 5.0 wifi
    • mode: Auto
    • 802.11ax / WiFi 6: ON
    • Channel bandwidth: 20/40/80 Mhz
    • Control Channel: 140
    • Roaming Assistant and Universal Beamforming Disabled
  • Ethernet Backhaul for AiMesh
I ended up with a nice network setup so I exported/saved router settings as a backup, between all info on those posts I decided what to do on conflicts, but those conflicts left me with some questions:
  • The highest channel I cant set on 5 GHz is 140, why? Both you and @L&LD suggest 149-161, I used 140 btw. (scanned with wifi analyzer app)
  • All my Echo Dot devices (Alexa) have better 5 GHz wifi signal reception instead of 2.4, how that's possible?
  • My 2.4 wifi has Multi-User MIMO and OFDMA/802.11ax MU-MIMO disabled, should I enable it? (those are enabled on 5Ghz wifi)
Anyway... BIG THANKS to you and @L&LD
 
Last edited:

OzarkEdge

Part of the Furniture
After some hours struggling with settings, testing, and rebooting/resetting, (I got the importance of reboot and waiting to correctly apply some modifications) everything seems to work smoothly and SUPER fine.
I followed your suggestions, merged with those 3 post suggestions:
A fast recap of my AX58U settings:
  • No Smart Connect, QoS, Traffic Analyzer, USB Apps, AiCloud, Parental Control. Only AiProtection and Firewall ON
  • WPS OFF
  • LAN IP Pool from 15 to 254, I use a tenth of devices with static IP
  • UPnP Off
  • WAN DNS Cloudflare (The fastest IMHO)
  • 2.4 wifi
    • mode: Auto
    • 802.11ax / WiFi 6: ON
    • Channel bandwidth: 20/40 Mhz
    • Control Channel: 11
    • Preamble: short
    • Roaming Assistant and Universal Beamforming Disabled
  • 5.0 wifi
    • mode: Auto
    • 802.11ax / WiFi 6: ON
    • Channel bandwidth: 20/40/80 Mhz
    • Control Channel: 140
    • Preamble: short
    • Roaming Assistant and Universal Beamforming Disabled
  • Ethernet Backhaul for AiMesh
I ended up with a nice network setup so I exported/saved router settings as a backup, between all info on those posts I decided what to do on conflicts, but those conflicts left me with some questions:
  • The highest channel I cant set on 5 GHz is 140, why? Both you and @L&LD suggest 149-161, I used 140 btw. (scanned with wifi analyzer app)
  • All my Echo Dot devices (Alexa) have better 5 GHz wifi signal reception instead of 2.4, how that's possible?
  • My 2.4 wifi has Multi-User MIMO and OFDMA/802.11ax MU-MIMO disabled, should I enable it? (those are enabled on 5Ghz wifi)
Anyway... BIG THANKS to you and @L&LD

Sounds like a steady commissioning of your new network... time and space to experiment and learn.

Some thoughts:

To be clear just in case... reboot means to restart (and/or power cycle) the device; reset means to reset the firmware to its factory default settings. When you use the terms together, in succession, or interchangeably (they are not related); it is not clear what you mean or did.

Regarding saving a firmware configuration... a saved configuration is most useful for restoring that specific firmware to those saved settings... and perhaps for cloning a second router of the same model and firmware, although some say not to use a saved configuration on another router of the same model... me, I'd try it to save time, if I needed to clone an install. But in practice, you will likely only want to restore a saved configuration after experimenting and deciding to revert back to where you started. Most of the time... and with AiMesh being a work-in-progress, and Asus releasing frequent firmware updates... you will flash new firmware for a 'dirty upgrade'; OR, you will flash new firmware, reset it to its defaults, and then configure it from scratch for a 'clean upgrade'... neither scenario will use a saved configuration of the previous firmware. Even disaster recovery will likely find you replacing a failed router with a new/different/better router, so you won't use a saved configuration backup.

Regarding WiFi... you should research the permitted channels in your country (as listed in a router purchased in your country). Some channels may have different allowed power levels... you might want to prefer using those for better coverage. Some 5.0 channels may be shared with airport and weather radar and ?... the router must use Dynamic Frequency Selection (DFS) to scan those channel for those higher priority users... if detected, the router will bump your WiFi to a different available channel. This DFS on the 5.0 band is disruptive to client connections and to trying to use 160 MHz bandwidth.

So my approach until WiFi6e gives use many usable channels on the 6.0 band, is to use fixed (not Auto), least-congested (less interference), non-DFS channels (not auto) to avoid channel changes/interference that can disrupt client connections. In the US, this means 5.0 80 MHz bandwidth max (160 MHz requires using DFS channels, so not good). And since 2.4 signals travel far, use 20 MHz bandwidth to share the 2.4 band with your immediate neighbors.

As for specific wireless client behavior... first be sure you have your channel and bandwidth selections set/optimized for your conditions and the considerations mentioned above (I don't mess with most of the default settings... just the basic settings noted in my notes). Then review your client behavior... the client decides where to connect. Perhaps the Alex clients prefer a 1-stream/antenna 433Mbps 5.0 AC connection over a 1-stream/antenna 150Mbps 2.4 N connection... inspect the client's connection details to better know their decision.

And beware that Amazon sidewalk nonsense that share's your WiFi with strangers walking by.

OE
 
Last edited:

bbunge

Part of the Furniture
After some hours struggling with settings, testing, and rebooting/resetting, (I got the importance of reboot and waiting to correctly apply some modifications) everything seems to work smoothly and SUPER fine.
I followed your suggestions, merged with those 3 post suggestions:
A fast recap of my AX58U settings:
  • No Smart Connect, QoS, Traffic Analyzer, USB Apps, AiCloud, Parental Control. Only AiProtection and Firewall ON
  • WPS OFF
  • LAN IP Pool from 15 to 254, I use a tenth of devices with static IP
  • UPnP Off
  • WAN DNS Cloudflare (The fastest IMHO)
  • 2.4 wifi
    • mode: Auto
    • 802.11ax / WiFi 6: ON
    • Channel bandwidth: 20/40 Mhz
    • Control Channel: 11
    • Preamble: short
    • Roaming Assistant and Universal Beamforming Disabled
  • 5.0 wifi
    • mode: Auto
    • 802.11ax / WiFi 6: ON
    • Channel bandwidth: 20/40/80 Mhz
    • Control Channel: 140
    • Roaming Assistant and Universal Beamforming Disabled
  • Ethernet Backhaul for AiMesh
I ended up with a nice network setup so I exported/saved router settings as a backup, between all info on those posts I decided what to do on conflicts, but those conflicts left me with some questions:
  • The highest channel I cant set on 5 GHz is 140, why? Both you and @L&LD suggest 149-161, I used 140 btw. (scanned with wifi analyzer app)
  • All my Echo Dot devices (Alexa) have better 5 GHz wifi signal reception instead of 2.4, how that's possible?
  • My 2.4 wifi has Multi-User MIMO and OFDMA/802.11ax MU-MIMO disabled, should I enable it? (those are enabled on 5Ghz wifi)
Anyway... BIG THANKS to you and @L&LD
More opinionated suggestions:

Do use Dual Band SmartConnect especially if you use DFS channels on 5 GHz. When air search RADAR bounces your 5 GHz off, your clients will switch to the 2.4 GHz band and keep working.
Don't change settings in the WIFI Professional area! Trust Asus!
Initally use Auto channel selection on both WIFI bands. After it runs for several days note which channels the router uses and then set them to fixed.
Other WIFI settings: 2.4 GHz at 20 MHz, 5 GHz at 80 MHz and leave other settings at default. Use WPA3 if you want to but WPA2/WPA3-Personal is better.
Use a filtering DNS provider in WAN DNS. 1.1.1.2 and 1.0.0.2, Quad9 or Clean Browsing
Use DNS Privacy Protocol. Cloudflare is in the list but Cloudflare Secure is a manual add: 1.1.1.2 and 1.0.0.2 with TLS Hostname of security.cloudflare-dns.com
 

SirChri

New Around Here
More opinionated suggestions:

Do use Dual Band SmartConnect especially if you use DFS channels on 5 GHz. When air search RADAR bounces your 5 GHz off, your clients will switch to the 2.4 GHz band and keep working.
Don't change settings in the WIFI Professional area! Trust Asus!
Initally use Auto channel selection on both WIFI bands. After it runs for several days note which channels the router uses and then set them to fixed.
Other WIFI settings: 2.4 GHz at 20 MHz, 5 GHz at 80 MHz and leave other settings at default. Use WPA3 if you want to but WPA2/WPA3-Personal is better.
Use a filtering DNS provider in WAN DNS. 1.1.1.2 and 1.0.0.2, Quad9 or Clean Browsing
Use DNS Privacy Protocol. Cloudflare is in the list but Cloudflare Secure is a manual add: 1.1.1.2 and 1.0.0.2 with TLS Hostname of security.cloudflare-dns.com
Sounds like a steady commissioning of your new network... time and space to experiment and learn.

Some thoughts:

To be clear just in case... reboot means to restart (and/or power cycle) the device; reset means to reset the firmware to its factory default settings. When you use the terms together, in succession, or interchangeably (they are not related); it is not clear what you mean or did.

Regarding saving a firmware configuration... a saved configuration is most useful for restoring that specific firmware to those saved settings... and perhaps for cloning a second router of the same model and firmware, although some say not to use a saved configuration on another router of the same model... me, I'd try it to save time, if I needed to clone an install. But in practice, you will likely only want to restore a saved configuration after experimenting and deciding to revert back to where you started. Most of the time... and with AiMesh being a work-in-progress, and Asus releasing frequent firmware updates... you will flash new firmware for a 'dirty upgrade'; OR, you will flash new firmware, reset it to its defaults, and then configure it from scratch for a 'clean upgrade'... neither scenario will use a saved configuration of the previous firmware. Even disaster recovery will likely find you replacing a failed router with a new/different/better router, so you won't use a saved configuration backup.

Regarding WiFi... you should research the permitted channels in your country (as listed in a router purchased in your country). Some channels may have different allowed power levels... you might want to prefer using those for better coverage. Some 5.0 channels may be shared with airport and weather radar and ?... the router must use Dynamic Frequency Selection (DFS) to scan those channel for those higher priority users... if detected, the router will bump your WiFi to a different available channel. This DFS on the 5.0 band is disruptive to client connections and to trying to use 160 MHz bandwidth.

So my approach until WiFi6e gives use many usable channels on the 6.0 band, is to use fixed (not Auto), least-congested (less interference), non-DFS channels (not auto) to avoid channel changes/interference that can disrupt client connections. In the US, this means 5.0 80 MHz bandwidth max (160 MHz requires using DFS channels, so not good). And since 2.4 signals travel far, use 20 MHz bandwidth to share the 2.4 band with your immediate neighbors.

As for specific wireless client behavior... first be sure you have your channel and bandwidth selections set/optimized for your conditions and the considerations mentioned above (I don't mess with most of the default settings... just the basic settings noted in my notes). Then review your client behavior... the client decides where to connect. Perhaps the Alex clients prefer a 1-stream/antenna 433Mbps 5.0 AC connection over a 1-stream/antenna 150Mbps 2.4 N connection... inspect the client's connection details to better know their decision.

And beware that Amazon sidewalk nonsense that share's your WiFi with strangers walking by.

OE

Thank you both for your suggestions.
I set 20 Mhz on 2.4 Wifi and 80 Mhz on 5.0 Wifi.
I switched the control channel of 5GHz wifi to 48, using 80 Mhz my Router only permits me to set Control Channel between 36-112, and in Europe, within this range, I have to set between 36 and 48.
I prefer to stick with Dual Band SmartConnect off, at least for now. My actual configuration seems to be pretty strong and stable.
I'm deciding right now if enabling or not DNS Privacy Protocol, anyway I'll activate it on 1.1.1.1, not 1.1.1.1 for family (1.1.1.2).
 

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top