[Beta 384/NG] Asuswrt-Merlin 384.3 Beta is now available

  • ATTENTION! As of November 1, 2020, you are not able to reply to threads 6 months after the thread is opened if there are more than 500 posts in the thread.
    Threads will not be locked, so posts may still be edited by their authors.
    Just start a new thread on the topic to post if you get an error message when trying to reply to a thread.
Status
Not open for further replies.

RMerlin

Asuswrt-Merlin dev
Feb 11th: Beta 3 is now available

Changes:
Code:
f12411e webui: don't insert FAQ urls into disabled links on OpenVPN server page
970f4e3 cfgsync: move cert generation to a dedicated script, and generate it at service launch
185fb29 cfgsync: hex-edit key.pem to use key.cfg instead
db3c6f9 Bumped revision to beta 3

Feb 8th: Beta 2 is now available

Changes:
Code:
c3bf092 Updated documentation
c550d5c rc: merge lan.c from 384_20287, including fixes for Repeater mode
0aea283 shared: disable roaming assistant by default on AMAS models since we don't currently support AMAS
582a23a rc: firewall: fix NSFW rules while in blacklist mode
69ddc52 webui: fix scrollbar positioning on Site Survey for native 384 models under Firefox
c1a9430 webui: fix FAQ links on OpenVPN server page
8816d93 webui: fix FAQ linking for people not using the DUT hostname to access the webui
e394ce3 httpd: gencert.sh: also generate the cfgsync certificate
a197dc1 Bumped revision to 384.3 beta 2


Asuswrt-Merlin 384.3 Beta is now available for download.

This release merges Asus GPL 384_10007, and also introduces support for the RT-AC3200.

The highlights:

  • Merge with GPL 384_10007 (note: AiMesh is NOT supported)
  • Added RT-AC3200 support. Note that with both this firmware and Asus's official 382_xxxxx for this model, you will no longer be able to downgrade to a 380.xx release due to the CFE/nvram upgrade done by the 382/384 releases for this model. Also due to the nvram upgrade, the RT-AC3200 once again allows up to 5 OpenVPN clients.
  • Stabilized RT-AC56U support (which was added in 382.2 beta).
  • Updated Nano to 2.9.3. Also, you can no configure nano by editing /jffs/configs/nanorc .
  • PPPoE NAT acceleration should now work for most models (fixes backported from 382_50010)
  • Fixed security issue CVE-2018-5721 in httpd
  • Various other fixes to networkmap, IPv6 and DHCP (see changelog for details)

Please keep discussions to this specific release.

Downloads are here.
Changelog is here.
 
Last edited:

RMerlin

Asuswrt-Merlin dev
Known issues:

  • Some pages will fail to restart services, like the new password wizard on first run, or the Guest Networking page (issue caused by Aimesh's config sync server, fixed in beta 2)
  • Broken FAQ links (fixed in beta 2)
  • Network Service Filtering doesn't work in blacklist mode (fixed in beta 2)
 
Last edited:

scjr

Very Senior Member
Thanks for all your hard work, Merlin.
 

Grigione

Regular Contributor
Thanks, have you fixed problems for updating ssid after guest networks enable/disable (ac86u)?
 

RMerlin

Asuswrt-Merlin dev
Thanks, have you fixed problems for updating ssid after guest networks enable/disable (ac86u)?

I'm unable to reproduce this problem here. Do a factory default reset and retest with this beta release. Also try a different browser, and make sure you don't use any special characters in the SSID.
 

skeal

Part of the Furniture
Nice build!! Really solid. No problems with my every day stuff. Thank again sir you are unreal!
 

skeal

Part of the Furniture

Protik

Senior Member
I'm guessing we won't see anything based on 3.0.0.4.384.20308 until 384.4?
Is there any new feature in your mentioned version that you think will be useful?

Sent from my Moto G (5) Plus using Tapatalk
 

stambeccuccio

Senior Member
..sorry, but the heading is it correct?
"[Beta 382] Asuswrt-Merlin 384.3 Beta is now available"
Is it beta 382 or 384?
 

Steffe

Regular Contributor
..sorry, but the heading is it correct?
"[Beta 382] Asuswrt-Merlin 384.3 Beta is now available"
Is it beta 382 or 384?
NOTE: To reduce confusion following the version
bump to 384, the current Github repository
was renamed from asuswrt-merlin.382 to
asuswrt-merlin.ng (for New Generation).
It's recommended that you update your
local repository if you're a developer,
for example by running:
 

Broken Hope

Regular Contributor
Is there any new feature in your mentioned version that you think will be useful?

Sent from my Moto G (5) Plus using Tapatalk

It fixes a bug I've been noticing with my iPhone X.

- Fixed 5GHz downlink throughput drop problem.

The bug was it was only connecting at a max link speed of 433 rather than the 866 it's capable of connecting at.
 

128bit

Regular Contributor
I'm unable to reproduce this problem here. Do a factory default reset and retest with this beta release. Also try a different browser, and make sure you don't use any special characters in the SSID.
does this mean that the guest ssid does not handle special characters? i'm able to do this on the stock fw but am ready to make the leap to these betas.
 

Protik

Senior Member
It fixes a bug I've been noticing with my iPhone X.

- Fixed 5GHz downlink throughput drop problem.

The bug was it was only connecting at a max link speed of 433 rather than the 866 it's capable of connecting at.

For a phone, that is not too bad.

Anyway, Merline mentioned it somewhere else. Asus is releasing too many versions of each model too soon. They are also increasing number of closed source binaries. Which makes it harder to move into any new codebase as it leaves some users stranded in a old codebase in case you move on. And also makes it harder to track down any new bug due to the closed source nature of some parts. So he requested users to be patient about incorporating any new versions.
 

Grigione

Regular Contributor
I'm unable to reproduce this problem here. Do a factory default reset and retest with this beta release. Also try a different browser, and make sure you don't use any special characters in the SSID.

My special character in SSID is only underscore "_" and it never gave any problems in 382.1_2 .You can reproduce problem in following mode: create (or enable previous created guest network ) a guest network SSID and verify if it is displayed automatically on wifi list of the smartphone,likewise when you remove a guest network verify if it is removed from smartphone sssid list.In my case only when I make a router reboot all ssid comes updating correctly.I think that there is a problem in some part of the firmare about wireless restart after a enable/remove guest network.Can you make a check?Thanks
 

128bit

Regular Contributor
My special character in SSID is only underscore "_" and it never gave any problems in 382.1_2 .You can reproduce problem in following mode: create (or enable previous created guest network ) a guest network SSID and verify if it is displayed automatically on wifi list of the smartphone,likewise when you remove a guest network verify if it is removed from smartphone sssid list.In my case only when I make a router reboot all ssid comes updating correctly.I think that there is a problem in some part of the firmare about wireless restart after a enable/remove guest network.Can you make a check?Thanks
ok, i'll give it a shot. i've got to read up on how to do these installs.
 

king006

Regular Contributor
Thank you! He works fine.
 

martywd

Occasional Visitor
My router: RT-AC88U -- Firmware: 384.3_beta1

Slight cosmetic issue on the 'Wireless|Site Survey' page in browsers: Pale Moon 27.7.2 and Firefox ESR 52.6 (both *nix 64-bit). Right side of 'Visible Networks' is slightly cut off with scroll bar at the bottom.

wireless_siteSurvey.jpg

.
 

drboss

Occasional Visitor
@RMerlin I now that You do very big work for as, but do You thinks to correct problems with dual WAN if second WAN is USB LTE modem?
After version 380.69_2 I have two problems (this version work fine) but in 382+ I receive Syslog message like: `0x12d1 product=0x1506' invalid for parameter `vendor'
1. the Huwai E3372 isn't in data, after start AC68 I need add the: insmod option vendor=0x12d1 product=0x1506, some time this work with service restart_wan
2. but they not work all the time, sometime I need do reset usb modem (by usbreset 12d1:1506, or at^reset, , but certain time they result of change mount point of second usb
3. many time when I go over inicialization of modem, they start work fine, but after few minut I have problem with routing (ex. chain FUPNP not found)
 
Status
Not open for further replies.

Similar threads

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top