[Beta] Asuswrt-Merlin 380.61 Beta is now available

  • ATTENTION! As of November 1, 2020, you are not able to reply to threads 6 months after the thread is opened if there are more than 500 posts in the thread.
    Threads will not be locked, so posts may still be edited by their authors.
    Just start a new thread on the topic to post if you get an error message when trying to reply to a thread.
Status
Not open for further replies.

xander73

Occasional Visitor
Possible bug, currently now testing with my new RT-AC88U with .61b1
USB Application > Network Place (Samba) Share:
Enable Share > On >> RT-AC88U does not appear in Windows 10 Network Computers.
However...
Force as Master Browser > Yes >> RT-AC88U does appear in Windows 10 Network Computers...
 
Last edited:

RMerlin

Asuswrt-Merlin dev
what does "dns probe" internet detect mean? i got this in syslog and then lost connection again and didn`t get back until router reboot....is this same as ppp echo internet detect?
Code:
Aug  2 17:14:39 WAN Connection: DNS probe failed (0/2)
Aug  2 17:14:46 WAN Connection: DNS probe failed (1/2)
Aug  2 17:14:53 WAN Connection: DNS probe failed (2/2)
Aug  2 17:14:53 WAN Connection: Fail to connect with some issues.
Aug  2 17:14:53 DualWAN: skip single wan wan_led_control - WANRED off

New WAN state detection code from Asus. Make sure you aren't blocking dns.msftncsi.com.
 

RMerlin

Asuswrt-Merlin dev
Possible bug, currently now testing with my new RT-AC88U with .61b1
USB Application > Network Place (Samba) Share:
Enable Share > On >> RT-AC88U does not appear in Windows 10 Network Computers.
However...
Force as Master Browser > Yes >> RT-AC88U does appear in Windows 10 Network Computers...

Works for me. This means there's a problem with whichever device on your LAN is serving as the master browser, or you aren't using the same workgroup.
 

PabloAbonia

Regular Contributor
Yes, sometimes there have been multiple copies of the RT-AC87U in Devices and Printers that are greyed out except usually for one. I usually highlight the greyed out ones, right click and select Remove this Device and remove all the greyed out ones. No change though. Router still "pings" the computer about every 5 seconds.

Thanks for your input......

There should only be one, with a single UUID. I think that was introduced in .59, as I have not seen this behavior before.

I don't what would lead to miniupnp/dlna to create brand new ids and wonder if that might be part of the problem in addition to the hard coded 5 minute checks noted in the other post.
 

R1-Limited

Regular Contributor
Upgraded from Alpha 2 Factory defaulted both RT-ac68u and RT-ac66u
Happy to say all is well even NTP sync no errors seen

Side note Post #42

RT-AC68U A1 Bug:

in Wireless - General - 5GHz setting: Control Channel = Auto, "Auto select channel including band1 channels" cannot be unchecked.

uncheck "Auto select channel including band1 channels" > apply > "Auto select channel including band1 channels" always back to checked.

I do not understand this as I can select anything I wish
 

R1-Limited

Regular Contributor
Just reporting as I never noticed before
Logs on the bot AP and Media bridge start with a proper date and time jump to jul 31 then to aug 2

Aug 2 17:53:44 kernel: usbcore: deregistering interface driver usblp
Jul 31 17:00:12 syslogd started: BusyBox v1.20.2
~
~
Jul 31 17:00:43 ntp: start NTP update
Aug 2 17:55:23 rc_service: ntp 219:notify_rc restart_diskmon
 

zenmota

Regular Contributor
There should only be one, with a single UUID. I think that was introduced in .59, as I have not seen this behavior before.

I don't what would lead to miniupnp/dlna to create brand new ids and wonder if that might be part of the problem in addition to the hard coded 5 minute checks noted in the other post.

I usually only get multiple ones (all greyed out except for one) when I reboot, power cycle or flash the router. And even then, I do not have the problem with version .59.

Thanks for your input...
 

RMerlin

Asuswrt-Merlin dev
Just reporting as I never noticed before
Logs on the bot AP and Media bridge start with a proper date and time jump to jul 31 then to aug 2

Aug 2 17:53:44 kernel: usbcore: deregistering interface driver usblp
Jul 31 17:00:12 syslogd started: BusyBox v1.20.2
~
~
Jul 31 17:00:43 ntp: start NTP update
Aug 2 17:55:23 rc_service: ntp 219:notify_rc restart_diskmon

The first two lines indicate your router just rebooted (syslogd start is the first thing that gets logged at boot time). Since the router has no battery backed up clock, it reverts back to July 31st. Then when it connects to the Internet and to an NTP server, it sets up the clock. This is all perfectly normal.
 

nik729

New Around Here
I was playing around with Smart Connect in both 380.59 and the latest beta 380.61 on my 88U and am unable to save any rule changes. The apply button does nothing while the default button reloads the page. Moving off the page nothing is ever saved or changed from the defaults. Is this a bug or something I am missing?
 

RMerlin

Asuswrt-Merlin dev
I took a look at the code, and the notify interval is a hardcoded option at 600 seconds in the conf file and hasn't changed forever.

I think the broadcast can also be sent in response to a query from a client...Have you started using a new DLNA client or did an OS upgrade recently?

I don't know what Asus are trying to do, but they actually hardcoded it to 3... seconds (!), bypassing the notify_interval value (which in the sample minidlna.conf, is set to 600 seconds).

https://github.com/RMerl/asuswrt-merlin/blob/master/release/src/router/minidlna/minidlna.c#L1196
https://github.com/RMerl/asuswrt-merlin/blob/master/release/src/router/minidlna/minidlna.c#L1336

I'm debating between just making it use the notify_interval variable (and have it default to a more sane value, like 600), or revert all of that code for the stock minidlna code (preserving only their custom icon code). I think part of what Asus are trying to do with their changes is rely on uptime() rather than timeofday, probably to avoid issues when the clock gets set by NTP. But frankly, this would be just a one-time hiccup at boot time, hardly enough to justify all the trouble they went through to make that change throughout minidlna.c.

(I'm already disabling their thumbnail cache that's there for AiCloud because I don't trust it.)
 

john9527

Part of the Furniture
I don't know what Asus are trying to do, but they actually hardcoded it to 3... seconds (!), bypassing the notify_interval value (which in the sample minidlna.conf, is set to 600 seconds).
It's actually built into the routers' minidlna.conf in usb.c, hardcoded to 600 sec (where I looked, silly me for not looking that they changed the base minidlna code :oops:). If someone wanted to change it, they could do it via a postconf if you revert that Asus change.
 

RMerlin

Asuswrt-Merlin dev
It's actually built into the routers' minidlna.conf in usb.c, hardcoded to 600 sec (where I looked, silly me for not looking that they changed the base minidlna code :oops:). If someone wanted to change it, they could do it via a postconf if you revert that Asus change.

I'm reverting that change, as well as all the instances were they replaced time() with uptime() for time-related checks, and a few other odd changes they did here and there. We'll see if it resolves some of those random issues some users have been reporting over the years.

So for now, 380.61 will use mostly the pristine 1.1.5 code + the db update patch from SF.net (Asus applied it) + the custom router icon code. I'll re-introduce the subprocess-related patches and the time/uptime patch if they appear to be necessary.
 

bayern1975

Very Senior Member
New WAN state detection code from Asus. Make sure you aren't blocking dns.msftncsi.com.
i have "msftncsi.com" in ab-solution adblocking file....is this same as "dns.msftncsi.com"?
 

ozzed

Regular Contributor
Short Story:
380.58 = Rock solid for 3 months before 380.59
380.59 = Clients list not always^populated and querying switch problem intermitant
380.60 beta= Wan Disconnect or Cable unplugged message
380.61 Alpha 1-2 = No issues , rock solid 9 days
380.61 Beta = The return of the infamous" Querying Switch" and the client list empty

Nothing have changed in my devices names since 1 year and there is no QUOTES in the names. o_O


Rick-Laptop
Rick-PC
WDTVLive
Rt-n66U
where are the Quotes in this?

I too have the "Querying Switch"- issue, on my 87u.
 

pietjepuk100

Regular Contributor
Up a little over 48 hours on this beta with my AC87U (Router) & AC68U (AP) and not a single glitch. Nothing worth mentioning in the syslogs.

Works great for me, thanks!
 

ViRUS2k

Regular Contributor
Just a update, firmware beta 1 finally flashed from alpha RT_AC88U

:)

had to do a hard reboot power off and back on instead of software rebooting lol that worked :)
 

bob bart

Occasional Visitor
Can we have a box that can be check regardless of policy rules that if the VPN goes down, the router can be killed (like a kill switch). I would like to see this box regardless if the redirect internet box is checked.

Right now to make sure of a kill switch, I set NAT to off. In case my VPN fails, the lack of Nat will kill the internet.

Policy rules dont work for me. I see too much DNS leaks as per my other comments.
 
Status
Not open for further replies.

Similar threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top